summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán2024-02-29 15:04:50 -0500
committerCarlos Aznarán2024-02-29 15:04:50 -0500
commit4f407ef7c1d78638ef2fbf0d7c8fd71ada9d9b20 (patch)
treeca061bdeb12a0e1714e52e1a53c55cd3e9badc7a
parentc42fc53a51b006caf064d884e8a46ac3ac46837e (diff)
downloadaur-4f407ef7c1d78638ef2fbf0d7c8fd71ada9d9b20.tar.gz
Bump version to 1.3.1
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD28
3 files changed, 25 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0c0f621f5568..77ffe91e0144 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,20 @@
pkgbase = python-downwards
pkgdesc = Read Wikipedia pages as manpages
pkgver = 1.3.1
- pkgrel = 1
- url = https://github.com/noqqe/downwards/
+ pkgrel = 2
+ url = https://github.com/noqqe/downwards
arch = any
license = MIT
- depends = python-unidecode
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-setuptools
+ makedepends = python-wheel
depends = python-click
depends = python-wikipedia
depends = python-wikitextparser
- depends = python-regex
- depends = python-wcwidth
depends = python-mako
- source = python-downwards-1.3.1.tar.gz::https://files.pythonhosted.org/packages/source/d/downwards/downwards-1.3.1.tar.gz
+ depends = python-unidecode
+ source = https://pypi.org/packages/source/d/downwards/downwards-1.3.1.tar.gz
sha512sums = 56762a54307950d76cf046d9f2f1a066733e685c632264f566368429c3d8311dc158232f053c9a65f9d75f04769e2302e91b81ee301cda5f0c52dcbc3bc6071f
pkgname = python-downwards
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
index a6a75becdfc6..e835d69c299e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,25 @@
-pkgname=python-downwards
-_name="${pkgname#python-}"
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: Moritz Kaspar Rudert (mortzu) <mortzu@riseup.net>
+_base=downwards
+pkgname=python-${_base}
pkgver=1.3.1
-pkgrel=1
+pkgrel=2
pkgdesc="Read Wikipedia pages as manpages"
-arch=('any')
-url="https://github.com/noqqe/downwards/"
-license=('MIT')
-depends=('python-unidecode' 'python-click' 'python-wikipedia' 'python-wikitextparser' 'python-regex' 'python-wcwidth' 'python-mako')
-source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+arch=(any)
+url="https://github.com/noqqe/${_base}"
+license=(MIT)
+depends=(python-click python-wikipedia python-wikitextparser python-mako python-unidecode)
+makedepends=(python-build python-installer python-setuptools python-wheel)
+source=(https://pypi.org/packages/source/${_base::1}/${_base}/${_base}-${pkgver}.tar.gz)
sha512sums=('56762a54307950d76cf046d9f2f1a066733e685c632264f566368429c3d8311dc158232f053c9a65f9d75f04769e2302e91b81ee301cda5f0c52dcbc3bc6071f')
build() {
- cd "$srcdir"/downwards-$pkgver
- python setup.py build
+ cd ${_base}-${pkgver}
+ python -m build --wheel --skip-dependency-check --no-isolation
}
package() {
- cd "$srcdir"/downwards-$pkgver
- python setup.py install --skip-build -O1 --root="$pkgdir"
+ cd ${_base}-${pkgver}
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}