summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Dimijian2020-12-30 00:35:18 -0500
committerDaniel Dimijian2020-12-30 00:35:18 -0500
commit4f5b453965135e46f877597b4ec304f47f5e227c (patch)
tree640479ab0389f1906aed316c84454bbf0cce7ea4
downloadaur-4f5b453965135e46f877597b4ec304f47f5e227c.tar.gz
init
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..782f001842fc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = godotpcktool
+ pkgdesc = A standalone executable for unpacking and packing Godot .pck files
+ pkgver = 1.4
+ pkgrel = 1
+ url = https://github.com/hhyyrylainen/GodotPckTool
+ arch = x86_64
+ license = MIT
+ makedepends = cmake
+ makedepends = cxxopts
+ makedepends = nlohmann-json
+ depends = glibc
+ source = godotpcktool-1.4.tar.gz::https://github.com/hhyyrylainen/GodotPckTool/archive/v1.4.tar.gz
+ sha256sums = 84d2264c3e0f89dbabf8707a90966610fc7c0c1e0bff8b278e81d71e26aa0121
+
+pkgname = godotpcktool
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aaff03cff5af
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Daniel Dimijian <jetfrog28@yahoo.com>
+_prjctname=GodotPckTool
+pkgname=godotpcktool
+pkgver=1.4
+pkgrel=1
+pkgdesc="A standalone executable for unpacking and packing Godot .pck files"
+arch=('x86_64')
+url="https://github.com/hhyyrylainen/GodotPckTool"
+license=('MIT')
+depends=('glibc')
+makedepends=('cmake' 'cxxopts' 'nlohmann-json')
+# source unsigned. git commits are signed, but I can't find the public key for the tagged commits
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('84d2264c3e0f89dbabf8707a90966610fc7c0c1e0bff8b278e81d71e26aa0121')
+
+build() {
+ cd "$_prjctname-$pkgver"
+
+ make install-local
+}
+
+package() {
+ cd "$_prjctname-$pkgver"
+
+ install -Dm755 "install/bin/godotpcktool" "$pkgdir/usr/bin/godotpcktool"
+ install -Dm644 "install/bin/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}