summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2021-07-27 13:52:45 +0200
committerAlexander F. Rødseth2021-07-27 13:52:45 +0200
commit4f615512bca9d058a793ea2308e730cb15131737 (patch)
tree4af7c0e82ac32bc95c25a2779d6abd4d4c10173c
parent8ff5182dee45b7fd122ea34ccf2db40303b582dd (diff)
downloadaur-4f615512bca9d058a793ea2308e730cb15131737.tar.gz
New release
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD18
2 files changed, 8 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index da7286fe8957..49d50a15bf64 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,13 @@
-# Generated by mksrcinfo v8
-# Wed Jun 5 13:24:14 UTC 2019
pkgbase = botsay
pkgdesc = Like cowsay, but with randomly generated ASCII robots and color support
- pkgver = 1.2.2
+ pkgver = 1.2.4
pkgrel = 1
url = https://github.com/xyproto/botsay
arch = x86_64
license = MIT
makedepends = git
makedepends = go
- source = git+https://github.com/xyproto/botsay#tag=v1.2.2
- md5sums = SKIP
+ source = git+https://github.com/xyproto/botsay#commit=3d80040f766ecab1a4e1cbf8b236b4171bd430bc
+ b2sums = SKIP
pkgname = botsay
-
diff --git a/PKGBUILD b/PKGBUILD
index 708df2563e75..445788ba001c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,23 @@
# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
pkgname=botsay
-pkgver=1.2.2
+pkgver=1.2.4
pkgrel=1
pkgdesc='Like cowsay, but with randomly generated ASCII robots and color support'
arch=(x86_64)
url='https://github.com/xyproto/botsay'
license=(MIT)
makedepends=(git go)
-source=("git+$url#tag=v$pkgver")
-md5sums=('SKIP')
+source=("git+$url#commit=3d80040f766ecab1a4e1cbf8b236b4171bd430bc") # tag: v1.2.4
+b2sums=(SKIP)
build() {
cd $pkgname
-
- go build \
- -asmflags "all=-trimpath=$PWD" \
- -buildmode=pie \
- -gcflags "all=-trimpath=$PWD" \
- -ldflags "-s -w -extldflags $LDFLAGS"
+ go build -v -mod=vendor -buildmode=pie -trimpath -ldflags="-s -w -extldflags \"${LDFLAGS}\""
}
package() {
cd "$pkgname"
-
- install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-
-# vim: ts=2 sw=2 et: