summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorДамјан Георгиевски2021-03-21 17:51:09 +0100
committerДамјан Георгиевски2021-03-21 17:52:51 +0100
commit4f620a664e03a2f10027c7f110ec6150dc45aea2 (patch)
tree5065b61a64f8e5a3a6be9d1c9baa770f9ca27e58
parented61d868e91a7fa430192d96a1aaf5d680268a5a (diff)
downloadaur-4f620a664e03a2f10027c7f110ec6150dc45aea2.tar.gz
bump to v0.3.3.r71
add makedepends to go-bindata-assetfs add a systemd system service, running as a DynamicUser=
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD12
-rw-r--r--olaris.service17
3 files changed, 28 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 72a7b39cd71d..38a2932dd50d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = olaris-git
pkgdesc = open-source, community driven, media manager and transcoding server
- pkgver = v0.3.2.r10.g6929193
+ pkgver = v0.3.3.r71.g022d7aa
pkgrel = 1
url = https://gitlab.com/olaris/olaris-server
arch = x86_64
@@ -8,6 +8,7 @@ pkgbase = olaris-git
makedepends = go
makedepends = git
makedepends = unzip
+ makedepends = go-bindata-assetfs
provides = olaris
conflicts = olaris
noextract = react-static.zip
@@ -15,9 +16,11 @@ pkgbase = olaris-git
source = olaris-server::git+https://gitlab.com/olaris/olaris-server.git
source = react-static.zip::https://gitlab.com/api/v4/projects/olaris%2Folaris-react/jobs/artifacts/develop/download?job=build
source = ffmpeg-build.zip::https://gitlab.com/api/v4/projects/olaris%2Fffmpeg/jobs/artifacts/master/download?job=compile
+ source = olaris.service
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = 2592546c3ac1ee3c7c7120edbfeecfe1053106a78bd5179c4a2077f3c764c871
pkgname = olaris-git
diff --git a/PKGBUILD b/PKGBUILD
index 2222a4889bfe..9f277472840c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Damjan Georgievski <gdamjan@gmail.com>
pkgname=olaris-git
_pkgname=olaris-server
-pkgver=v0.3.3.r47.g432918e
+pkgver=v0.3.3.r71.g022d7aa
pkgrel=1
pkgdesc='open-source, community driven, media manager and transcoding server'
arch=('x86_64')
@@ -12,9 +12,12 @@ conflicts=('olaris')
provides=('olaris')
source=("${_pkgname}::git+https://gitlab.com/olaris/olaris-server.git"
"react-static.zip::https://gitlab.com/api/v4/projects/olaris%2Folaris-react/jobs/artifacts/develop/download?job=build"
- "ffmpeg-build.zip::https://gitlab.com/api/v4/projects/olaris%2Fffmpeg/jobs/artifacts/master/download?job=compile")
+ "ffmpeg-build.zip::https://gitlab.com/api/v4/projects/olaris%2Fffmpeg/jobs/artifacts/master/download?job=compile"
+ "olaris.service"
+)
noextract=('react-static.zip' 'ffmpeg-build.zip')
-sha256sums=('SKIP' 'SKIP' 'SKIP')
+sha256sums=('SKIP' 'SKIP' 'SKIP'
+ '2592546c3ac1ee3c7c7120edbfeecfe1053106a78bd5179c4a2077f3c764c871')
pkgver() {
cd ${_pkgname}
@@ -33,8 +36,7 @@ build() {
ffmpeg-static/bin/ffmpeg ffmpeg-static/bin/ffprobe \
-d $FFMPEG_LOC
- make deps
- PATH=~/go/bin:/usr/bin make generate
+ make generate
make build-local
}
diff --git a/olaris.service b/olaris.service
new file mode 100644
index 000000000000..befa1036a837
--- /dev/null
+++ b/olaris.service
@@ -0,0 +1,17 @@
+# /etc/systemd/system/olaris.service
+[Unit]
+Description=Olaris Media Server
+
+[Service]
+Type=exec
+DynamicUser=yes
+CacheDirectory=olaris
+StateDirectory=olaris
+Environment=XDG_CACHE_HOME=/var/cache/olaris
+Environment=OLARIS_CONFIG_DIR=/var/lib/olaris
+WorkingDirectory=/var/lib/olaris
+ExecStart=/usr/bin/olaris
+Restart=on-failure
+
+[Install]
+WantedBy=multi-user.target