summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSchala2017-02-14 21:36:53 -0800
committerSchala2017-02-14 21:36:53 -0800
commit4f6d567c307220edf8586db6b9f0e1ae9566856f (patch)
tree1c0b0ac797159ca9011526b72d0a2db375b0c602
downloadaur-4f6d567c307220edf8586db6b9f0e1ae9566856f.tar.gz
init
-rw-r--r--.SRCINFO26
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD32
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..19a63ceea66d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+# Generated by mksrcinfo v8
+# Wed Feb 15 05:36:43 UTC 2017
+pkgbase = mingw-w64-fpc
+ pkgdesc = Cross FPC for the MinGW-w64 cross compiler
+ pkgver = 3.0.0
+ pkgrel = 1
+ url = http://www.freepascal.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = LGPL
+ license = MPL
+ makedepends = fpc
+ depends = ncurses
+ depends = expat
+ depends = zlib
+ depends = mingw-w64-binutils
+ options = staticlibs
+ options = !emptydirs
+ options = !strip
+ options = !buildflags
+ source = ftp://ftp.freepascal.org/pub/fpc/dist/3.0.0/source/fpcbuild-3.0.0.tar.gz
+ sha256sums = d5913b1d5d3d13190ae7ee72c305d5da49ac2ddc1b375b814751ef09ae5c80ec
+
+pkgname = mingw-w64-fpc
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..49c4674d6625
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg/
+src/
+*.gz
+*.log
+*.tar
+*.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..06f0ae70796e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+pkgname=mingw-w64-fpc
+pkgver=3.0.0
+pkgrel=1
+pkgdesc="Cross FPC for the MinGW-w64 cross compiler"
+arch=(i686 x86_64)
+url="http://www.freepascal.org/"
+license=("GPL" "LGPL" "MPL")
+makedepends=(fpc)
+depends=(ncurses expat zlib mingw-w64-binutils)
+options=(staticlibs !emptydirs !strip !buildflags)
+source=("ftp://ftp.freepascal.org/pub/fpc/dist/$pkgver/source/fpcbuild-$pkgver.tar.gz")
+sha256sums=('d5913b1d5d3d13190ae7ee72c305d5da49ac2ddc1b375b814751ef09ae5c80ec')
+
+build() {
+ cd "$srcdir"/fpcbuild-$pkgver
+ make NOGDB=1 all OS_TARGET=win32 CPU_TARGET=i386
+ make NOGDB=1 all OS_TARGET=win64 CPU_TARGET=x86_64
+}
+
+package() {
+ cd "$srcdir"/fpcbuild-$pkgver
+ make -j1 NOGDB=1 PREFIX="$pkgdir"/usr crossinstall OS_TARGET=win32 CPU_TARGET=i386
+ make -j1 NOGDB=1 PREFIX="$pkgdir"/usr crossinstall OS_TARGET=win64 CPU_TARGET=x86_64
+ rm -rf "$pkgdir"/usr/{doc,share/doc}
+ find "$pkgdir" -name '*.exe' -exec rm {} \;
+ strip "$pkgdir/usr/lib/fpc/$pkgver/ppcross386"
+ strip "$pkgdir/usr/lib/fpc/$pkgver/ppcrossx64"
+ find "$pkgdir/usr/lib/fpc/$pkgver/units/i386-win32" -name '*.a' -o -name '*.o' | xargs i686-w64-mingw32-strip -g
+ find "$pkgdir/usr/lib/fpc/$pkgver/units/x86_64-win64" -name '*.a' -o -name '*.o' | xargs x86_64-w64-mingw32-strip -g
+ ln -s /usr/lib/fpc/$pkgver/ppcross386 "$pkgdir"/usr/bin/ppcross386
+ ln -s /usr/lib/fpc/$pkgver/ppcrossx64 "$pkgdir"/usr/bin/ppcrossx64
+}