summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgspu2018-05-08 17:02:20 +0200
committergspu2018-05-08 17:02:20 +0200
commit4f9119118c51009f0eb8a34e179c8ab7a2d5ca90 (patch)
tree4e6db399423c1af9e1fc4c58eedcbaaa3696adf2
downloadaur-4f9119118c51009f0eb8a34e179c8ab7a2d5ca90.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f4cb29da8081
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = bitkeeper
+ pkgdesc = a fast, enterprise-ready, distributed SCM
+ pkgver = 7.3.2
+ pkgrel = 1
+ url = http://www.bitkeeper.org
+ arch = i686
+ arch = x86_64
+ license = Apache 2.0
+ depends = libxft
+ source_i686 = https://github.com/bitkeeper-scm/bitkeeper/releases/download/bk-7.3.2/bk-7.3.2-x86-glibc219-linux.bin
+ sha256sums_i686 = f327b28a5ffe34988a2c4f738d33f8ebe86e29043167dfdec096657ce4e19981
+ source_x86_64 = https://github.com/bitkeeper-scm/bitkeeper/releases/download/bk-7.3.2/bk-7.3.2-x86_64-glibc219-linux.bin
+ sha256sums_x86_64 = 7fe084cec862d297254793399a537344b054fd8efeb174d9cc6269f85c24b745
+
+pkgname = bitkeeper
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dacc60c3e2d6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: gspu <bssbk2455[at]gmail[dot]com>
+
+pkgname=bitkeeper
+pkgver=7.3.2
+pkgrel=1
+pkgdesc="a fast, enterprise-ready, distributed SCM"
+arch=("i686" "x86_64")
+license=("Apache 2.0")
+depends=("libxft")
+url="http://www.bitkeeper.org"
+
+source_i686=("https://github.com/bitkeeper-scm/bitkeeper/releases/download/bk-${pkgver}/bk-${pkgver}-x86-glibc219-linux.bin")
+source_x86_64=("https://github.com/bitkeeper-scm/bitkeeper/releases/download/bk-${pkgver}/bk-${pkgver}-x86_64-glibc219-linux.bin")
+
+sha256sums_i686=('f327b28a5ffe34988a2c4f738d33f8ebe86e29043167dfdec096657ce4e19981')
+sha256sums_x86_64=('7fe084cec862d297254793399a537344b054fd8efeb174d9cc6269f85c24b745')
+
+package() {
+ _arch=${CARCH}
+ if [ "${_arch}" == "i686" ]; then
+ _arch=x86
+ fi
+
+ chmod +x ${srcdir}/bk-${pkgver}-${_arch}-glibc219-linux.bin
+ ${srcdir}/bk-${pkgver}-${_arch}-glibc219-linux.bin ${pkgdir}/opt/bitkeeper
+
+ mkdir -p $pkgdir/usr/bin
+ ln -s /opt/bitkeeper/bk ${pkgdir}/usr/bin
+
+ chmod go-w -R ${pkgdir}/*
+}