summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFireBlackHat2019-09-18 16:45:24 +0430
committerFireBlackHat2019-09-18 16:45:24 +0430
commit4fa0f9022faab4bb814fadd163c5d88d6431a1ea (patch)
tree9aff8c95264a3bd328ce7863c7d1cae6e81c9157
downloadaur-4fa0f9022faab4bb814fadd163c5d88d6431a1ea.tar.gz
First Release
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8082ef6e6b44
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = pkgbase
+ pkgdesc = Fuse filesystem to read http(s) URL
+ pkgver = 1.5.0
+ pkgrel = 1
+ url = https://gitlab.com/BylonAkila/astreamfs
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = fuse
+ source = git+https://gitlab.com/BylonAkila/astreamfs.git
+ sha1sums = SKIP
+
+pkgname = astreamfs-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7cde849a1861
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Foxy <gmail: foxyblackhat@gmail.com>
+pkgbase=pkgbase
+pkgname=astreamfs-git
+pkgver=1.5.0
+pkgrel=1
+pkgdesc='Fuse filesystem to read http(s) URL'
+arch=(i686 x86_64)
+url='https://gitlab.com/BylonAkila/astreamfs'
+license=(GPL3)
+depends=('fuse')
+makedepends=('git')
+source=(git+https://gitlab.com/BylonAkila/astreamfs.git)
+sha1sums=('SKIP')
+
+pkgver() {
+ cd astreamfs
+ echo r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd astreamfs
+ make
+}
+
+package() {
+ cd astreamfs
+ install -Dm755 astreamfs "${pkgdir}/usr/bin/astreamfs"
+ install -Dm644 license "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}