summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIlya Basin2018-03-27 17:12:03 +0300
committerIlya Basin2018-03-27 17:12:03 +0300
commit4fab08b7c04afa9091e0d8ae91fed2c73fd5d970 (patch)
tree8625487a3bacd75581c59a346cefbfce2a915473
downloadaur-4fab08b7c04afa9091e0d8ae91fed2c73fd5d970.tar.gz
root
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD55
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e0c3770d892c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Tue Mar 27 14:11:56 UTC 2018
+pkgbase = aarch64-linux-gnu-expat
+ pkgdesc = An XML parser library
+ pkgver = 2.2.5
+ pkgrel = 1
+ url = https://libexpat.github.io/
+ arch = any
+ license = custom
+ depends = aarch64-linux-gnu-glibc
+ source = https://github.com/libexpat/libexpat/releases/download/R_2_2_5/expat-2.2.5.tar.bz2
+ sha256sums = d9dc32efba7e74f788fcc4f212a43216fc37cf5f23f4c2339664d473353aedf6
+
+pkgname = aarch64-linux-gnu-expat
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c7601292f016
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# $Id$
+# Contributor: Allan McRae <allan@archlinux.org>
+# Contributor: Judd Vinet <jvinet@zeroflux.org>
+
+_target=aarch64-linux-gnu
+_pkgname=expat
+pkgname=${_target}-expat
+pkgver=2.2.5
+pkgrel=1
+pkgdesc='An XML parser library'
+arch=('any')
+url='https://libexpat.github.io/'
+license=(custom)
+depends=(${_target}-glibc)
+source=(https://github.com/libexpat/libexpat/releases/download/R_${pkgver//./_}/$_pkgname-$pkgver.tar.bz2)
+sha256sums=('d9dc32efba7e74f788fcc4f212a43216fc37cf5f23f4c2339664d473353aedf6')
+
+build() {
+ cd $_pkgname-$pkgver
+ unset CFLAGS CXXFLAGS
+ ./configure --prefix=/usr/${_target} \
+ --host=${_target} \
+ --disable-static
+ make
+}
+
+strip() {
+ ${_target}-strip "$@"
+}
+
+objcopy() {
+ ${_target}-objcopy "$@"
+}
+
+check() {
+ local s readelfarch
+ readelfarch='AArch64'
+ cd $_pkgname-$pkgver
+
+ s=$(find . -type f "(" -name "*.so*" -o -name "*.a" ")" -print0 | \
+ 2>/dev/null LC_ALL=C xargs -0 readelf -h | \
+ sed -n -e '/File:/h;/Machine:/{/'"$readelfarch"'/!{H;x;p}}' | head -10)
+
+ if [ -n "$s" ]; then
+ >&2 echo "some binaries have wrong architecture:"
+ >&2 echo "$s"
+ return 1
+ fi
+}
+
+package() {
+ cd $_pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "-t$pkgdir/usr/${_target}/share/licenses/$_pkgname" COPYING
+}