summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruno Victal2015-06-09 16:24:41 +0800
committerBruno Victal2015-06-09 16:24:41 +0800
commit4fb6c8946b02d8b6a82277364438e509d07abcf7 (patch)
treea6f299de3f3efa6481de4d8bfaaabd59b121263d
downloadaur-4fb6c8946b02d8b6a82277364438e509d07abcf7.tar.gz
Import from AUR
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD32
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2a6ec1d4a77a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = mikmod
+ pkgdesc = A curses module player based on libmikmod
+ pkgver = 3.2.6
+ pkgrel = 1
+ url = http://mikmod.sourceforge.net
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libmikmod
+ depends = ncurses
+ source = http://downloads.sourceforge.net/project/mikmod/mikmod/3.2.6/mikmod-3.2.6.tar.gz
+ sha256sums = 04544e0edb36a19fab61233dff97430969cff378a98f5989a1378320550e2673
+
+pkgname = mikmod
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ce4af291ea10
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Bruno Victal <ubr47k at gmail dot com>
+# Contributor: Kaiting Chen <kaitocracy@gmail.com>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+# Contributor: hornetsnest0@gmail.com
+
+pkgname=mikmod
+pkgver=3.2.6
+pkgrel=1
+pkgdesc="A curses module player based on libmikmod"
+url="http://mikmod.sourceforge.net"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('libmikmod' 'ncurses')
+source=("http://downloads.sourceforge.net/project/mikmod/mikmod/${pkgver}/mikmod-${pkgver}.tar.gz")
+sha256sums=('04544e0edb36a19fab61233dff97430969cff378a98f5989a1378320550e2673')
+
+prepare() {
+ mkdir build
+}
+
+build() {
+ cd build
+ ../mikmod-${pkgver}/configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR=${pkgdir} install
+}