summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Boehlke2018-06-08 17:51:43 -0500
committerMatt Boehlke2018-06-08 17:51:43 -0500
commit4fb72e2c25f9ca0fb5eec224dc644e982f4b240a (patch)
tree84280c712c09ff63c65d2bb6337297b11c535591
downloadaur-4fb72e2c25f9ca0fb5eec224dc644e982f4b240a.tar.gz
Intial Commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
-rw-r--r--configure.patch18
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6473c489d737
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = rgbpaint
+ pkgdesc = Very simple pixel-based painting program
+ pkgver = 0.8.7
+ pkgrel = 1
+ url = http://mtpaint.sourceforge.net/rgbpaint.html
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = gtk2
+ source = https://sourceforge.net/projects/mtpaint/files/rgbpaint/0.8.7/rgbpaint-0.8.7.tar.bz2
+ source = configure.patch
+ sha256sums = 90741335ce887a0bb27e3c36d6013cfdbfb37dc4a38c3790b3b0a8cb9ef46994
+ sha256sums = 5679a40035c61be7ff99fd74ba08f6d8122e897379b8589cdf7438b4a56c2fc6
+
+pkgname = rgbpaint
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e8356a6cc90
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Matt Boehlke (mtboehlke <at> gmail <dot> com)
+pkgname=rgbpaint
+pkgver=0.8.7
+pkgrel=1
+pkgdesc="Very simple pixel-based painting program"
+arch=('i686' 'x86_64')
+url="http://mtpaint.sourceforge.net/rgbpaint.html"
+license=('GPL2')
+depends=('gtk2')
+source=("https://sourceforge.net/projects/mtpaint/files/$pkgname/$pkgver/$pkgname-$pkgver.tar.bz2"
+ 'configure.patch')
+sha256sums=('90741335ce887a0bb27e3c36d6013cfdbfb37dc4a38c3790b3b0a8cb9ef46994'
+ '5679a40035c61be7ff99fd74ba08f6d8122e897379b8589cdf7438b4a56c2fc6')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch -Nbp1 -i "$srcdir/configure.patch"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure cflags man intl \
+ --prefix="$pkgdir/usr" \
+ --mandir="$pkgdir/usr/share/man/man1"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make install
+ install -Dm644 README "$pkgdir/usr/share/doc/$pkgname/README"
+}
diff --git a/configure.patch b/configure.patch
new file mode 100644
index 000000000000..218cc20c6a76
--- /dev/null
+++ b/configure.patch
@@ -0,0 +1,18 @@
+diff --git a/configure b/configure
+index 6c469f3..2b014f7 100755
+--- a/configure
++++ b/configure
+@@ -1,3 +1,4 @@
++#!/bin/bash
+ # Mini configure script
+ # 1-10-2004
+
+@@ -148,6 +149,8 @@ else
+ BIN_INSTALL=$LIN_BIN_INSTALL
+ GTK_INCLUDE=`pkg-config gtk+-2.0 --cflags`
+ GTK_LIB=`pkg-config gtk+-2.0 --libs`
++ GTK_INCLUDE="$GTK_INCLUDE -I/usr/include/X11"
++ GTK_LIB="$GTK_LIB -lm -lX11"
+ else
+ BIN_INSTALL=$WIN_BIN_INSTALL
+ MT_LANG_DEST=locale