summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsolaraquarion2017-02-15 10:20:09 -0500
committersolaraquarion2017-02-15 10:20:09 -0500
commit4fba2b66387df5d7b65fba67a7526a9ec95e8c93 (patch)
tree0127fef7ba7b6737f806ad5b0100efcab6b69484
downloadaur-4fba2b66387df5d7b65fba67a7526a9ec95e8c93.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD26
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8461e63a832b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Wed Feb 15 15:19:56 UTC 2017
+pkgbase = python-whither
+ pkgdesc = Desktop application SDK for creating Universal Linux Applications.
+ pkgver = 0.2.5
+ pkgrel = 1
+ url = https://github.com/antergos/whither
+ arch = any
+ license = GPL
+ makedepends = python-setuptools
+ depends = python-pyqt5
+ depends = qt5-webengine
+ depends = python-ruamel-yaml
+ source = https://files.pythonhosted.org/packages/source/w/whither/whither-0.2.5.tar.gz
+ md5sums = 48bb8c3ea43df1eb47bc00a2e1ac196f
+
+pkgname = python-whither
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6966e382702a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Antergos Developers <dev@antergos.com>
+
+pkgname=python-whither
+_module="${pkgname#*-}"
+pkgver=0.2.5
+pkgrel=1
+pkgdesc='Desktop application SDK for creating Universal Linux Applications.'
+url="https://github.com/antergos/whither"
+depends=('python-pyqt5' 'qt5-webengine' 'python-ruamel-yaml')
+makedepends=('python-setuptools')
+license=('GPL')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/w/${_module}/${_module}-${pkgver}.tar.gz")
+md5sums=('48bb8c3ea43df1eb47bc00a2e1ac196f')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}
+
+# -*- mode: bash;-*-