summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfufik2016-04-21 06:49:32 +0000
committerfufik2016-04-21 06:49:32 +0000
commit4fbfdab6ce3d2ed0fb07df3da945174cb05ce9c6 (patch)
tree9332777e2e36525a35cebaf448b97d694f7d486e
downloadaur-4fbfdab6ce3d2ed0fb07df3da945174cb05ce9c6.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4b47362ca76a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = cpr-git
+ pkgdesc = C++ requests library by whoshuu
+ pkgver = 1.2
+ pkgrel = 1
+ url = https://github.com/whoshuu/cpr
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = cmake
+ depends = curl
+ source = cpr-1.2::git+https://github.com/whoshuu/cpr.git
+ md5sums = SKIP
+
+pkgname = cpr-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e53a913a4518
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Contributor: Penter ivaiva1999ivaiva@gmail.com
+pkgname=cpr-git
+_pkgname=cpr
+_pkgauthor=whoshuu
+pkgver=1.2
+pkgrel=1
+pkgdesc="C++ requests library by whoshuu"
+arch=('i686' 'x86_64')
+url="https://github.com/whoshuu/cpr"
+license=('MIT')
+depends=('curl')
+makedepends=('git' 'cmake')
+md5sums=('SKIP')
+source+=("${_pkgname}-${pkgver}::git+https://github.com/${_pkgauthor}/${_pkgname}.git")
+
+prepare (){
+ cd "$srcdir/$_pkgname-$pkgver"
+# mkdir build && cd build
+ cmake -DCPR_LIBRARY=/usr/lib CPR_INCLUDE_DIR=/usr/include -DINSECURE_CURL=ON -DBUILD_CPR_TESTS=OFF -DUSE_SYSTEM_CURL=ON .
+ make
+}
+
+package(){
+ cd "$srcdir/$_pkgname-$pkgver"
+ mkdir "$pkgdir/usr"
+ cp -R include "$pkgdir/usr"
+ cp -R lib "$pkgdir/usr"
+}