summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulioJu2016-05-22 17:25:58 +0200
committerJulioJu2016-05-22 17:25:58 +0200
commit4fc1b73b133030a59640a61f02c688891b5370fd (patch)
treec05e5b6fe901bfac1c73a1780d52c303594aee9d
downloadaur-4fc1b73b133030a59640a61f02c688891b5370fd.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2ece2555b473
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Sun May 22 15:18:07 UTC 2016
+pkgbase = uml_utilities
+ pkgdesc = User Mode Linux Utilities
+ pkgver = 20070815
+ pkgrel = 1
+ url = http://user-mode-linux.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = (L)GPL2
+ depends = fuse
+ depends = readline
+ source = http://user-mode-linux.sourceforge.net/uml_utilities_20070815.tar.bz2
+ md5sums = b0468ac8b79cef53f36f5f9517907462
+
+pkgname = uml_utilities
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4ed31822ef69
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer : JulioJu < juanes 0890 at google mail dot com >
+# Contributor: JulioJu < juanes 0890 at google mail dot com >
+
+pkgname=uml_utilities
+pkgver=20070815
+pkgrel=1
+pkgdesc="User Mode Linux Utilities"
+arch=(i686 x86_64)
+depends=('fuse' 'readline')
+provides=('')
+conflicts=('')
+url="http://user-mode-linux.sourceforge.net/"
+source=( "http://user-mode-linux.sourceforge.net/${pkgname}_${pkgver}.tar.bz2")
+license=('(L)GPL2')
+md5sums=('b0468ac8b79cef53f36f5f9517907462')
+
+prepare() {
+ cd "$srcdir/tools-$pkgver"
+ sed 's|lib64|lib|g' -i Makefile || return 3
+}
+
+build() {
+ cd "$srcdir/tools-$pkgver"
+ make
+}
+
+package() {
+ cd "$srcdir/tools-$pkgver"
+ make DESTDIR="$pkgdir" install
+ mv "$pkgdir/usr/sbin/"* "$pkgdir/usr/bin/" && rmdir "$pkgdir/usr/sbin/" || return 4
+ chown root "$pkgdir/usr/bin/"*
+}