summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorehs20132016-07-24 05:24:37 +0800
committerehs20132016-07-24 05:24:37 +0800
commit4fd5530a43a41610eaeac92ca36faf4e4797417c (patch)
tree94ed29320fa78b973f6b325a1d6fc7037f90f90e
downloadaur-4fd5530a43a41610eaeac92ca36faf4e4797417c.tar.gz
Initial commit
-rw-r--r--.SRCINFO37
-rw-r--r--PKGBUILD70
-rw-r--r--blacklist.conf55
-rw-r--r--linux-ruisu.install37
-rw-r--r--linux-ruisu.install.pkg37
-rw-r--r--linux-ruisu.preset14
6 files changed, 250 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cd9ed3ba62a8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,37 @@
+pkgbase = linux-ruisu
+ pkgver = 3.16.0_43
+ pkgrel = 1
+ url = http://www.kernel.org/
+ arch = x86_64
+ license = GPL2
+ makedepends = tar
+ noextract = linux-image-3.16.0-43-generic_3.16.0-43.58~14.04.1_amd64.deb
+ noextract = linux-image-extra-3.16.0-43-generic_3.16.0-43.58~14.04.1_amd64.deb
+ noextract = linux-headers-3.16.0-43-generic_3.16.0-43.58~14.04.1_amd64.deb
+ noextract = linux-ruisu.preset
+ noextract = blacklist.conf
+ options = !strip
+ source = https://mirrors.kernel.org/ubuntu/pool/main/l/linux-lts-utopic/linux-image-3.16.0-43-generic_3.16.0-43.58~14.04.1_amd64.deb
+ source = https://mirrors.kernel.org/ubuntu/pool/main/l/linux-lts-utopic/linux-image-extra-3.16.0-43-generic_3.16.0-43.58~14.04.1_amd64.deb
+ source = https://mirrors.kernel.org/ubuntu/pool/main/l/linux-lts-utopic/linux-headers-3.16.0-43-generic_3.16.0-43.58~14.04.1_amd64.deb
+ source = linux-ruisu.preset
+ source = blacklist.conf
+ md5sums = 952bd1c63fa0f220eaad7554adc842aa
+ md5sums = 9bab067d05b2805c7f61ff374640a710
+ md5sums = 9dca52bf9b319626e75587b45afbacab
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = linux-ruisu
+ pkgdesc = Linux kernel image for installing ServerSpeeder (a.k.a ruisu, using ZetaTCP technology)
+ install = linux-ruisu.install
+ depends = coreutils
+ depends = linux-firmware
+ depends = kmod
+ depends = mkinitcpio>=0.7
+ optdepends = crda: to set the correct wireless channels of your country
+
+pkgname = linux-ruisu-headers
+ pkgdesc = Header files and scripts for building modules for Linux-ruisu kernel
+ provides = linux-ubuntu-headers
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6c5366a9e40e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,70 @@
+# Original PKGBUILD: Timothy Redaelli <timothy.redaelli@gmail.com>
+# Maintainer: ehs2013
+
+pkgbase=linux-ruisu
+pkgver='3.16.0_43'
+pkgrel=1
+arch=('x86_64')
+url="http://www.kernel.org/"
+license=('GPL2')
+makedepends=(tar)
+options=(!strip)
+_ubuntu_ver='3.16.0-43-generic'
+_ubuntu_buildver='3.16.0-43.58~14.04.1'
+_mirror='https://mirrors.kernel.org/ubuntu'
+source=("${_mirror}/pool/main/l/linux-lts-utopic/linux-image-${_ubuntu_ver}_${_ubuntu_buildver}_amd64.deb"
+ "${_mirror}/pool/main/l/linux-lts-utopic/linux-image-extra-${_ubuntu_ver}_${_ubuntu_buildver}_amd64.deb"
+ "${_mirror}/pool/main/l/linux-lts-utopic/linux-headers-${_ubuntu_ver}_${_ubuntu_buildver}_amd64.deb"
+ "linux-ruisu.preset"
+ "blacklist.conf")
+md5sums=('952bd1c63fa0f220eaad7554adc842aa'
+ '9bab067d05b2805c7f61ff374640a710'
+ '9dca52bf9b319626e75587b45afbacab'
+ 'SKIP'
+ 'SKIP')
+noextract=("${source[@]##*/}")
+pkgname=("${pkgbase}" "${pkgbase}-headers")
+package_linux-ruisu() {
+ pkgdesc="Linux kernel image for installing ServerSpeeder (a.k.a ruisu, using ZetaTCP technology)"
+ depends=('coreutils' 'linux-firmware' 'kmod' 'mkinitcpio>=0.7')
+ optdepends=('crda: to set the correct wireless channels of your country')
+ install=linux-ruisu.install
+
+ for deb in linux-image-*.deb; do
+ ar p "$deb" data.tar.bz2 | tar -xjf - -C "$pkgdir/" --transform='s,^./lib,usr/lib,'
+ done
+
+ # remove useless files for Arch Linux
+ rm -f $pkgdir/boot/{System.map,abi,config}-${_ubuntu_ver}
+
+ # change kernel file name
+ mv "$pkgdir/boot/vmlinuz-${_ubuntu_ver}" "$pkgdir/boot/vmlinuz-$pkgname"
+ # remove useless Debian changelog and license
+ rm -rf "$pkgdir/usr/share"
+
+ # set correct depmod command for install
+ cp -f "${startdir}/${install}" "${startdir}/${install}.pkg"
+ true && install=${install}.pkg
+ sed \
+ -e "s/KERNEL_NAME=.*/KERNEL_NAME=${pkgname#linux}/" \
+ -e "s/KERNEL_VERSION=.*/KERNEL_VERSION=${_ubuntu_ver}/" \
+ -i "${startdir}/${install}"
+
+ # install mkinitcpio preset file for kernel
+ install -D -m644 "${srcdir}/${pkgname}.preset" "${pkgdir}/etc/mkinitcpio.d/${pkgname}.preset"
+
+ # install modprobe.d blacklist file (taked from kmod_22-1.1ubuntu1.debian.tar.xz)
+ install -D -m644 "${srcdir}/blacklist.conf" "${pkgdir}/etc/modprobe.d/ubuntu-blacklist.conf"
+}
+
+package_linux-ruisu-headers() {
+ pkgdesc="Header files and scripts for building modules for ${pkgbase/linux/Linux} kernel"
+ provides=(linux-ubuntu-headers)
+
+ for x in linux-headers-*.deb; do
+ ar p "$x" data.tar.xz | tar -xJf - -C "$pkgdir/" --transform='s,^./lib,usr/lib,'
+ done
+
+ # remove useless Debian changelog and license
+ rm -rf "$pkgdir/usr/share"
+}
diff --git a/blacklist.conf b/blacklist.conf
new file mode 100644
index 000000000000..08b38541bf4b
--- /dev/null
+++ b/blacklist.conf
@@ -0,0 +1,55 @@
+# This file lists those modules which we don't want to be loaded by
+# alias expansion, usually so some other driver will be loaded for the
+# device instead.
+
+# evbug is a debug tool that should be loaded explicitly
+blacklist evbug
+
+# these drivers are very simple, the HID drivers are usually preferred
+blacklist usbmouse
+blacklist usbkbd
+
+# replaced by e100
+blacklist eepro100
+
+# replaced by tulip
+blacklist de4x5
+
+# causes no end of confusion by creating unexpected network interfaces
+blacklist eth1394
+
+# snd_intel8x0m can interfere with snd_intel8x0, doesn't seem to support much
+# hardware on its own (Ubuntu bug #2011, #6810)
+blacklist snd_intel8x0m
+
+# Conflicts with dvb driver (which is better for handling this device)
+blacklist snd_aw2
+
+# causes failure to suspend on HP compaq nc6000 (Ubuntu: #10306)
+blacklist i2c_i801
+
+# replaced by p54pci
+blacklist prism54
+
+# replaced by b43 and ssb.
+blacklist bcm43xx
+
+# most apps now use garmin usb driver directly (Ubuntu: #114565)
+blacklist garmin_gps
+
+# replaced by asus-laptop (Ubuntu: #184721)
+blacklist asus_acpi
+
+# low-quality, just noise when being used for sound playback, causes
+# hangs at desktop session start (Ubuntu: #246969)
+blacklist snd_pcsp
+
+# ugly and loud noise, getting on everyone's nerves; this should be done by a
+# nice pulseaudio bing (Ubuntu: #77010)
+blacklist pcspkr
+
+# EDAC driver for amd76x clashes with the agp driver preventing the aperture
+# from being initialised (Ubuntu: #297750). Blacklist so that the driver
+# continues to build and is installable for the few cases where its
+# really needed.
+blacklist amd76x_edac
diff --git a/linux-ruisu.install b/linux-ruisu.install
new file mode 100644
index 000000000000..dd2fa5c7aac5
--- /dev/null
+++ b/linux-ruisu.install
@@ -0,0 +1,37 @@
+# arg 1: the new package version
+# arg 2: the old package version
+
+KERNEL_NAME=
+KERNEL_VERSION=
+
+post_install () {
+ # updating module dependencies
+ echo ">>> Updating module dependencies. Please wait ..."
+ depmod ${KERNEL_VERSION}
+ echo ">>> Generating initial ramdisk, using mkinitcpio. Please wait..."
+ mkinitcpio -p linux${KERNEL_NAME}
+}
+
+post_upgrade() {
+ if findmnt --fstab -uno SOURCE /boot &>/dev/null && ! mountpoint -q /boot; then
+ echo "WARNING: /boot appears to be a separate partition but is not mounted."
+ fi
+
+ # updating module dependencies
+ echo ">>> Updating module dependencies. Please wait ..."
+ depmod ${KERNEL_VERSION}
+ echo ">>> Generating initial ramdisk, using mkinitcpio. Please wait..."
+ mkinitcpio -p linux${KERNEL_NAME}
+
+ if [ $(vercmp $2 3.13) -lt 0 ]; then
+ echo ">>> WARNING: AT keyboard support is no longer built into the kernel."
+ echo ">>> In order to use your keyboard during early init, you MUST"
+ echo ">>> include the 'keyboard' hook in your mkinitcpio.conf."
+ fi
+}
+
+post_remove() {
+ # also remove the compat symlinks
+ rm -f boot/initramfs-linux${KERNEL_NAME}.img
+ rm -f boot/initramfs-linux${KERNEL_NAME}-fallback.img
+}
diff --git a/linux-ruisu.install.pkg b/linux-ruisu.install.pkg
new file mode 100644
index 000000000000..4c9c7ff716de
--- /dev/null
+++ b/linux-ruisu.install.pkg
@@ -0,0 +1,37 @@
+# arg 1: the new package version
+# arg 2: the old package version
+
+KERNEL_NAME=-ruisu
+KERNEL_VERSION=3.16.0-43-generic
+
+post_install () {
+ # updating module dependencies
+ echo ">>> Updating module dependencies. Please wait ..."
+ depmod ${KERNEL_VERSION}
+ echo ">>> Generating initial ramdisk, using mkinitcpio. Please wait..."
+ mkinitcpio -p linux${KERNEL_NAME}
+}
+
+post_upgrade() {
+ if findmnt --fstab -uno SOURCE /boot &>/dev/null && ! mountpoint -q /boot; then
+ echo "WARNING: /boot appears to be a separate partition but is not mounted."
+ fi
+
+ # updating module dependencies
+ echo ">>> Updating module dependencies. Please wait ..."
+ depmod ${KERNEL_VERSION}
+ echo ">>> Generating initial ramdisk, using mkinitcpio. Please wait..."
+ mkinitcpio -p linux${KERNEL_NAME}
+
+ if [ $(vercmp $2 3.13) -lt 0 ]; then
+ echo ">>> WARNING: AT keyboard support is no longer built into the kernel."
+ echo ">>> In order to use your keyboard during early init, you MUST"
+ echo ">>> include the 'keyboard' hook in your mkinitcpio.conf."
+ fi
+}
+
+post_remove() {
+ # also remove the compat symlinks
+ rm -f boot/initramfs-linux${KERNEL_NAME}.img
+ rm -f boot/initramfs-linux${KERNEL_NAME}-fallback.img
+}
diff --git a/linux-ruisu.preset b/linux-ruisu.preset
new file mode 100644
index 000000000000..1fe4774b10c4
--- /dev/null
+++ b/linux-ruisu.preset
@@ -0,0 +1,14 @@
+# mkinitcpio preset file for the 'linux-ruisu' package
+
+ALL_config="/etc/mkinitcpio.conf"
+ALL_kver="/boot/vmlinuz-linux-ruisu"
+
+PRESETS=('default' 'fallback')
+
+#default_config="/etc/mkinitcpio.conf"
+default_image="/boot/initramfs-linux-ruisu.img"
+#default_options=""
+
+#fallback_config="/etc/mkinitcpio.conf"
+fallback_image="/boot/initramfs-linux-ruisu-fallback.img"
+fallback_options="-S autodetect"