summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-12-25 22:58:19 -0600
committerLuis Martinez2021-12-25 22:58:19 -0600
commit4fd8b879b8c3d7d216496aa5ac76b54806558e52 (patch)
treea9afe01ba168a3bea78bd277efa78e92e0e8d8bd
parent3096d975e8f1b1be00daa4747fc526f2a6dc00fe (diff)
downloadaur-4fd8b879b8c3d7d216496aa5ac76b54806558e52.tar.gz
update to 2.1.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD34
2 files changed, 15 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 76ce92cfea63..e9673f7c8d3a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,11 @@
pkgbase = nordic-theme
- pkgdesc = Nordic is a Gtk3.20+ theme created using the awesome Nord color pallete.
- pkgver = 2.0.0
+ pkgdesc = GTK theme using the Nord color palette
+ pkgver = 2.1.0
pkgrel = 1
url = https://github.com/EliverLara/Nordic
- arch = i686
- arch = x86_64
+ arch = any
license = GPL3
- source = https://github.com/EliverLara/Nordic/releases/download/2.0.0/Nordic.tar.xz
- sha256sums = c6c75f9474568c2b7a0067490d6a76427b9c2ff9fc6963dd3878efa9c4a24543
+ source = nordic-theme-2.1.0.tar.xz::https://github.com/EliverLara/Nordic/releases/download/v2.1.0/Nordic.tar.xz
+ sha256sums = cce429254c31473571963b5125e8fb652ce517bbec5245b1e17fe975b9bfd10b
pkgname = nordic-theme
diff --git a/PKGBUILD b/PKGBUILD
index 26cbf15fde75..cb7a70737e66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,18 @@
# Maintainer: hamki <hamki.do2000@gmail.com>
+# Contributor: Luis Martinez <luis dot martinez at disroot dot org>
+
pkgname=nordic-theme
-_pkgname=Nordic
-pkgver=2.0.0
+pkgver=2.1.0
pkgrel=1
-epoch=
-pkgdesc="Nordic is a Gtk3.20+ theme created using the awesome Nord color pallete."
-arch=('i686' 'x86_64')
+pkgdesc="GTK theme using the Nord color palette"
+arch=('any')
url="https://github.com/EliverLara/Nordic"
license=('GPL3')
-groups=()
-depends=()
-makedepends=()
-checkdepends=()
-optdepends=()
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
-install=
-changelog=
-source=("https://github.com/EliverLara/Nordic/releases/download/$pkgver/$_pkgname.tar.xz"
-)
-noextract=()
-sha256sums=(c6c75f9474568c2b7a0067490d6a76427b9c2ff9fc6963dd3878efa9c4a24543)
+source=("$pkgname-$pkgver.tar.xz::$url/releases/download/v$pkgver/Nordic.tar.xz")
+sha256sums=('cce429254c31473571963b5125e8fb652ce517bbec5245b1e17fe975b9bfd10b')
package() {
- cd "${_pkgname}"
- mkdir -p "${pkgdir}/usr/share/themes/$_pkgname"
- cp -a "${srcdir}/${_pkgname}/"* "${pkgdir}/usr/share/themes/${_pkgname}/"
+ cd Nordic
+ find assets cinnamon gnome-shell gtk-* metacity-1 xfwm4 index.theme \
+ -type f -exec install -Dm 644 '{}' "$pkgdir/usr/share/themes/Nordic/{}" \;
}