summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart De Vries2023-02-05 14:27:28 +0100
committerBart De Vries2023-02-05 18:25:32 +0100
commit4fe1422693d24b7ec87b4aeab23b68179be32b75 (patch)
tree43f846f028de6eba9cbea54d68bb6b6ff5422f0e
parent28b0482f215ab33eb3d65a3153f7a17d2f7a2ce9 (diff)
downloadaur-4fe1422693d24b7ec87b4aeab23b68179be32b75.tar.gz
Update to upstream version 0.27.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD19
-rw-r--r--gcc11-fix.patch10
-rw-r--r--snapcast.install18
4 files changed, 30 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d958ddb7d5e3..da4768673871 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = snapcast
pkgdesc = Synchronous multi-room audio player
- pkgver = 0.26.0
- pkgrel = 2
+ pkgver = 0.27.0
+ pkgrel = 1
url = https://github.com/badaix/snapcast
install = snapcast.install
arch = x86_64
@@ -23,13 +23,15 @@ pkgbase = snapcast
backup = etc/default/snapserver
backup = etc/default/snapclient
backup = etc/snapserver.conf
- source = snapcast-0.26.0.tar.gz::https://github.com/badaix/snapcast/archive/v0.26.0.tar.gz
+ source = snapcast-0.27.0.tar.gz::https://github.com/badaix/snapcast/archive/v0.27.0.tar.gz
+ source = snapos-0.27.0.tar.gz::https://github.com/badaix/snapos/archive/v0.27.0.tar.gz
source = snapcast.sysusers
source = snapcast.tmpfiles
source = snapcast.install
- sha256sums = 166353267a5c461a3a0e7cbd05d78c4bfdaebeda078801df3b76820b54f27683
+ sha256sums = c662c6eafbaa42a4797a4ed6ba4a7602332abf99f6ba6ea88ff8ae59978a86ba
+ sha256sums = 5f4f59dd6f39059c22687b29231e2c007a7d0ea0f920af6092f18eeba9a5e208
sha256sums = 9fe6e9e07adb77f555a617b772e6d01e098e1dfaad1e8075e03a7d7ba76141de
sha256sums = e8c3441c4ca646a9b66d61355e90862fd3481562ae3b4e0a4bc1c978464ae2c7
- sha256sums = 98cfdc3221270e3243f7dd0ca32f8c4b271258f32fc04fdb52a286f0986d7350
+ sha256sums = 87945989ce215c3720e12e9d53642d7b1112f8276cd02d999fd7e27517aea126
pkgname = snapcast
diff --git a/PKGBUILD b/PKGBUILD
index 6eb3d4216154..39eb6ba369ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: Bart De Vries <bart at mogwai dot be>
pkgname=snapcast
-pkgver=0.26.0
-pkgrel=2
+_pkgname_snapos=snapos
+pkgver=0.27.0
+pkgrel=1
pkgdesc="Synchronous multi-room audio player"
arch=('x86_64' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/badaix/snapcast"
@@ -12,13 +13,15 @@ makedepends=(cmake alsa-utils boost)
install="snapcast.install"
backup=('etc/default/snapserver' 'etc/default/snapclient' 'etc/snapserver.conf')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/badaix/snapcast/archive/v${pkgver}.tar.gz"
+ "snapos-${pkgver}.tar.gz::https://github.com/badaix/snapos/archive/v${pkgver}.tar.gz"
"snapcast.sysusers"
"snapcast.tmpfiles"
"snapcast.install")
-sha256sums=('166353267a5c461a3a0e7cbd05d78c4bfdaebeda078801df3b76820b54f27683'
+sha256sums=('c662c6eafbaa42a4797a4ed6ba4a7602332abf99f6ba6ea88ff8ae59978a86ba'
+ '5f4f59dd6f39059c22687b29231e2c007a7d0ea0f920af6092f18eeba9a5e208'
'9fe6e9e07adb77f555a617b772e6d01e098e1dfaad1e8075e03a7d7ba76141de'
'e8c3441c4ca646a9b66d61355e90862fd3481562ae3b4e0a4bc1c978464ae2c7'
- '98cfdc3221270e3243f7dd0ca32f8c4b271258f32fc04fdb52a286f0986d7350')
+ '87945989ce215c3720e12e9d53642d7b1112f8276cd02d999fd7e27517aea126')
build() {
cd "${pkgname}-${pkgver}"
@@ -46,10 +49,10 @@ package() {
install -Dm755 bin/snapclient "${pkgdir}/usr/bin/snapclient"
install -Dm644 client/snapclient.1 "${pkgdir}/usr/share/man/man1/snapclient.1"
- install -Dm644 debian/snapserver.service "${pkgdir}/usr/lib/systemd/system/snapserver.service"
- install -Dm644 debian/snapserver.default "${pkgdir}/etc/default/snapserver"
- install -Dm644 debian/snapclient.service "${pkgdir}/usr/lib/systemd/system/snapclient.service"
- install -Dm644 debian/snapclient.default "${pkgdir}/etc/default/snapclient"
+ install -Dm644 ${srcdir}/${_pkgname_snapos}-${pkgver}/debian/snapserver.service "${pkgdir}/usr/lib/systemd/system/snapserver.service"
+ install -Dm644 ${srcdir}/${_pkgname_snapos}-${pkgver}/debian/snapserver.default "${pkgdir}/etc/default/snapserver"
+ install -Dm644 ${srcdir}/${_pkgname_snapos}-${pkgver}/debian/snapclient.service "${pkgdir}/usr/lib/systemd/system/snapclient.service"
+ install -Dm644 ${srcdir}/${_pkgname_snapos}-${pkgver}/debian/snapclient.default "${pkgdir}/etc/default/snapclient"
install -Dm644 "${srcdir}/snapcast.sysusers" "${pkgdir}/usr/lib/sysusers.d/snapclient.conf"
install -Dm644 "${srcdir}/snapcast.tmpfiles" "${pkgdir}/usr/lib/tmpfiles.d/snapclient.conf"
diff --git a/gcc11-fix.patch b/gcc11-fix.patch
deleted file mode 100644
index e9c9390f0590..000000000000
--- a/gcc11-fix.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- snapcast-0.25.0/common/message/message.hpp 2021-05-15 13:16:03.000000000 +0200
-+++ snapcast-0.25.0b/common/message/message.hpp 2021-05-16 16:15:34.243593726 +0200
-@@ -29,6 +29,7 @@
- #include <sys/time.h>
- #endif
- #include <vector>
-+#include <memory>
-
- /*
- template<typename CharT, typename TraitsT = std::char_traits<CharT> >
diff --git a/snapcast.install b/snapcast.install
index 769d7a801c74..f3c0c8c453e7 100644
--- a/snapcast.install
+++ b/snapcast.install
@@ -4,8 +4,11 @@ post_install() {
echo ":: The default setup will create a pipe /tmp/snapfifo."
echo " Due to recent changes in systemd, pipes in /tmp are by default only"
echo " writable by the owning user (here: sysuser snapserver)."
- echo " This is controlled by systclt fs.protected_fifos."
- echo " A possible workaround is to disable the sysctl feature by running:"
+ echo " The safest option is to change the location of the fifo to a"
+ echo " different location, e.g. /run/snapserver. This can be done by"
+ echo " editing /etc/snapserver.conf"
+ echo " Another possible workaround is to disable the sysctl feature by"
+ echo " running:"
echo " # sysctl fs.protected_fifos=0"
echo ":: Snapcast now has a built-in snapweb control client which is enabled"
echo " by default on a new setup. This functionality enables a webserver"
@@ -17,17 +20,20 @@ post_upgrade() {
echo ":: The default setup will create a pipe /tmp/snapfifo."
echo " Due to recent changes in systemd, pipes in /tmp are by default only"
echo " writable by the owning user (here: sysuser snapserver)."
- echo " This is controlled by systclt fs.protected_fifos."
- echo " A possible workaround is to disable the sysctl feature by running:"
+ echo " The safest option is to change the location of the fifo to a"
+ echo " different location, e.g. /run/snapserver. This can be done by"
+ echo " editing /etc/snapserver.conf"
+ echo " Another possible workaround is to disable the sysctl feature by"
+ echo " running:"
echo " # sysctl fs.protected_fifos=0"
echo ":: Snapcast now has a built-in snapweb control client which is enabled"
echo " by default on a new setup. This functionality enables a webserver"
- echo " on port 1780. This can be controlled by the doc_root variable in"
+ echo " on port 1780. This can be controlled by the doc_root variable in"
echo " /etc/snapserver.conf."
# return if old package version greater 10.4...
(( $(vercmp $2 '0.15.0') > 0 )) && return
-
+
echo ":: The snapserver configuration layout has changed!"
echo " -> Most of the configuration has moved from /etc/default/snapserver"
echo " to /etc/snapserver.conf."