summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLev Levitsky2023-04-20 17:51:22 +0200
committerLev Levitsky2023-04-20 17:51:22 +0200
commit4fe58ea6d6d0cf84e4480488a5232c0b4a482fac (patch)
treeb24dcc89178b8470d4284af4ac1454683fd1fc41
parentaf6681eaee1f779c8319749d6b9d4fcd9501ec96 (diff)
downloadaur-4fe58ea6d6d0cf84e4480488a5232c0b4a482fac.tar.gz
Version 4.6
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG29
-rw-r--r--PKGBUILD4
3 files changed, 34 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ada2c89254fc..533575546f7f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-pyteomics
pkgdesc = A framework for proteomics data analysis.
- pkgver = 4.5.6
+ pkgver = 4.6
pkgrel = 1
url = https://pyteomics.readthedocs.io
changelog = CHANGELOG
@@ -16,7 +16,7 @@ pkgbase = python-pyteomics
optdepends = python-dill: needed for multiprocessing when pickle is not enough
optdepends = python-pynumpress: for Numpress support
options = !emptydirs
- source = https://pypi.debian.net/pyteomics/pyteomics-4.5.6-py2.py3-none-any.whl
- sha256sums = 0e279c085370e8085c84997adb8f9e16425facf2d088ba80f2b7e6bcb59cfebe
+ source = https://pypi.debian.net/pyteomics/pyteomics-4.6-py2.py3-none-any.whl
+ sha256sums = 95fea3ca8c8700d6113e85bf20e627acecdd892821fcc6559d16e18235e631dc
pkgname = python-pyteomics
diff --git a/CHANGELOG b/CHANGELOG
index b9483672c03b..bdb0730ab1b2 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,3 +1,32 @@
+4.6
+---
+
+ - When passing an existing file (by name) to :py:func:`pyteomics.mgf.write` or :py:func:`pyteomics.fasta.write` and
+ other writing functions, **the file will be opened for writing by default**. Previously, it would be opened for
+ appending with a warning about the upcoming change. Please be aware that existing files will be overwritten
+ if passed by name. The rationale for this is better reproducibility if the same code is run multiple
+ times. You can use the `file_mode` argument of the writing functions to override this behaviour, or pass your own
+ file objects.
+ - Add a special warning when trying to write a single spectrum with :py:func:`pyteomics.mgf.write`.
+ See also: `Writing one or more MGF spectra to a file <https://github.com/levitsky/pyteomics/discussions/109>`_.
+ - In :py:func:`pyteomics.mass.mass.calculate_mass`, the `absolute` parameter is now `True` by default.
+ When calculating *m/z* for negative charges, the returned value will be positive by default.
+ - Fix issue #98 (`#99 <https://github.com/levitsky/pyteomics/pull/99>`_ and
+ `#101 <https://github.com/levitsky/pyteomics/pull/101>`_ by Joshua Klein).
+ - Fix issue #91 (`#92 <https://github.com/levitsky/pyteomics/pull/92>`_ by Joshua Klein).
+ - Fix issue #96.
+ - Update the UniProt header pattern (fix rare parsing errors with
+ :py:class:`pyteomics.fasta.UniProt` and :py:class:`pyteomics.fasta.IndexedUniProt`) in
+ `#93 <https://github.com/levitsky/pyteomics/pull/93>`_.
+ - Update the UniRef header pattern (fix parsing errors with
+ :py:class:`pyteomics.fasta.UniRef` and :py:class:`pyteomics.fasta.IndexedUniRef`) in
+ `#102 <https://github.com/levitsky/pyteomics/pull/102>`_. Some keys are removed from the output.
+ - Fix pickling issues with :py:class:`pyteomics.mgf.IndexedMGF`, :py:class:`pyteomics.ms1.IndexedMS1`,
+ :py:class:`pyteomics.ms2.IndexedMS2` (#108).
+ - Add "charge array" and "resolution array" to the output of MS2 parsers (#108). Add new arguments `read_charges`
+ and `read_resolutions` to disable parsing, and `convert_arrays` to govern the creation of NumPy arrays
+ (and masked arrays).
+
4.5.6
-----
diff --git a/PKGBUILD b/PKGBUILD
index 51570bc1109f..50745bfa1ac6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Lev Levitsky <levlev at mail dot ru>
pkgname=python-pyteomics
-pkgver=4.5.6
+pkgver=4.6
pkgrel=1
pkgdesc="A framework for proteomics data analysis."
arch=('any')
@@ -16,7 +16,7 @@ optdepends=('python-matplotlib: for pylab_aux module'
'python-pynumpress: for Numpress support')
options=(!emptydirs)
source=("https://pypi.debian.net/pyteomics/pyteomics-${pkgver}-py2.py3-none-any.whl")
-sha256sums=('0e279c085370e8085c84997adb8f9e16425facf2d088ba80f2b7e6bcb59cfebe')
+sha256sums=('95fea3ca8c8700d6113e85bf20e627acecdd892821fcc6559d16e18235e631dc')
changelog=CHANGELOG
package() {