summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxdavidwu2022-08-12 14:12:38 +0800
committerxdavidwu2022-08-12 14:12:38 +0800
commit4ff3a04ea53267ba6bd80bb9edea646d4a916e4b (patch)
tree39f27456152bdebd247a993bcebd4fad60ab6fde
parent47636675da7814ee6fa1d5a7ab2b18692a7fc3a2 (diff)
downloadaur-4ff3a04ea53267ba6bd80bb9edea646d4a916e4b.tar.gz
18.0.2b9_openj9_0.33.0-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0fcbfb5abbd5..52021796c2e2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = jdk-openj9-bin
pkgdesc = Eclipse (former IBM) OpenJ9 with openjdk18
- pkgver = 18.0.1.1b2_openj9_0.32.0
+ pkgver = 18.0.2b9_openj9_0.33.0
pkgrel = 1
url = https://developer.ibm.com/languages/java/semeru-runtimes/downloads
arch = x86_64
@@ -17,7 +17,7 @@ pkgbase = jdk-openj9-bin
conflicts = jdk18-openj9-bin
conflicts = jdk18-openj9
options = !strip
- source = https://github.com/ibmruntimes/semeru18-binaries/releases/download/jdk-18.0.1.1%2B2_openj9-0.32.0/ibm-semeru-open-jdk_x64_linux_18.0.1.1_2_openj9-0.32.0.tar.gz
- sha256sums = 708d7d7b5ac3c793f7fa9b045024276b54f973dcb833cccc0be697261884db4a
+ source = https://github.com/ibmruntimes/semeru18-binaries/releases/download/jdk-18.0.2%2B9_openj9-0.33.0/ibm-semeru-open-jdk_x64_linux_18.0.2_9_openj9-0.33.0.tar.gz
+ sha256sums = 48a7ea9b5043e5476b63d3b77b3bf01d71fd7fb53dd76db13865ce8bf8d4c09f
pkgname = jdk-openj9-bin
diff --git a/PKGBUILD b/PKGBUILD
index 2d1ac3a57659..1f3809af42f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,11 +9,11 @@
pkgname=jdk-openj9-bin
_jdkver=18
_jdkminor=0
-_jdkpatch=1
-_jdksubpatch=1
-_jdkfullver=${_jdkver}.${_jdkminor}.${_jdkpatch}.${_jdksubpatch}
-_openj9ver=0.32.0
-_buildvershort=2
+_jdkpatch=2
+_jdksubpatch=0
+_jdkfullver=${_jdkver}.${_jdkminor}.${_jdkpatch} #.${_jdksubpatch}
+_openj9ver=0.33.0
+_buildvershort=9
_buildver=${_buildvershort}_openj9-${_openj9ver}
pkgver=${_jdkfullver}b${_buildver//-/_}
pkgrel=1
@@ -34,7 +34,7 @@ conflicts=("jdk${_jdkver}-openj9-bin" "jdk${_jdkver}-openj9")
options=(!strip)
source=("https://github.com/ibmruntimes/semeru${_jdkver}-binaries/releases/download/jdk-${_jdkfullver}%2B${_buildver}/ibm-semeru-open-jdk_x64_linux_${_jdkfullver}_${_buildver}.tar.gz")
-sha256sums=('708d7d7b5ac3c793f7fa9b045024276b54f973dcb833cccc0be697261884db4a')
+sha256sums=('48a7ea9b5043e5476b63d3b77b3bf01d71fd7fb53dd76db13865ce8bf8d4c09f')
_jvmdir=usr/lib/jvm/java-${_jdkver}-j9