summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-08-14 12:23:28 +1200
committercaltlgin2020-08-14 12:23:28 +1200
commit4ff48b858b17be66a754033cff88ddcaa0972909 (patch)
treecda51d60c6ce2c9aecb9e18d34617ece43d4bc59
parent9636fffcbdbbb469d8764e748d4668dbf0c505e4 (diff)
downloadaur-4ff48b858b17be66a754033cff88ddcaa0972909.tar.gz
Adopt and Update PKGBUILD
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD61
-rwxr-xr-xsherlock.sh4
4 files changed, 41 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 38385756e073..680dc45777e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,13 @@
pkgbase = sherlock-git
- pkgdesc = Find usernames across social networks
- pkgver = 0.10.6.r1003.45a8c5e
+ pkgdesc = Hunt down social media accounts by username across social networks
+ pkgver = r1276.ca89d12
pkgrel = 1
url = https://github.com/sherlock-project/sherlock
arch = any
license = MIT
makedepends = git
+ makedepends = python-setuptools
+ depends = python
depends = python-beautifulsoup4
depends = python-certifi
depends = python-colorama
@@ -16,10 +18,11 @@ pkgbase = sherlock-git
depends = python-soupsieve
depends = python-stem
depends = python-torrequest
- source = sherlock-git::git+https://github.com/sherlock-project/sherlock.git
+ provides = sherlock
+ source = sherlock::git+https://github.com/sherlock-project/sherlock.git
source = sherlock.sh
sha256sums = SKIP
- sha256sums = 45bb5034d63681f3e0f0d12f868465024a473b12b2751b00e968fcb7a935497c
+ sha256sums = 21c364a2de4c5a491d85c1e6e9ecb4913505a436aa0db75fe98b367209913500
pkgname = sherlock-git
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index 47e8cf7d5b2a..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1,7 +0,0 @@
-sherlock-git/
-*.log
-pkg/
-src/
-*.pkg.tar.xz
-*.pkg.tar.zst
-*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 9cf768610a1e..96c9ab3912c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,44 @@
-# Maintainer: peeweep <peeweep at 0x0 dot ee>
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+# Contributor: peeweep <peeweep at 0x0 dot ee>
-pkgname=sherlock-git
-pkgver=0.10.6.r1003.45a8c5e
+_pkgname=sherlock
+pkgname=${_pkgname}-git
+pkgver=r1276.ca89d12
pkgrel=1
-pkgdesc="Find usernames across social networks"
+pkgdesc='Hunt down social media accounts by username across social networks'
arch=('any')
-url="https://github.com/sherlock-project/sherlock"
+url='https://github.com/sherlock-project/sherlock'
license=('MIT')
-depends=(
- 'python-beautifulsoup4'
- 'python-certifi'
- 'python-colorama'
- 'python-lxml'
- 'python-pysocks'
- 'python-requests'
- 'python-requests-futures'
- 'python-soupsieve'
- 'python-stem'
- 'python-torrequest'
-)
-makedepends=('git')
-source=(
- "${pkgname}::git+${url}.git"
- "sherlock.sh"
-)
+depends=('python'
+ 'python-beautifulsoup4'
+ 'python-certifi'
+ 'python-colorama'
+ 'python-lxml'
+ 'python-pysocks'
+ 'python-requests'
+ 'python-requests-futures'
+ 'python-soupsieve'
+ 'python-stem'
+ 'python-torrequest')
+makedepends=('git' 'python-setuptools')
+provides=("${_pkgname}")
+source=("${_pkgname}::git+${url}.git"
+ "${_pkgname}.sh")
sha256sums=('SKIP'
- '45bb5034d63681f3e0f0d12f868465024a473b12b2751b00e968fcb7a935497c')
+ '21c364a2de4c5a491d85c1e6e9ecb4913505a436aa0db75fe98b367209913500')
pkgver() {
- cd "${srcdir}/${pkgname}"
- printf "%s.r%s.%s" "$(grep '__version__ = ' sherlock.py | cut -d '"' -f 2)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- install -Dm755 "${srcdir}/sherlock.sh" "${pkgdir}/usr/bin/sherlock"
- install -Dm644 "${srcdir}/${pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/sherlock/LICENSE"
- cp -r "${srcdir}/${pkgname}" "${pkgdir}/usr/share/sherlock"
+ install -Dm755 "${_pkgname}.sh" "${pkgdir}/usr/bin/${_pkgname}"
+ cd "${_pkgname}"
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${_pkgname}" {removed_sites.md,sites.md,README.md}
+ install -Dm644 -t "${pkgdir}/usr/share/licenses/${_pkgname}" 'LICENSE'
+ install -dm755 "${pkgdir}/usr/share/${_pkgname}"
+ cp -a "${_pkgname}/"* "${pkgdir}/usr/share/${_pkgname}"
}
-# vim:set ts=2 sw=2 et:
+# vim: ts=2 sw=2 et:
diff --git a/sherlock.sh b/sherlock.sh
index 682eb01e7b51..788a57c4cc8b 100755
--- a/sherlock.sh
+++ b/sherlock.sh
@@ -1,2 +1,2 @@
-#!/usr/bin/bash
-python /usr/share/sherlock/sherlock.py "$@"
+#!/bin/sh
+cd /usr/share/sherlock && exec python sherlock.py "$@"