summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorentith2021-08-21 00:51:14 -0400
committerentith2021-08-21 00:51:14 -0400
commit4fff525d441ee8a240045ce4c9e3eac6695b993f (patch)
tree993252fadcc71f58e8e39d87c29c15c675baa096
parent9c918953630a994114feacf8e07a06e6e9daf9e1 (diff)
downloadaur-4fff525d441ee8a240045ce4c9e3eac6695b993f.tar.gz
Fix PKGBUILD
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 24 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 60810218d3a0..7213b55b6ad2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,17 @@
pkgbase = vkdevicechooser
pkgdesc = Vulkan layer to force a specific physical GPU device to be used
- pkgver = 1
- pkgrel = 1
+ pkgver = 1.0
+ pkgrel = 2
url = https://github.com/aejsmith/vkdevicechooser
arch = x86_64
license = MIT
- source = https://github.com/aejsmith/vkdevicechooser/archive/master.zip
- md5sums = 22df9532f1f89855a0db8ad068ba0145
+ makedepends = git
+ makedepends = vulkan-headers
+ makedepends = vulkan-validation-layers
+ makedepends = meson
+ makedepends = ninja
+ depends = vulkan-icd-loader
+ source = https://github.com/aejsmith/vkdevicechooser/archive/refs/tags/1.0.zip
+ md5sums = 5555405659067e6ba80fac37fcd556d4
pkgname = vkdevicechooser
-
diff --git a/PKGBUILD b/PKGBUILD
index 795cb192d6a5..256464eb4003 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,25 @@
-# Maintainer: Vorpal <vorpal@riseup.net>
+# Maintainer: Entith <entith@entith.net>
+# Contributor: Vorpal <vorpal@riseup.net>
pkgname=vkdevicechooser
-pkgver=1
-pkgrel=1
+pkgver=1.0
+pkgrel=2
pkgdesc="Vulkan layer to force a specific physical GPU device to be used"
arch=('x86_64')
url="https://github.com/aejsmith/vkdevicechooser"
license=('MIT')
-source=(https://github.com/aejsmith/vkdevicechooser/archive/master.zip)
-md5sums=('22df9532f1f89855a0db8ad068ba0145')
+depends=('vulkan-icd-loader')
+makedepends=('git' 'vulkan-headers' 'vulkan-validation-layers' 'meson' 'ninja')
+source=(https://github.com/aejsmith/vkdevicechooser/archive/refs/tags/1.0.zip)
+md5sums=('5555405659067e6ba80fac37fcd556d4')
build() {
- cd "${pkgname}-master"
- make CXXFLAGS="$CXXFLAGS"
+ cd "${pkgname}-${pkgver}"
+ meson --prefix=/usr build
+ ninja -C build
}
package() {
- cd "${pkgname}-master"
- make install DESTDIR="${HOME}"
+ cd "${pkgname}-${pkgver}"
+ echo "pkgdir $pkgdir"
+ DESTDIR="$pkgdir" ninja -C build install
}