summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2022-11-26 14:00:03 -0500
committerGuillaume Horel2022-11-26 14:00:03 -0500
commit500cbe00ae6cbddd8ee5f732cea61b7c761e00ab (patch)
treeedc19386e94ed239d0e9a6782388791adcacaddf
parentc9f679bcede25a255b1455b83fe8c92ad55fd70c (diff)
downloadaur-500cbe00ae6cbddd8ee5f732cea61b7c761e00ab.tar.gz
bump to 5.1.71
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD26
2 files changed, 17 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 09514c8bcf62..50bdf2d5af31 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,9 @@
pkgbase = liblinphone
pkgdesc = A high-level SIP library
- pkgver = 4.4.11
+ pkgver = 5.1.71
pkgrel = 1
url = http://www.linphone.org
arch = x86_64
- arch = i686
license = GPL
makedepends = cmake
makedepends = doxygen
@@ -14,11 +13,11 @@ pkgbase = liblinphone
makedepends = xsd
depends = belcard
depends = belle-sip
+ depends = jsoncpp-cmake-git
depends = mediastreamer
depends = xerces-c
depends = lime
- source = https://gitlab.linphone.org/BC/public/liblinphone/-/archive/4.4.11/liblinphone-4.4.11.tar.gz
- sha256sums = cf4d83254edde9baaea9f46907830de4880f69e1fc670fba76e546134311dc25
+ source = https://gitlab.linphone.org/BC/public/liblinphone/-/archive/5.1.71/liblinphone-5.1.71.tar.gz
+ sha256sums = 12d8ad934bd7a0fc13bf314ddd077fcd1d66193d8e5dfba03df1cd7954c689b6
pkgname = liblinphone
-
diff --git a/PKGBUILD b/PKGBUILD
index a287d1fd8564..7e4041396c2e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,36 @@
-# Maintainer: David P. <megver83@parabola.nu>
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
+# Contributor: David P. <megver83@parabola.nu>
pkgname=liblinphone
-pkgver=4.4.11
+pkgver=5.1.71
pkgrel=1
pkgdesc='A high-level SIP library'
-arch=(x86_64 i686)
+arch=(x86_64)
url='http://www.linphone.org'
license=('GPL')
-depends=(belcard belle-sip mediastreamer xerces-c lime)
+depends=(belcard belle-sip jsoncpp-cmake-git mediastreamer xerces-c lime)
makedepends=(cmake doxygen graphviz python-pystache python-sphinx xsd)
source=("https://gitlab.linphone.org/BC/public/$pkgname/-/archive/$pkgver/$pkgname-$pkgver.tar.gz")
-sha256sums=('cf4d83254edde9baaea9f46907830de4880f69e1fc670fba76e546134311dc25')
+sha256sums=('12d8ad934bd7a0fc13bf314ddd077fcd1d66193d8e5dfba03df1cd7954c689b6')
build() {
- cd "$pkgname-$pkgver"
CXXFLAGS+=" -Wno-deprecated -Wimplicit-fallthrough=0 -Wno-unused-function"
- cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ cmake -B build -S "${pkgname}-${pkgver}"\
+ -DCMAKE_INSTALL_PREFIX=/usr \
-DENABLE_STATIC=NO \
-DENABLE_CXX_WRAPPER=YES \
-DENABLE_DOC=NO \
- -DENABLE_LIME=YES \
+ -DENABLE_LIME=NO \
+ -DENABLE_LIME_X3DH=YES \
-DENABLE_UNIT_TESTS=NO \
-DENABLE_STRICT=NO \
- -DCMAKE_INSTALL_RPATH=NO .
- make
+ -DCMAKE_INSTALL_RPATH=NO
+ cmake --build build
}
package() {
- cd "$pkgname-$pkgver"
-
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
sed -i "${srcdir//\//\\/}\/$pkgname-$pkgver\/wrappers\/cpp\/include/d" \
"$pkgdir/usr/share/LinphoneCxx/cmake/LinphoneCxxConfig.cmake"
}