summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEli Schwartz2019-07-03 16:30:46 -0400
committerEli Schwartz2019-07-03 16:30:46 -0400
commit5046b82acfcd1d60e6ce9ee22baa8c4a6e3d0269 (patch)
treecfa96dae6712f4c9845b6224f5950b634143ce98
parentcdd7157ad38fba41a7570f76cbfea162778e031a (diff)
downloadaur-5046b82acfcd1d60e6ce9ee22baa8c4a6e3d0269.tar.gz
upgpkg: cinnamon-git 4.2.0.r3.g4d1da807e-1
upstream release; update version constraints add provides/conflicts, why were these not already there? refresh patch fuzz Fix FS#63047 -- missing new dependency for cinnamon-settings.
-rw-r--r--.SRCINFO13
-rw-r--r--0001-cinnamon-settings-don-t-rely-on-the-presence-of-cinn.patch18
-rw-r--r--PKGBUILD15
3 files changed, 26 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ac8a240ba109..33851622c2c6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cinnamon-git
pkgdesc = Linux desktop which provides advanced innovative features and a traditional user experience
- pkgver = 4.0.9.r73.g05b529767
- pkgrel = 2
+ pkgver = 4.2.0.r3.g4d1da807e
+ pkgrel = 1
url = https://github.com/linuxmint/cinnamon
arch = x86_64
license = GPL2
@@ -15,7 +15,7 @@ pkgbase = cinnamon-git
depends = cinnamon-menus
depends = cinnamon-screensaver
depends = cinnamon-session
- depends = cinnamon-settings-daemon>=4.0.3.r3.gg8ebfd80
+ depends = cinnamon-settings-daemon>=4.2.0
depends = cjs
depends = gnome-backgrounds
depends = gnome-themes-extra
@@ -23,7 +23,7 @@ pkgbase = cinnamon-git
depends = libgnomekbd
depends = libkeybinder3
depends = librsvg
- depends = muffin-git
+ depends = muffin>=4.2.0
depends = network-manager-applet
depends = nemo
depends = polkit-gnome
@@ -34,19 +34,22 @@ pkgbase = cinnamon-git
depends = python-pexpect
depends = python-pillow
depends = python-pyinotify
+ depends = python-tinycss
depends = xapps
optdepends = blueberry: Bluetooth support
optdepends = cinnamon-translations: i18n
optdepends = gnome-panel: fallback mode
optdepends = metacity: fallback mode
optdepends = system-config-printer: printer settings
+ provides = cinnamon=4.2.0.r3.g4d1da807e
+ conflicts = cinnamon
options = !emptydirs
source = git+https://github.com/linuxmint/cinnamon.git
source = 0001-cinnamon-settings-don-t-rely-on-the-presence-of-cinn.patch
source = set_wheel.diff
source = default-theme.patch
sha256sums = SKIP
- sha256sums = 024fa59ea6e1e7e6f6307786abf71ddeb1f6add43c832d568ba856bb43bf4dc6
+ sha256sums = edb5c1cf43913da086aa11f303b0919bbea232d140afa33ceac52fe367d15fcf
sha256sums = 7517d651d440361947f9539fe8f42548d5eb43a09c28c9a11f51cfdfdefd042f
sha256sums = 566585873f38a79ec248b916645a2e081abec3c6d4df2c34339cde1f35375cc5
diff --git a/0001-cinnamon-settings-don-t-rely-on-the-presence-of-cinn.patch b/0001-cinnamon-settings-don-t-rely-on-the-presence-of-cinn.patch
index 39b41ada1ab4..e3ddd3622e5f 100644
--- a/0001-cinnamon-settings-don-t-rely-on-the-presence-of-cinn.patch
+++ b/0001-cinnamon-settings-don-t-rely-on-the-presence-of-cinn.patch
@@ -1,4 +1,4 @@
-From ad1e03d6b652b4c7ce0bd9469087b40989824f5c Mon Sep 17 00:00:00 2001
+From ac4d2fc9fafb38ebb02615a41b23cceca304e73a Mon Sep 17 00:00:00 2001
From: Eli Schwartz <eschwartz93@gmail.com>
Date: Tue, 20 Mar 2018 14:11:02 -0400
Subject: [PATCH] cinnamon-settings: don't rely on the presence of
@@ -13,19 +13,19 @@ exists.
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/files/usr/bin/cinnamon-settings b/files/usr/bin/cinnamon-settings
-index fcd1fee9e..e20ba0b78 100755
+index 9fbdbecd2..98ca454a5 100755
--- a/files/usr/bin/cinnamon-settings
+++ b/files/usr/bin/cinnamon-settings
-@@ -7,6 +7,7 @@ Usage: cinnamon-settings [optional module name]
-
+@@ -58,6 +58,7 @@ Available types of sort, and corresponding numbers:
+ import getopt
import os
import sys
+import sysconfig
- if len(sys.argv) > 1:
- module = sys.argv[1]
-@@ -14,7 +15,7 @@ if len(sys.argv) > 1:
- os.execvp("/usr/share/cinnamon/cinnamon-settings/xlet-settings.py", (" ", module[0:-1]) + tuple(sys.argv[2:]))
+ def usage():
+ print("""Usage:
+@@ -119,7 +120,7 @@ if len(sys.argv) > 1:
+ os.execvp("/usr/share/cinnamon/cinnamon-settings/cinnamon-settings.py", (" ",) + tuple(sys.argv[1:]))
elif os.path.exists("/usr/share/cinnamon/cinnamon-settings/modules/cs_%s.py" % module):
os.execvp("/usr/share/cinnamon/cinnamon-settings/cinnamon-settings.py", (" ",) + tuple(sys.argv[1:]))
- elif os.path.exists("/usr/bin/cinnamon-control-center"):
@@ -34,5 +34,5 @@ index fcd1fee9e..e20ba0b78 100755
elif os.path.exists("/usr/bin/gnome-control-center"):
print ("Unknown module %s, calling gnome-control-center" % module)
--
-2.20.0
+2.22.0
diff --git a/PKGBUILD b/PKGBUILD
index 21ba9a32abaf..65576d443325 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,22 +5,25 @@
# Contributor: CReimer
pkgname=cinnamon-git
-pkgver=4.0.9.r73.g05b529767
-pkgrel=2
+pkgver=4.2.0.r3.g4d1da807e
+pkgrel=1
pkgdesc="Linux desktop which provides advanced innovative features and a traditional user experience"
arch=('x86_64')
url="https://github.com/linuxmint/${pkgname%-git}"
license=('GPL2')
depends=('accountsservice' 'caribou' 'cinnamon-control-center' 'cinnamon-menus' 'cinnamon-screensaver'
- 'cinnamon-session' 'cinnamon-settings-daemon>=4.0.3.r3.gg8ebfd80' 'cjs' 'gnome-backgrounds'
- 'gnome-themes-extra' 'gstreamer' 'libgnomekbd' 'libkeybinder3' 'librsvg' 'muffin-git'
+ 'cinnamon-session' 'cinnamon-settings-daemon>=4.2.0' 'cjs' 'gnome-backgrounds'
+ 'gnome-themes-extra' 'gstreamer' 'libgnomekbd' 'libkeybinder3' 'librsvg' 'muffin>=4.2.0'
'network-manager-applet' 'nemo' 'polkit-gnome' 'python-cairo' 'python-dbus'
- 'python-gobject' 'python-pam' 'python-pexpect' 'python-pillow' 'python-pyinotify' 'xapps')
+ 'python-gobject' 'python-pam' 'python-pexpect' 'python-pillow' 'python-pyinotify'
+ 'python-tinycss' 'xapps')
optdepends=('blueberry: Bluetooth support'
'cinnamon-translations: i18n'
'gnome-panel: fallback mode'
'metacity: fallback mode'
'system-config-printer: printer settings')
+provides=("${pkgname%-git}=${pkgver}")
+conflicts=("${pkgname%-git}")
makedepends=('git' 'intltool' 'gtk-doc' 'gobject-introspection')
options=('!emptydirs')
source=("git+${url}.git"
@@ -28,7 +31,7 @@ source=("git+${url}.git"
"set_wheel.diff"
"default-theme.patch")
sha256sums=('SKIP'
- '024fa59ea6e1e7e6f6307786abf71ddeb1f6add43c832d568ba856bb43bf4dc6'
+ 'edb5c1cf43913da086aa11f303b0919bbea232d140afa33ceac52fe367d15fcf'
'7517d651d440361947f9539fe8f42548d5eb43a09c28c9a11f51cfdfdefd042f'
'566585873f38a79ec248b916645a2e081abec3c6d4df2c34339cde1f35375cc5')