summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlorenzo2017-06-16 15:05:35 +0200
committerlorenzo2017-06-16 15:05:35 +0200
commit5061357377778a0d41951e405b7087b9b5f099ac (patch)
tree6fd94f7b27ac3fd14393b8ecdbe91b1c0ce34d79
parent6bca4bcdd49994780911abccb4dc08e0119c505d (diff)
downloadaur-5061357377778a0d41951e405b7087b9b5f099ac.tar.gz
Updated to version 3.6.1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD36
-rw-r--r--changelog21
-rw-r--r--modelio.desktop2
4 files changed, 35 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc674c4ec56d..f1402209422c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Mon Nov 14 16:12:46 UTC 2016
pkgbase = modelio-bin
pkgdesc = The opensource modeling environment
- pkgver = 3.5.1.a
+ pkgver = 3.6.1
pkgrel = 1
url = https://www.modelio.org/
changelog = changelog
@@ -18,12 +16,12 @@ pkgbase = modelio-bin
optdepends = cairo
source = modelio.desktop
source = changelog
- sha256sums = 6b90872f1ddcfba5db33b56d115334220c5a081d04bbf80cc0b9f7227a0104ac
- sha256sums = d6009847389012b96c5b2f36358acd93a260236e5449739c41727f64c696b5db
- source_i686 = modelio-3.5.1.a-i686::https://sourceforge.net/projects/modeliouml/files/3.5.1.a/modelio-open-201607131846-linux.gtk.x86.tar.gz/download
- sha256sums_i686 = ffe5d0df932512d46c9cc8087ae927f34a4aaf1859eb981dfa76e578d806be63
- source_x86_64 = modelio-3.5.1.a-x86_64::https://sourceforge.net/projects/modeliouml/files/3.5.1.a/modelio-open-201607131846-linux.gtk.x86_64.tar.gz/download
- sha256sums_x86_64 = 7769bca6e8ae924667809131a7a405cb735a8dc317eb964d2b113e1c26d3f2dc
+ sha256sums = SKIP
+ sha256sums = SKIP
+ source_i686 = modelio-3.6.1-i686::https://sourceforge.net/projects/modeliouml/files/3.6.1/modelio-open-source-3.6.1_i386.deb/download
+ sha256sums_i686 = SKIP
+ source_x86_64 = modelio-3.6.1-x86_64::https://sourceforge.net/projects/modeliouml/files/3.6.1/modelio-open-source-3.6.1_amd64.deb/download
+ sha256sums_x86_64 = SKIP
pkgname = modelio-bin
diff --git a/PKGBUILD b/PKGBUILD
index f854118f9e88..4400bc3b26c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
# Maintainer: rafaelsoaresbr <rafaelsoaresbr@gmail.com>
+# Maintainer: llde
# modelio-bin
# Contributing: https://github.com/rafaelsoaresbr/pkgbuild
# Builds: https://gitlab.com/rafaelsoaresbr/pkgbuild/builds
@@ -6,11 +7,8 @@
pkgname=modelio-bin
# Version
-pkgver=3.5.1.a
+pkgver=3.6.1
pkgrel=1
-#epoch=
-_ver=3.5
-_timestamp=201607131846
# Generic
pkgdesc="The opensource modeling environment"
@@ -38,24 +36,22 @@ changelog=changelog
# Sources
source=("modelio.desktop" "changelog")
-source_i686=("modelio-${pkgver}-i686::https://sourceforge.net/projects/modeliouml/files/${pkgver}/modelio-open-${_timestamp}-linux.gtk.x86.tar.gz/download")
-source_x86_64=("modelio-${pkgver}-x86_64::https://sourceforge.net/projects/modeliouml/files/${pkgver}/modelio-open-${_timestamp}-linux.gtk.x86_64.tar.gz/download")
+source_i686=("modelio-${pkgver}-i686::https://sourceforge.net/projects/modeliouml/files/${pkgver}/modelio-open-source-${pkgver}_i386.deb/download")
+source_x86_64=("modelio-${pkgver}-x86_64::https://sourceforge.net/projects/modeliouml/files/${pkgver}/modelio-open-source-${pkgver}_amd64.deb/download
+")
#noextract=()
#validpgpkeys=()
-
-# Integrity
-#md5sums=
-#sha1sums=()
-sha256sums=('6b90872f1ddcfba5db33b56d115334220c5a081d04bbf80cc0b9f7227a0104ac'
- 'd6009847389012b96c5b2f36358acd93a260236e5449739c41727f64c696b5db')
-sha256sums_i686=('ffe5d0df932512d46c9cc8087ae927f34a4aaf1859eb981dfa76e578d806be63')
-sha256sums_x86_64=('7769bca6e8ae924667809131a7a405cb735a8dc317eb964d2b113e1c26d3f2dc')
+sha256sums=('SKIP'
+ 'SKIP')
+sha256sums_i686=('SKIP')
+sha256sums_x86_64=('SKIP')
#pkgver() {
#}
-#prepare() {
-#}
+prepare() {
+ ar p modelio-${pkgver}-${CARCH} data.tar.gz | tar zx
+}
#build() {
#}
@@ -64,8 +60,8 @@ sha256sums_x86_64=('7769bca6e8ae924667809131a7a405cb735a8dc317eb964d2b113e1c26d3
#}
package() {
- install -dm755 "$pkgdir/usr/share/applications/"
- install -dm755 "$pkgdir/opt/modelio"
- install -Dm755 "$srcdir/modelio.desktop" "$pkgdir/usr/share/applications/"
- cp -ru $srcdir/Modelio\ ${_ver}/* "$pkgdir/opt/modelio/"
+ install -dm755 "${pkgdir}/usr/share/applications/"
+ install -dm755 "${pkgdir}/opt/modelio"
+ install -Dm755 "${srcdir}/modelio.desktop" "${pkgdir}/usr/share/applications/"
+ cp -r "${srcdir}"/usr/lib/modelio-open-source3.6/* "${pkgdir}/opt/modelio/"
}
diff --git a/changelog b/changelog
index 5c226c006969..351eb673c232 100644
--- a/changelog
+++ b/changelog
@@ -1,18 +1,19 @@
-Released on November 24th 2015
+Changelog Modelio 3.6.1
Evolutions:
- Diagrams layout assistant is now customizable.
- Floating labels are no more taken into account by the layout assistant.
- Views positions are now saved when closing a project.
+ Improvement of the indexes management.
+ Diagrams palette are now displayed in ‘icon’ mode by default.
+ A diagram selection box now appears when creating a Related Diagram Link.
Fixes / Improvements:
- Fixes in the Patterns feature.
- Fix Use Cases edition boxes.
- Fixes in Sequence diagrams.
- Fixes in Activity diagrams.
- Fixes in XMI import/export.
+ Fixed issues with edition in diagrams when several diagrams are opened.
+ Fixed issues with the XMI import/export.
+ Fixed memory leaks in diagram editors.
+ Fixed issue with integer values edition in the Properties view.
+ Fixed issue with elements label display in ‘User defined image’ representation mode.
+ Fixed issue with project export on MacOS.
Notes:
@@ -36,4 +37,4 @@ The Rich Note feature has been validated under the following platforms:
LibreOffice 3.6.1 (32 and 64-bit)
LibreOffice 4.1.3 (32-bit only)
-(Recommended versions are in bold)
+(Recommended versions are in bold) \ No newline at end of file
diff --git a/modelio.desktop b/modelio.desktop
index fc3cc130e753..7d9ac19de907 100644
--- a/modelio.desktop
+++ b/modelio.desktop
@@ -1,6 +1,6 @@
[Desktop Entry]
Name=Modelio
-Version=3.5.1.a
+Version=3.6.1
Comment=The opensource modeling environment
Exec=/opt/modelio/modelio %u
Icon=/opt/modelio/icon.xpm