summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas18182020-11-26 23:05:31 +0100
committerLukas18182020-11-26 23:05:31 +0100
commit506d4341072f55944aecdef1373782b41e3f92bd (patch)
tree268fa49f7d776470189162b1163cf04567e79631
downloadaur-506d4341072f55944aecdef1373782b41e3f92bd.tar.gz
init git
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD29
-rwxr-xr-xSpace Haven.desktop8
-rwxr-xr-xstart-spaceheaven.sh9
4 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fd77b74284a5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = gog-space-haven
+ pkgdesc = Embark on a space voyage with your ragtag crew of civilians in search of a new home.
+ pkgver = 0.10.2
+ pkgrel = 1
+ url = https://www.gog.com/game/space_haven
+ arch = x86_64
+ license = custom
+ makedepends = lgogdownloader
+ depends = jre-openjdk
+ depends = bash
+ depends = coreutils
+ source = space_haven_english_0_10_2.sh::gogdownloader://1589675197/en3installer0
+ source = Space Haven.desktop
+ source = start-spaceheaven.sh
+ sha512sums = 8902694d3ec99871031728a7d41b253f05e346c088822d639e47891d8b3ecfb8265f26a85c842805be9d3814b306b8c3c53a3bde8b44e35863d960c52de81b7a
+ sha512sums = caecccc1cc3a125b468a6359bbfc921721939d2ac1f78b806e3c1b76c399ee256a59daf49236746923893a5969818ad0da2f9aadb098278cfd314d1ab177ed16
+ sha512sums = caf0d0d15d41349fb9bc33aa3ee7206e219c1a55b2358fe45f0f0a75a9ad6530190efd5575f667d6e39f67ee04f08d3222f8a2b8e3af94fb05a10ce0c5a254e3
+
+pkgname = gog-space-haven
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0e60d735aebf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Lukas1818 aur at lukas1818 dot de
+
+pkgname=gog-space-haven
+pkgver=0.10.2
+_pkgtag=$pkgver
+pkgrel=1
+pkgdesc="Embark on a space voyage with your ragtag crew of civilians in search of a new home."
+arch=('x86_64')
+url="https://www.gog.com/game/space_haven"
+license=('custom')
+makedepends=('lgogdownloader')
+depends=('jre-openjdk' 'bash' 'coreutils')
+source=("space_haven_english_${pkgver//./_}.sh::gogdownloader://1589675197/en3installer0"
+ "Space Haven.desktop"
+ "start-spaceheaven.sh")
+sha512sums=('8902694d3ec99871031728a7d41b253f05e346c088822d639e47891d8b3ecfb8265f26a85c842805be9d3814b306b8c3c53a3bde8b44e35863d960c52de81b7a'
+ 'caecccc1cc3a125b468a6359bbfc921721939d2ac1f78b806e3c1b76c399ee256a59daf49236746923893a5969818ad0da2f9aadb098278cfd314d1ab177ed16'
+ 'caf0d0d15d41349fb9bc33aa3ee7206e219c1a55b2358fe45f0f0a75a9ad6530190efd5575f667d6e39f67ee04f08d3222f8a2b8e3af94fb05a10ce0c5a254e3')
+
+DLAGENTS+=('gogdownloader::/usr/bin/lgogdownloader --download-file=%u -o %o')
+
+package()
+{
+ install -Dm 644 "${srcdir}/data/noarch/game/spacehaven.jar" "${pkgdir}/opt/$pkgname/spacehaven.jar"
+ install -Dm 755 "${srcdir}/start-spaceheaven.sh" "${pkgdir}/usr/bin/spacehaven"
+ install -Dm 755 "${srcdir}/Space Haven.desktop" "$pkgdir/usr/share/applications/Space Haven.desktop"
+ install -Dm 644 "${srcdir}/data/noarch/support/icon.png" "${pkgdir}/usr/share/pixmaps/$pkgname.png"
+ install -Dm 644 "${srcdir}/data/noarch/docs/End User License Agreement.txt" "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
+}
diff --git a/Space Haven.desktop b/Space Haven.desktop
new file mode 100755
index 000000000000..e18dbecc85f3
--- /dev/null
+++ b/Space Haven.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Space Haven
+Exec=spacehaven
+Comment=Embark on a space voyage with your ragtag crew of civilians in search of a new home. Build spaceships tile by tile, create optimal gas conditions, manage the needs and moods of their crew, encounter other space-faring groups, and explore the universe in this spaceship colony sim.
+Terminal=false
+Icon=gog-space-haven.png
+Type=Application
+Categories=Game;
diff --git a/start-spaceheaven.sh b/start-spaceheaven.sh
new file mode 100755
index 000000000000..2f5ef2a48167
--- /dev/null
+++ b/start-spaceheaven.sh
@@ -0,0 +1,9 @@
+#!/bin/bash
+set -e
+set -u
+
+#Space Haven wirte settings and saves to the working directory
+save_dir="${HOME}/.config/Space Haven"
+mkdir -p "$save_dir"
+cd "$save_dir"
+java -Xmx3g -jar /opt/gog-space-haven/spacehaven.jar $@