summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Heitzmann Gabrielli2020-10-17 15:43:58 -0300
committerLucas Heitzmann Gabrielli2020-10-17 15:43:58 -0300
commit5081e892be565535e1e35f3c31751383be9949e5 (patch)
tree4af20dd7e82ccc98d85c11ab236326caf5bfc07f
parentcf78acbe2abe169854dd8c8984a2d0d0fb550d03 (diff)
downloadaur-5081e892be565535e1e35f3c31751383be9949e5.tar.gz
Update to development branch
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD20
2 files changed, 11 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc6e77fea384..4ce2213f9f7c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-fiat-git
- pkgdesc = Supports generation of arbitrary order instances of the Lagrange elements on lines, triangles, and tetrahedra.
- pkgver = 20181101
+ pkgdesc = Generation of arbitrary order Lagrange elements on lines, triangles, and tetrahedra.
+ pkgver = 20200113
pkgrel = 1
url = https://bitbucket.org/fenics-project/fiat
arch = any
@@ -11,7 +11,7 @@ pkgbase = python-fiat-git
depends = python-numpy
depends = python-sympy
options = !emptydirs
- source = fiat::git+https://bitbucket.org/fenics-project/fiat.git#branch=master
+ source = fiat::git+https://bitbucket.org/fenics-project/fiat.git
md5sums = SKIP
pkgname = python-fiat-git
diff --git a/PKGBUILD b/PKGBUILD
index 92aeca46f090..90bc27bf79b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,30 @@
# Maintainer: Lucas H. Gabrielli <heitzmann@gmail.com>
-_base=fiat
-_fragment="#branch=master"
-pkgname=python-${_base}-git
-pkgdesc="Supports generation of arbitrary order instances of the Lagrange elements on lines, triangles, and tetrahedra."
-pkgver=20181101
+pkgname=python-fiat-git
+pkgdesc="Generation of arbitrary order Lagrange elements on lines, triangles, and tetrahedra."
+pkgver=20200113
pkgrel=1
arch=('any')
-url="https://bitbucket.org/fenics-project/${_base}"
+url="https://bitbucket.org/fenics-project/fiat"
license=('GPL3')
groups=('fenics-git')
depends=('python-numpy' 'python-sympy')
makedepends=('python-setuptools' 'git')
options=(!emptydirs)
-source=("${_base}::git+https://bitbucket.org/fenics-project/${_base}.git${_fragment}")
+source=("fiat::git+https://bitbucket.org/fenics-project/fiat.git")
md5sums=('SKIP')
pkgver() {
- cd ${_base}
+ cd fiat
git log --format="%cd" --date=short -1 | sed 's/-//g'
}
build() {
- cd ${_base}
+ cd fiat
python setup.py build
}
package() {
- cd ${_base}
+ cd fiat
python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
}
-
-# vim: shiftwidth=2 softtabstop=2 tabstop=2 noexpandtab