summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2023-12-23 09:52:28 -0500
committergraysky2023-12-23 09:52:31 -0500
commit508c6d72d3451514a56d9210a0c0d85052c45c43 (patch)
tree7f798523a959dd355052d6b49f7fca2847b1da51
parent7aa4c444bec4a810c32da8bda977afa09a474ef6 (diff)
downloadaur-508c6d72d3451514a56d9210a0c0d85052c45c43.tar.gz
Update to r64774.7eebcfa3056-1
Add var to define renderer to avoid superfluous builds of both gl and gles
-rw-r--r--.SRCINFO71
-rw-r--r--PKGBUILD72
2 files changed, 22 insertions, 121 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2a1b5287501a..fdf23b78f723 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = kodi-git
- pkgver = r64767.d9bc4008620
+ pkgver = r64774.7eebcfa3056
pkgrel = 1
url = https://kodi.tv
arch = x86_64
@@ -94,7 +94,7 @@ pkgbase = kodi-git
b2sums = 6d647177380c619529fb875374ec46f1fff6273be1550f056c18cb96e0dea8055272b47664bb18cdc964496a3e9007fda435e67c4f1cee6375a80c048ae83dd0
pkgname = kodi-git
- pkgdesc = A software media player and entertainment hub for digital media (gl renderer, master branch)
+ pkgdesc = A software media player and entertainment hub for digital media (master branch, gles renderer)
depends = bluez-libs
depends = curl
depends = dav1d
@@ -141,65 +141,7 @@ pkgname = kodi-git
optdepends = pulseaudio: PulseAudio support
optdepends = pipewire: PipeWire support
optdepends = upower: Display battery level
- provides = kodi-common=r64767.d9bc4008620
- provides = kodi-x11
- provides = kodi-wayland
- provides = kodi-gbm
- conflicts = kodi-gles
- conflicts = kodi-x11
- conflicts = kodi-wayland
- conflicts = kodi-gbm
-
-pkgname = kodi-git-gles
- pkgdesc = A software media player and entertainment hub for digital media (gles renderer, master branch)
- depends = bluez-libs
- depends = curl
- depends = dav1d
- depends = desktop-file-utils
- depends = hicolor-icon-theme
- depends = fmt
- depends = lcms2
- depends = libass
- depends = libbluray
- depends = libcdio
- depends = libcec
- depends = libmicrohttpd
- depends = libnfs
- depends = libplist
- depends = libpulse
- depends = libva
- depends = libvdpau
- depends = libxslt
- depends = lirc
- depends = lzo
- depends = mariadb-libs
- depends = mesa
- depends = libpipewire
- depends = python-pillow
- depends = python-pycryptodomex
- depends = python-simplejson
- depends = shairplay
- depends = smbclient
- depends = sndio
- depends = spdlog
- depends = sqlite
- depends = taglib
- depends = tinyxml
- depends = libxrandr
- depends = libxkbcommon
- depends = waylandpp
- depends = libinput
- depends = pcre
- depends = libdisplay-info
- depends = tinyxml2
- optdepends = afpfs-ng: Apple shares support
- optdepends = bluez: Blutooth support
- optdepends = python-pybluez: Bluetooth support
- optdepends = pulseaudio: PulseAudio support
- optdepends = pipewire: PipeWire support
- optdepends = upower: Display battery level
- provides = kodi-common=r64767.d9bc4008620
- provides = kodi=r64767.d9bc4008620
+ provides = kodi-common=r64774.7eebcfa3056
provides = kodi-x11
provides = kodi-wayland
provides = kodi-gbm
@@ -212,7 +154,7 @@ pkgname = kodi-git-eventclients
pkgdesc = Kodi Event Clients (master branch)
optdepends = kodi: local machine eventclient use
optdepends = python: most eventclients are implemented in python
- provides = kodi-eventclients=r64767.d9bc4008620
+ provides = kodi-eventclients=r64774.7eebcfa3056
conflicts = kodi-eventclients
pkgname = kodi-git-tools-texturepacker
@@ -221,11 +163,10 @@ pkgname = kodi-git-tools-texturepacker
depends = giflib
depends = libjpeg-turbo
depends = lzo
- provides = kodi-tools-texturepacker=r64767.d9bc4008620
+ provides = kodi-tools-texturepacker=r64774.7eebcfa3056
conflicts = kodi-tools-texturepacker
pkgname = kodi-git-dev
pkgdesc = Kodi dev files (master branch)
- depends = kodi-git
- provides = kodi-dev=r64767.d9bc4008620
+ provides = kodi-dev=r64774.7eebcfa3056
conflicts = kodi-dev
diff --git a/PKGBUILD b/PKGBUILD
index e0c79602c774..5405c57288fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,9 +20,12 @@
# set this to anything to build with clang rather than with gcc
_clangbuild=
+# define the applicaton render system, valid values are either 'gl' or 'gles'
+_renderer=gles
+
pkgbase=kodi-git
-pkgname=("$pkgbase" "$pkgbase-gles" "$pkgbase-eventclients" "$pkgbase-tools-texturepacker" "$pkgbase-dev")
-pkgver=r64767.d9bc4008620
+pkgname=("$pkgbase" "$pkgbase-eventclients" "$pkgbase-tools-texturepacker" "$pkgbase-dev")
+pkgver=r64774.7eebcfa3056
pkgrel=1
arch=('x86_64')
url="https://kodi.tv"
@@ -106,13 +109,13 @@ pkgver() {
}
prepare() {
- [[ -d "$srcdir/kodi-build" ]] && rm -rf "$srcdir/kodi-build"
+ [[ -d kodi-build ]] && rm -rf kodi-build
mkdir "$srcdir/kodi-build"
- [[ -d "$srcdir/kodi-build-gles" ]] && rm -rf "$srcdir/kodi-build-gles"
- mkdir "$srcdir/kodi-build-gles"
cd "$_gitname"
+ rm -rf system/certs # remove not needed cacert
+
[[ "$_sse_workaround" -eq 1 ]] && patch -p1 -i "$srcdir/cheat-sse-build.patch"
if [[ -n "$_clangbuild" ]]; then
@@ -122,6 +125,7 @@ prepare() {
}
build() {
+ cd "$srcdir/kodi-build"
_args=(
-DCMAKE_BUILD_TYPE=Release
@@ -163,26 +167,21 @@ build() {
-DFSTRCMP_URL="$srcdir/fstrcmp-$_fstrcmp_version.tar.gz"
-DFLATBUFFERS_URL="$srcdir/flatbuffers-$_flatbuffers_version.tar.gz"
-DUDFREAD_URL="$srcdir/libudfread-$_libudfread_version.tar.gz"
+ -DAPP_RENDER_SYSTEM=$_renderer
)
# https://github.com/google/flatbuffers/issues/7404
CXXFLAGS+=' -Wno-error=restrict'
echo "building kodi"
- cd "$srcdir/kodi-build"
- cmake "${_args[@]}" -DAPP_RENDER_SYSTEM=gl ../"$_gitname"
- make
-
- echo "building kodi-gles"
- cd "$srcdir/kodi-build-gles"
- cmake "${_args[@]}" -DAPP_RENDER_SYSTEM=gles ../"$_gitname"
+ cmake "${_args[@]}" ../"$_gitname"
make
}
# kodi
# components: kodi
package_kodi-git() {
- pkgdesc="A software media player and entertainment hub for digital media (gl renderer, master branch)"
+ pkgdesc="A software media player and entertainment hub for digital media (master branch, $_renderer renderer)"
depends=(
'bluez-libs' 'curl' 'dav1d' 'desktop-file-utils' 'hicolor-icon-theme' 'fmt'
'lcms2' 'libass' 'libbluray' 'libcdio' 'libcec' 'libmicrohttpd' 'libnfs'
@@ -203,7 +202,7 @@ package_kodi-git() {
'upower: Display battery level'
)
provides=("kodi-common=${pkgver}" 'kodi-x11' 'kodi-wayland' 'kodi-gbm')
- conflicts=('kodi-gles' 'kodi-x11' 'kodi-wayland' 'kodi-gbm')
+ conflicts=('kodi' 'kodi-x11' 'kodi-wayland' 'kodi-gbm')
_components=(
'kodi'
@@ -220,49 +219,11 @@ package_kodi-git() {
# avoid error <general>: GetDirectory - Error getting /usr/lib/kodi/addons
# https://bugs.archlinux.org/task/77366
mkdir -p "$pkgdir"/usr/lib/kodi/addons
-}
-# kodi-gles
-# components: kodi
-package_kodi-git-gles() {
- pkgdesc="A software media player and entertainment hub for digital media (gles renderer, master branch)"
- depends=(
- 'bluez-libs' 'curl' 'dav1d' 'desktop-file-utils' 'hicolor-icon-theme' 'fmt'
- 'lcms2' 'libass' 'libbluray' 'libcdio' 'libcec' 'libmicrohttpd' 'libnfs'
- 'libplist' 'libpulse' 'libva' 'libvdpau' 'libxslt' 'lirc' 'lzo'
- 'mariadb-libs' 'mesa' 'libpipewire' 'python-pillow' 'python-pycryptodomex'
- 'python-simplejson' 'shairplay' 'smbclient' 'sndio' 'spdlog' 'sqlite'
- 'taglib' 'tinyxml' 'libxrandr' 'libxkbcommon' 'waylandpp' 'libinput'
- 'pcre' 'libdisplay-info' 'tinyxml2'
- )
- [[ -n "$_clangbuild" ]] && depends+=('glu')
+ # https://archlinux.org/todo/use-system-ca-store/
+ mkdir -p "$pkgdir"/usr/share/kodi/system/certs
+ ln -s /etc/ssl/cert.pem "$pkgdir"/usr/share/kodi/system/certs/cacert.pem
- optdepends=(
- 'afpfs-ng: Apple shares support'
- 'bluez: Blutooth support'
- 'python-pybluez: Bluetooth support'
- 'pulseaudio: PulseAudio support'
- 'pipewire: PipeWire support'
- 'upower: Display battery level'
- )
- provides=("kodi-common=${pkgver}" "kodi=${pkgver}" 'kodi-x11' 'kodi-wayland' 'kodi-gbm')
- conflicts=('kodi' 'kodi-x11' 'kodi-wayland' 'kodi-gbm')
-
- _components=(
- 'kodi'
- 'kodi-bin'
- )
-
- cd kodi-build-gles
- for _cmp in ${_components[@]}; do
- DESTDIR="$pkgdir" /usr/bin/cmake \
- -DCMAKE_INSTALL_COMPONENT="$_cmp" \
- -P cmake_install.cmake
- done
-
- # avoid error <general>: GetDirectory - Error getting /usr/lib/kodi/addons
- # https://bugs.archlinux.org/task/77366
- mkdir -p "$pkgdir"/usr/lib/kodi/addons
}
# kodi-eventclients
@@ -316,7 +277,6 @@ package_kodi-git-dev() {
pkgdesc="Kodi dev files (master branch)"
provides=("kodi-dev=${pkgver}")
conflicts=('kodi-dev')
- depends=('kodi-git')
_components=(
'kodi-addon-dev'