summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrealgagu2018-03-23 16:19:31 -0500
committerfrealgagu2018-03-23 16:19:31 -0500
commit5092e5a96d09bf5aa8436fc5c92b4b086cdfb911 (patch)
tree5f98edc3d639931b7748750351db8cdeaeb9afbf
parentdc799ebfd29f04de079ed64141f9f64613b72db0 (diff)
downloadaur-5092e5a96d09bf5aa8436fc5c92b4b086cdfb911.tar.gz
Fixing build issue by using rakuco suggestion
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD36
2 files changed, 25 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e1ca7b4d05d6..db562a317ed2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = antimicro
pkgdesc = Graphical program used to map keyboard keys and mouse controls to gamepad buttons
pkgver = 2.23
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/AntiMicro/antimicro
arch = i686
arch = x86_64
@@ -10,14 +10,14 @@ pkgbase = antimicro
makedepends = gettext
makedepends = itstool
makedepends = qt5-tools
+ depends = desktop-file-utils
depends = libxkbcommon-x11
depends = libxtst
depends = qt5-base
depends = sdl2
depends = shared-mime-info
- depends = desktop-file-utils
source = antimicro-2.23.tar.gz::https://github.com/AntiMicro/antimicro/archive/2.23.tar.gz
- sha1sums = 8656ce94a1eac2a0934e62db42e386bc481708bb
+ sha256sums = ef309170612da805992f9194f1973bf38a3174a0856856afedab67f9d927a9ef
pkgname = antimicro
diff --git a/PKGBUILD b/PKGBUILD
index 592de191be90..d2393782b100 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,29 +4,37 @@
pkgname=antimicro
pkgver=2.23
-pkgrel=1
+pkgrel=2
pkgdesc="Graphical program used to map keyboard keys and mouse controls to gamepad buttons"
-arch=('i686' 'x86_64')
-url="https://github.com/AntiMicro/antimicro"
-license=('GPL3')
-depends=('libxkbcommon-x11' 'libxtst' 'qt5-base' 'sdl2' 'shared-mime-info' 'desktop-file-utils')
-makedepends=('cmake' 'gettext' 'itstool' 'qt5-tools')
+arch=("i686" "x86_64")
+url="https://github.com/AntiMicro/${pkgname}"
+license=("GPL3")
+depends=("desktop-file-utils" "libxkbcommon-x11" "libxtst" "qt5-base" "sdl2" "shared-mime-info")
+makedepends=("cmake" "gettext" "itstool" "qt5-tools")
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/AntiMicro/${pkgname}/archive/${pkgver}.tar.gz")
-sha1sums=('8656ce94a1eac2a0934e62db42e386bc481708bb')
-
+sha256sums=("ef309170612da805992f9194f1973bf38a3174a0856856afedab67f9d927a9ef")
+prepare() {
+ #Using fix suggested by rakuco by deleting lines with QT5_WRAP_CPP
+ #https://github.com/AntiMicro/antimicro/pull/207/files
+ sed -i "/QT5_WRAP_CPP/d" "${pkgname}-${pkgver}/CMakeLists.txt"
+}
build() {
- cd ${pkgname}-${pkgver}
-
- mkdir -p build && cd build
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DUSE_SDL_2=ON -DWITH_XTEST=ON \
- -DWITH_UINPUT=ON -DAPPDATA=ON ..
+ mkdir -p "${pkgname}-${pkgver}/build"
+ cd "${pkgname}-${pkgver}/build"
+
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DUSE_SDL_2=ON \
+ -DWITH_XTEST=ON \
+ -DWITH_UINPUT=ON \
+ -DAPPDATA=ON
make
}
package() {
- cd ${pkgname}-${pkgver}/build
+ cd "${pkgname}-${pkgver}/build"
make DESTDIR="${pkgdir}" install
}