summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-01-25 09:27:51 +0800
committerzxp198210052024-01-25 09:27:51 +0800
commit50a3d3fc7cadc33098bcc59269f406ce693b6f00 (patch)
treead264803763a78e8bfaae0faf95544e01eb9d7bf
parent4b389ca063b89b702fa4cc0a1fb891c7d619e70e (diff)
downloadaur-50a3d3fc7cadc33098bcc59269f406ce693b6f00.tar.gz
update to 6.0.0
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD14
-rw-r--r--whalebird.sh7
3 files changed, 17 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e1c36d0c0acb..2d3bc9fa6c2a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = whalebird-bin
pkgdesc = An Electron based Mastodon, Pleroma, and Misskey client
- pkgver = 5.1.1
- pkgrel = 3
+ pkgver = 6.0.0
+ pkgrel = 1
url = https://whalebird.social/
arch = x86_64
- license = GPL3
- depends = electron22
- provides = whalebird=5.1.1
+ license = GPL-3.0-only
+ depends = electron26
+ provides = whalebird=6.0.0
conflicts = whalebird
- source = whalebird-5.1.1.deb::https://github.com/h3poteto/whalebird-desktop/releases/download/v5.1.1/Whalebird-5.1.1-linux-amd64.deb
+ source = whalebird-6.0.0.deb::https://github.com/h3poteto/whalebird-desktop/releases/download/v6.0.0/Whalebird-6.0.0-linux-amd64.deb
source = whalebird.sh
- sha256sums = 556acfb66a0f37d7be1b838c37aa371228efd3655c6d212ac2ecd5749c9ec57a
- sha256sums = d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231
+ sha256sums = 9cbed53a0a063593f5dec47ee748b9faf0575864cbd6d5e5bd45f4c936c83286
+ sha256sums = 1d3f21d54a2d9d1a53661bd91c2afd00df79b0ce4057a66b4c953febfc464cd8
pkgname = whalebird-bin
diff --git a/PKGBUILD b/PKGBUILD
index add2ceca8254..2ae6c3e27fe3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,14 @@
# Contributor : Mélanie Chauvel (ariasuni) <perso@hack-libre.org>
pkgname=whalebird-bin
_pkgname=Whalebird
-pkgver=5.1.1
-_electronversion=22
-pkgrel=3
+pkgver=6.0.0
+_electronversion=26
+pkgrel=1
pkgdesc="An Electron based Mastodon, Pleroma, and Misskey client"
arch=('x86_64')
url="https://whalebird.social/"
_ghurl="https://github.com/h3poteto/whalebird-desktop"
-license=('GPL3')
+license=('GPL-3.0-only')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
@@ -21,8 +21,8 @@ source=(
"${pkgname%-bin}-${pkgver}.deb::${_ghurl}/releases/download/v${pkgver}/${_pkgname}-${pkgver}-linux-amd64.deb"
"${pkgname%-bin}.sh"
)
-sha256sums=('556acfb66a0f37d7be1b838c37aa371228efd3655c6d212ac2ecd5749c9ec57a'
- 'd4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
+sha256sums=('9cbed53a0a063593f5dec47ee748b9faf0575864cbd6d5e5bd45f4c936c83286'
+ '1d3f21d54a2d9d1a53661bd91c2afd00df79b0ce4057a66b4c953febfc464cd8')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
@@ -34,8 +34,6 @@ build() {
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
install -Dm644 "${srcdir}/opt/${_pkgname}/resources/app.asar" -t "${pkgdir}/usr/lib/${pkgname%-bin}"
- install -Dm644 "${srcdir}/opt/${_pkgname}/resources/build/icons/"*.* -t "${pkgdir}/usr/lib/${pkgname%-bin}/build/icons"
- install -Dm644 "${srcdir}/opt/${_pkgname}/resources/build/sounds/"*.wav -t "${pkgdir}/usr/lib/${pkgname%-bin}/build/sounds"
install -Dm644 "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
install -Dm644 "${srcdir}/usr/share/icons/hicolor/256x256/apps/${pkgname%-bin}.png" -t"${pkgdir}/usr/share/pixmaps"
} \ No newline at end of file
diff --git a/whalebird.sh b/whalebird.sh
index aacd8f895847..0d20cddc70ca 100644
--- a/whalebird.sh
+++ b/whalebird.sh
@@ -8,8 +8,7 @@ export ELECTRON_IS_DEV=0
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_ASAR}" "$@"
+ exec electron@electronversion@ "${_ASAR}" "$@" || exit $?
else
- exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
-fi
-exit \ No newline at end of file
+ exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@" || exit $?
+fi \ No newline at end of file