summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Northon2023-02-27 07:16:59 -0500
committerPatrick Northon2023-02-27 07:16:59 -0500
commit50b2c4b2f0098c8179f88b50c5df6c9f4275e64f (patch)
tree302d60f9d21d29ddd9a76db1319969de36d561cf
parent5ed4311bcfca0387be6745b353cba518e3066f85 (diff)
downloadaur-50b2c4b2f0098c8179f88b50c5df6c9f4275e64f.tar.gz
Add missing git dependency and fix source filenames.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
-rw-r--r--python-cef-fix-build.patch (renamed from fix-build.patch)0
3 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 37c1c3732c0d..3e6ad5d3f54d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,6 +9,7 @@ pkgbase = python-cef
makedepends = python-setuptools
makedepends = python-wheel
makedepends = cython
+ makedepends = git
depends = python
depends = nss
depends = libgl
@@ -17,9 +18,9 @@ pkgbase = python-cef
depends = gtk2
depends = libxss
source = git+https://github.com/cztomczak/cefpython.git#commit=5679f28cec18a57a56e298da2927aac8d8f83ad6
- source = https://github.com/cztomczak/cefpython/pull/640.patch
+ source = python-cef-640.patch::https://github.com/cztomczak/cefpython/pull/640.patch
source = https://github.com/cztomczak/cefpython/releases/download/v66-upstream/cef66_3.3359.1774.gd49d25f_linux64.zip
- source = fix-build.patch
+ source = python-cef-fix-build.patch
sha256sums = SKIP
sha256sums = ad9a68087018797697e3ca0c8e20a164036c0b4e73d845e3d6e93396423d5333
sha256sums = a9ec9a72cc84f290cb985bbf06b9825312b7f84cb3e1ca3f4dcfeeeef338d84b
diff --git a/PKGBUILD b/PKGBUILD
index 9a4b1cc70d84..31d146324920 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,13 +9,13 @@ pkgdesc="CEF python bindings (with bundled spotify-built CEF)"
arch=('x86_64')
url='https://github.com/cztomczak/cefpython'
depends=('python' 'nss' 'libgl' 'libxtst' 'alsa-lib' 'gtk2' 'libxss')
-makedepends=('python-docopt' 'python-setuptools' 'python-wheel' 'cython')
+makedepends=('python-docopt' 'python-setuptools' 'python-wheel' 'cython' 'git')
license=('BSD')
_cefstring="cef66_3.3359.1774.gd49d25f_linux64"
source=("git+https://github.com/cztomczak/cefpython.git#commit=5679f28cec18a57a56e298da2927aac8d8f83ad6"
- "https://github.com/cztomczak/cefpython/pull/640.patch"
+ "${pkgname}-640.patch::https://github.com/cztomczak/cefpython/pull/640.patch"
"https://github.com/cztomczak/cefpython/releases/download/v${_vermajor}-upstream/${_cefstring}.zip"
- 'fix-build.patch')
+ "${pkgname}-fix-build.patch")
sha256sums=('SKIP'
'ad9a68087018797697e3ca0c8e20a164036c0b4e73d845e3d6e93396423d5333'
'a9ec9a72cc84f290cb985bbf06b9825312b7f84cb3e1ca3f4dcfeeeef338d84b'
@@ -31,8 +31,8 @@ pkgver() {
prepare() {
cd "${_dir}"
- patch -p1 -i '../640.patch'
- patch -p1 -i '../fix-build.patch'
+ patch -p1 -i "../${pkgname}-640.patch"
+ patch -p1 -i "../${pkgname}-fix-build.patch"
sed -i 's/command = sudo_command/#command = sudo_command/' 'tools/build.py'
diff --git a/fix-build.patch b/python-cef-fix-build.patch
index 47660ce39f1f..47660ce39f1f 100644
--- a/fix-build.patch
+++ b/python-cef-fix-build.patch