summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrendan Szymanski2019-11-13 19:34:34 -0500
committerBrendan Szymanski2019-11-13 19:34:34 -0500
commit50e98b28b9c39296c5c4f1e8de39a1dd3876c0a3 (patch)
tree33bc6241bb1e6c32d27ff3d87ae7dbb621ced7a2
parent035f1b9f624394ddf3b993cae25f2978cf680ddb (diff)
downloadaur-50e98b28b9c39296c5c4f1e8de39a1dd3876c0a3.tar.gz
Change repo back over to canary. Mainline is unstable, and canary is still being updated
-rwxr-xr-x.SRCINFO6
-rwxr-xr-xPKGBUILD17
2 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 382c0e43387c..0c8d17bd2363 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = yuzu-canary-git
pkgdesc = An experimental open-source Nintendo Switch emulator/debugger
- pkgver = r12836.27118b23e
+ pkgver = r13098.0740db225
pkgrel = 1
- url = https://github.com/yuzu-emu/yuzu-mainline
+ url = https://github.com/yuzu-emu/yuzu-canary
arch = i686
arch = x86_64
license = GPL2
@@ -17,7 +17,7 @@ pkgbase = yuzu-canary-git
depends = qt5-tools
depends = libxkbcommon-x11
optdepends = qt5-wayland: for Wayland support
- source = yuzu::git+https://github.com/yuzu-emu/yuzu-mainline
+ source = yuzu::git+https://github.com/yuzu-emu/yuzu-canary
md5sums = SKIP
pkgname = yuzu-canary-git
diff --git a/PKGBUILD b/PKGBUILD
index 0d329d1f6067..73724295f617 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,16 @@
_pkgname=yuzu
pkgname=$_pkgname-canary-git
-pkgver=r12836.27118b23e
+pkgver=r13098.0740db225
pkgrel=1
pkgdesc="An experimental open-source Nintendo Switch emulator/debugger"
arch=('i686' 'x86_64')
-url="https://github.com/yuzu-emu/yuzu-mainline"
+url="https://github.com/yuzu-emu/yuzu-canary"
license=('GPL2')
depends=('shared-mime-info' 'desktop-file-utils' 'sdl2' 'qt5-base' 'qt5-multimedia' 'qt5-tools' 'libxkbcommon-x11')
makedepends=('git' 'cmake' 'python2')
optdepends=('qt5-wayland: for Wayland support')
-source=("$_pkgname::git+https://github.com/yuzu-emu/yuzu-mainline")
+source=("$_pkgname::git+https://github.com/yuzu-emu/yuzu-canary")
md5sums=('SKIP')
pkgver() {
@@ -32,7 +32,7 @@ build() {
cd "$srcdir/$_pkgname"
export CI=true
export TRAVIS=true
- export TRAVIS_REPO_SLUG=yuzu-emu/yuzu-mainline
+ export TRAVIS_REPO_SLUG=yuzu-emu/yuzu-canary
export TRAVIS_TAG=$(git describe --tags)
# Hopefully temporary fix for a compilation error involving fmt
@@ -49,11 +49,10 @@ build() {
make
}
-# Tests removed temporarily as they haven't been updated and throw a false error
-#check() {
-# cd "$srcdir/$_pkgname/build"
-# make test
-#}
+check() {
+ cd "$srcdir/$_pkgname/build"
+ make test
+}
package() {
cd "$srcdir/$_pkgname/build"