summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Westover2022-02-01 22:10:57 -0500
committerBen Westover2022-02-01 22:10:57 -0500
commit5109b185b6396c8d15c790498281a562fcd44cc6 (patch)
treea31bd7359b40b121a1a3834529a933dac1257e57
parent24f98fc6fcf289d441b69ec832c83bf449bd0b67 (diff)
downloadaur-5109b185b6396c8d15c790498281a562fcd44cc6.tar.gz
Update to 11.3.0
-rw-r--r--.SRCINFO25
-rw-r--r--LICENSE15
-rw-r--r--PKGBUILD45
3 files changed, 50 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0fee9384f3b4..a150d6e3c18c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,22 @@
-# Generated by mksrcinfo v8
-# Fri Feb 10 00:06:58 UTC 2017
pkgbase = reportbug
- pkgdesc = report bugs in the Debian distribution + python modules
- pkgver = 7.1.4
+ pkgdesc = A tool designed to make the reporting of bugs in Debian and derived distributions relatively painless
+ pkgver = 11.3.0
pkgrel = 1
- url = http://packages.debian.org/sid/reportbug
+ url = https://salsa.debian.org/reportbug-team/reportbug
arch = any
- license = MIT
+ license = custom
+ makedepends = python-setuptools
+ depends = python
depends = python-debian
depends = python-debianbts
- depends = python-requests
+ depends = python-apt
depends = apt
depends = sensible-utils
- provides = python-reportbug=7.1.4
+ provides = python-reportbug
conflicts = python-reportbug
- options = !emptydirs
- backup = etc/reportbug.conf
- source = http://ftp.debian.org/debian/pool/main/r/reportbug/reportbug_7.1.4.tar.bz2
- sha256sums = 3a4f0366ee7885408a07c24e6067d4e6ed6990ba6d57494226c916dc43fe27c8
+ source = https://salsa.debian.org/reportbug-team/reportbug/-/archive/11.3.0/reportbug-11.3.0.tar.gz
+ source = LICENSE
+ sha256sums = 6f820023355ecf1afca7b49e4ea0b66f6ecafe422b30601e4c7c22e1da56fe34
+ sha256sums = 604ec308937cc86922cd5c64baaf0e63ccbc87b8d8d3a6c1c5b0f2e47182b273
pkgname = reportbug
-
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..b89fd5b49b5a
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,15 @@
+This program is freely distributable per the following license:
+
+Permission to use, copy, modify, and distribute this software and its
+documentation for any purpose and without fee is hereby granted,
+provided that the above copyright notice appears in all copies and that
+both that copyright notice and this permission notice appear in
+supporting documentation.
+
+I DISCLAIM ALL WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING ALL
+IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO EVENT SHALL I
+BE LIABLE FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY
+DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS,
+WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION,
+ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index 162251ac298f..e11556b5508a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,33 @@
-# Contributor: Johannes Dewender arch at JonnyJD dot net
+# Maintainer: Ben Westover <kwestover.kw@gmail.com>
+
pkgname=reportbug
-pkgver=7.1.4
+pkgver=11.3.0
pkgrel=1
-pkgdesc="report bugs in the Debian distribution + python modules"
+pkgdesc="A tool designed to make the reporting of bugs in Debian and derived distributions relatively painless"
arch=('any')
-url="http://packages.debian.org/sid/reportbug"
-license=('MIT')
-depends=('python-debian' 'python-debianbts' 'python-requests' 'apt'
-'sensible-utils')
-provides=("python-reportbug=$pkgver")
+url="https://salsa.debian.org/reportbug-team/reportbug"
+license=('custom')
+depends=('python' 'python-debian' 'python-debianbts' 'python-apt' 'apt' 'sensible-utils')
+makedepends=('python-setuptools')
conflicts=('python-reportbug')
-options=(!emptydirs)
-backup=('etc/reportbug.conf')
-source=(http://ftp.debian.org/debian/pool/main/r/$pkgname/${pkgname}_$pkgver.tar.bz2)
-sha256sums=('3a4f0366ee7885408a07c24e6067d4e6ed6990ba6d57494226c916dc43fe27c8')
+provides=('python-reportbug')
+source=("https://salsa.debian.org/$pkgname-team/$pkgname/-/archive/$pkgver/$pkgname-${pkgver}.tar.gz"
+ "LICENSE" # Extracted from debian/copyright in the source tree
+ )
+sha256sums=('6f820023355ecf1afca7b49e4ea0b66f6ecafe422b30601e4c7c22e1da56fe34'
+ '604ec308937cc86922cd5c64baaf0e63ccbc87b8d8d3a6c1c5b0f2e47182b273')
build() {
- cd "$srcdir/$pkgname-$pkgver"
- python setup.py build
+ cd $pkgname-$pkgver
+ python setup.py build
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
- mkdir -p $pkgdir/usr/share/man/man1/ $pkgdir/usr/share/man/man5/
- install -m644 -t $pkgdir/usr/share/man/man1/ man/*.1
- install -m644 -t $pkgdir/usr/share/man/man5/ man/*.5
- install -Dm644 conf/reportbug.conf $pkgdir/etc/reportbug.conf
+ cd $pkgname-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ mkdir -p $pkgdir/usr/share/man/man1 $pkgdir/usr/share/man/man5
+ install -m644 -t $pkgdir/usr/share/man/man1/ man/*.1
+ install -m644 -t $pkgdir/usr/share/man/man5/ man/*.5
+ install -Dm644 conf/reportbug.conf $pkgdir/etc/reportbug.conf
+ install -Dm644 $srcdir/LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
}
-
-# vim:set ts=2 sw=2 et: