summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2023-07-30 23:59:30 -0700
committerxiota2023-07-30 23:59:30 -0700
commit510d32f6be100ba9d3e92a05f4b54505d5467d57 (patch)
treea85a43fcec27be778e76af56428d8bac22f8e797
parent567f9abc7c506a89185714a49073269e4f6f9f6b (diff)
downloadaur-510d32f6be100ba9d3e92a05f4b54505d5467d57.tar.gz
libgweather-4-git
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD51
2 files changed, 44 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b2ae0715fdce..d1e3e6b4a8f4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libgweather-git
pkgdesc = Location and timezone database and weather-lookup library
- pkgver = 4.2.0.r27.g93127506
+ pkgver = 4.2.0.r28.g1c3dfe68
pkgrel = 1
url = https://gitlab.gnome.org/GNOME/libgweather
arch = x86_64
@@ -16,14 +16,16 @@ pkgbase = libgweather-git
depends = json-glib
depends = libsoup3
depends = libxml2
- provides = libgweather
- provides = libgweather-4
- conflicts = libgweather
- conflicts = libgweather-4
source = libgweather::git+https://gitlab.gnome.org/GNOME/libgweather
sha256sums = SKIP
pkgname = libgweather-git
+ pkgdesc = metapackage to track broken dependencies
+ depends = libgweather-4-git
provides = libgweather
+ conflicts =
+
+pkgname = libgweather-4-git
provides = libgweather-4
provides = libgweather-4.so
+ conflicts = libgweather-4
diff --git a/PKGBUILD b/PKGBUILD
index a891667c3920..0a1debd055fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,24 @@
# Maintainer:
# Contributor: Ignacy KuchciƄski (ignapk) <ignacykuchcinski@gmail.com>
-_pkgname='libgweather'
-pkgname="$_pkgname-git"
-pkgver=4.2.0.r27.g93127506
+_pkgbase="libgweather"
+pkgbase="$_pkgbase-git"
+
+case "${_srcinfo::1}" in
+ 't'|'y'|1)
+ pkgname=(
+ "libgweather-git"
+ "libgweather-4-git"
+ )
+ ;;
+ *)
+ pkgname=(
+ "libgweather-4-git"
+ )
+ ;;
+esac
+
+pkgver=4.2.0.r28.g1c3dfe68
pkgrel=1
pkgdesc='Location and timezone database and weather-lookup library'
url='https://gitlab.gnome.org/GNOME/libgweather'
@@ -26,33 +41,41 @@ makedepends=(
'vala'
)
-provides=(
- 'libgweather'
- 'libgweather-4'
-)
-conflicts=(${provides[@]})
-
-source=("$_pkgname"::"git+$url")
+source=("$_pkgbase"::"git+$url")
sha256sums=('SKIP')
pkgver() {
- cd $_pkgname
+ cd "$srcdir/$_pkgbase"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- arch-meson "$_pkgname" build -D gtk_doc=true
+ arch-meson "$_pkgbase" build -D gtk_doc=true
meson compile -C build
}
check() {
- meson test -C build --print-errorlogs || :
+ meson test -C build --print-errorlogs || true
+}
+
+package_libgweather-git() {
+ pkgdesc='metapackage to track broken dependencies'
+ depends=('libgweather-4-git')
+
+ provides+=(
+ 'libgweather'
+ )
+ conflicts=(${provides[@]})
}
-package() {
+package_libgweather-4-git() {
provides+=(
+ 'libgweather-4'
'libgweather-4.so'
)
+ conflicts=(
+ 'libgweather-4'
+ )
meson install -C build --destdir "$pkgdir"
}