summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMalstrond2019-09-24 20:35:25 +0200
committerMalstrond2019-09-24 20:35:25 +0200
commit518206ac7c6b9adab6032f4d24b3c11b4ac6c40c (patch)
treeb962d8ae0375f77174579d14e5229f8e85f5861f
parent94eb4260f64485d966751d793c8975ae9d9fcd17 (diff)
downloadaur-518206ac7c6b9adab6032f4d24b3c11b4ac6c40c.tar.gz
Updated, new dependencies, moved to /opt
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD42
-rw-r--r--com.ubuntu.user-interface.gschema.xml28
-rw-r--r--inspire.sh12
4 files changed, 74 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 490e9414821f..a7605fd277de 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,31 @@
pkgbase = activinspire
pkgdesc = Presentation Software for use with Promethean Hardware products.
- pkgver = 2.15.67911
+ pkgver = 2.17.68075
pkgrel = 0
url = https://support.prometheanworld.com/product/activinspire
arch = x86_64
license = unknown
depends = lib32-libxmu
depends = lib32-gst-plugins-base
+ depends = lib32-libjpeg-turbo
depends = lib32-libjpeg6-turbo
depends = lib32-libxrender
depends = lib32-libgl
depends = lib32-fontconfig
depends = lib32-openssl-1.0
depends = lib32-nss
+ depends = lib32-libxcomposite
+ depends = lib32-libxcursor
+ depends = lib32-dbus
optdepends = bin32-jre: For using the equation editor
optdepends = activdriver: Driver for Promethean hardware
optdepends = activtools: Tools for Promethean hardware, e.g. calibration or systray monitor
- source = http://activsoftware.co.uk/linux/repos/ubuntu/pool/non-oss/a/activinspire/activinspire_2.15.67911-1.amd64_amd64.deb
+ source = http://activsoftware.co.uk/linux/repos/ubuntu/pool/non-oss/a/activinspire/activinspire_2.17.68075-1.amd64_amd64.deb
source = inspire.sh
- md5sums = de5a3c8345b59de44bdd946ad2d1541a
- md5sums = ff6607cc18a27e2535b8475f5f0db09d
+ source = com.ubuntu.user-interface.gschema.xml
+ md5sums = 59e02cb9f8cd7636507cb4255a7268ec
+ md5sums = 21ff8944ba388a6b5aab894839745132
+ md5sums = e0f2c4078eadd00de8f28159b273e576
pkgname = activinspire
diff --git a/PKGBUILD b/PKGBUILD
index f7212509cae4..b40ef9636e42 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,60 @@
# Maintainer: Malstrond <malstrond@gmail.com>
-# Contributor: Jose Riha <jose1711 gmail com>
+# Contributor: Jean-Baptiste Le Coz <jb.lecoz@gmail.com>
+# Contributor: Jose Riha <jose1711@gmail.com>
# Contributor: Bazon <bazonbloch@arcor.de>
pkgname=activinspire
-pkgver=2.15.67911
+pkgver=2.17.68075
pkgrel=0
pkgdesc="Presentation Software for use with Promethean Hardware products."
arch=('x86_64')
url="https://support.prometheanworld.com/product/activinspire"
license=('unknown')
-depends=(lib32-libxmu lib32-gst-plugins-base lib32-libjpeg6-turbo lib32-libxrender lib32-libgl lib32-fontconfig lib32-openssl-1.0 lib32-nss)
+depends=(lib32-libxmu lib32-gst-plugins-base lib32-libjpeg-turbo lib32-libjpeg6-turbo lib32-libxrender lib32-libgl lib32-fontconfig lib32-openssl-1.0 lib32-nss lib32-libxcomposite lib32-libxcursor lib32-dbus)
optdepends=('bin32-jre: For using the equation editor'
'activdriver: Driver for Promethean hardware'
'activtools: Tools for Promethean hardware, e.g. calibration or systray monitor')
source=("http://activsoftware.co.uk/linux/repos/ubuntu/pool/non-oss/a/activinspire/activinspire_${pkgver}-1.amd64_amd64.deb"
- "inspire.sh")
-md5sums=('de5a3c8345b59de44bdd946ad2d1541a'
- 'ff6607cc18a27e2535b8475f5f0db09d')
+ "inspire.sh"
+ "com.ubuntu.user-interface.gschema.xml")
+md5sums=('59e02cb9f8cd7636507cb4255a7268ec'
+ '21ff8944ba388a6b5aab894839745132'
+ 'e0f2c4078eadd00de8f28159b273e576')
package() {
# The upstream .deb actually includes 3 whole setups:
# 1. The actual files to be used by the package manager (in the . directory),
# 2. a self-contained installer for installing without a package manager (in ./inspire),
# 3. an older version of ActivInspire (13.x) (in ./inspire/DEB).
- # It also includes/etc/xdg (not needed) and /var/Promethean (created with the correct permissions below).
+ # It also includes /etc/xdg (not needed) and /var/Promethean (created with the correct permissions below).
# All except #1 are not extracted to save time while removing them.
bsdtar -C "$pkgdir" --exclude=./inspire --exclude=./var --exclude=./etc -xf data.tar.gz
- # Use /usr instead of /usr/local to match Arch packaging standards.
- mv "$pkgdir"/usr/local/bin "$pkgdir"/usr/
+ # Use /opt instead of /usr/local/bin for binaries to match Arch packaging standards for large self-contained packages.
+ mkdir "$pkgdir"/opt
+ ## These are the binaries.
+ mv "$pkgdir"/usr/local/bin/activsoftware "$pkgdir"/opt/
+ ## This is just a start script, so it can be put into bin alongside inspire.sh.
+ install -dm0755 "$pkgdir"/usr/bin
+ mv "$pkgdir"/usr/local/bin/activityplayer "$pkgdir"/usr/bin/activityplayer
+ rmdir "$pkgdir"/usr/local/bin
rmdir "$pkgdir"/usr/local
- # Because we just changed that, now we need to fix the absolute paths that Promethean uses in their files.
+ # Because we just changed the paths, now we need to fix the absolute paths that Promethean uses in their files.
sed -i "s%/usr/local/bin%/usr/bin%" "$pkgdir"/usr/share/applications/activsoftware.desktop
sed -i "s%/usr/local/bin%/usr/bin%" "$pkgdir"/usr/share/applications/activplayer.desktop
- sed -i "s%/usr/local/bin%/usr/bin%" "$pkgdir"/usr/bin/activsoftware/workbench/activdashboard.sh
- sed -i "s%/usr/local/bin%/usr/bin%" "$pkgdir"/usr/bin/activityplayer
+ sed -i "s%/usr/local/bin%/opt%" "$pkgdir"/opt/activsoftware/workbench/activdashboard.sh
+ sed -i "s%/usr/local/bin%/opt%" "$pkgdir"/usr/bin/activityplayer
+
+ # Install com.ubuntu.user-interface schema need to launch ActivInspire.
+ mkdir "$pkgdir"/usr/share/glib-2.0
+ mkdir "$pkgdir"/usr/share/glib-2.0/schemas
+ install -Dm755 com.ubuntu.user-interface.gschema.xml "$pkgdir"/usr/share/glib-2.0/schemas
# ActivInspire ships with functionality to disable compositing. This should really be handled by the users WM configuration, so we remove that.
rm "$pkgdir"/usr/share/applications/activsoftware-nc.desktop
- # The upstream launch script for ActivInspire only works with Ubuntu, so we replace it with out own.
- install -Dm555 inspire.sh "$pkgdir"/usr/bin/inspire
+ # The upstream launch script for ActivInspire only works with Ubuntu, so we replace it with our own.
+ install -Dm755 inspire.sh "$pkgdir"/usr/bin/inspire
# This software attempts to create a lockfile in /var/Promethean/ActivInspire, the path is hardcoded.
# Since it is started by the user, this directory needs to be world-writable, even if that's a bad idea.
diff --git a/com.ubuntu.user-interface.gschema.xml b/com.ubuntu.user-interface.gschema.xml
new file mode 100644
index 000000000000..62e04e97174c
--- /dev/null
+++ b/com.ubuntu.user-interface.gschema.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<schemalist gettext-domain="gsettings-ubuntu-touch-schemas">
+ <schema path="/com/ubuntu/user-interface/" id="com.ubuntu.user-interface">
+ <key type="a{si}" name="scale-factor">
+ <summary>Per monitor scale factor</summary>
+ <default>{}</default>
+ <description>Per monitor scale factor for all user interface components. The values are stored in a dictionary where the keys are IDs of monitors and the values are the scale factors. The scale factors are not the traditional float scale factors that one might expect. Instead they are integers that need to be divided by 8 before being used as regular scale factors. That limits the number of possible scalings applied to the UI without jeopardizing flexibility (there is still enough possible scalings for all devices out there). This limiting allows for better testing since there is now only a finite number of possible scalings. The scale factor also maps directly to the grid units used in the Ubuntu UI Toolkit where one grid unit is exactly equal to 'scale factor' number of pixels.</description>
+ </key>
+ </schema>
+ <schema path="/com/ubuntu/user-interface/desktop/" id="com.ubuntu.user-interface.desktop">
+ <key type="u" name="scaling-factor">
+ <default>0</default>
+ <summary>Window scaling factor</summary>
+ <description>Integer factor used to scale windows by. For use on high-dpi screens. 0 means pick automatically based on monitor.</description>
+ </key>
+ <key type="d" name="text-scaling-factor">
+ <range min="0.5" max="3.0"/>
+ <default>1.0</default>
+ <summary>Text scaling factor</summary>
+ <description>Factor used to enlarge or reduce text display, without changing font size.</description>
+ </key>
+ <key type="i" name="cursor-size">
+ <default>24</default>
+ <summary>Cursor size</summary>
+ <description>Size of the cursor used as cursor theme.</description>
+ </key>
+ </schema>
+</schemalist> \ No newline at end of file
diff --git a/inspire.sh b/inspire.sh
index 2d99582cb71e..7c594ef3040c 100644
--- a/inspire.sh
+++ b/inspire.sh
@@ -2,7 +2,7 @@
# This script launches ActivInspire. It is partially based on the upstream launch script, with obsolete and Ubuntu-specific stuff fixed or removed.
-cd /usr/bin/activsoftware
+cd /opt/activsoftware
# Promethean software has a bug that often causes it to hang when attempting to close it using the GUI. So we need to kill those instances before launching a new one.
killall -q Inspire
@@ -11,8 +11,12 @@ killall -q Inspire
export JAVA_HOME=/usr/lib32/jvm/java32-8-jre/jre
# Promethean ships ActivInspire with a bunch of libraries. We can't recompile it and there are less problems when using this library versions.
-export LD_LIBRARY_PATH="/usr/bin/activsoftware:/usr/bin/activsoftware/workbench:/usr/bin/activsoftware/workbench/lib:/usr/bin/activsoftware/32bit_libs_for_64bit_OS:$LD_LIBRARY_PATH"
-export GST_PLUGIN_PATH="/usr/bin/activsoftware/32bit_libs_for_64bit_OS:$GST_PLUGIN_PATH"
-export QTWEBKIT_PLUGIN_PATH="/usr/bin/activsoftware/32bit_libs_for_64bit_OS:$QTWEBKIT_PLUGIN_PATH"
+export LD_LIBRARY_PATH="/opt/activsoftware:/opt/activsoftware/workbench:/opt/activsoftware/workbench/lib:/opt/activsoftware/32bit_libs_for_64bit_OS:$LD_LIBRARY_PATH"
+export GST_PLUGIN_PATH="/opt/activsoftware/32bit_libs_for_64bit_OS:$GST_PLUGIN_PATH"
+export QTWEBKIT_PLUGIN_PATH="/opt/activsoftware/32bit_libs_for_64bit_OS:$QTWEBKIT_PLUGIN_PATH"
+# Launch and open the file if one was given as an argument.
./Inspire "$@"
+
+# This is a lock file. Since ActivInspire hangs when attempting to close it, it never gets deleted, causing problems.
+rm -f /dev/shm/sem.promethean \ No newline at end of file