summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2020-04-05 20:25:17 +0000
committerAntonio Rojas2020-04-05 20:25:17 +0000
commit518b77ad1533ad5b1ddb1f0dfecd4a68ef388379 (patch)
tree435753f887b4b434da1b586fb7640821aa405c3f
parentb94a8e964b9311a20a4df1c9a588bd4fe6398e7a (diff)
downloadaur-518b77ad1533ad5b1ddb1f0dfecd4a68ef388379.tar.gz
Update to 0.5.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 93a55edfb368..a3578e03dd9c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = kaidan
pkgdesc = A user-friendly XMPP client for every device
- pkgver = 0.4.1
+ pkgver = 0.5.0
pkgrel = 1
url = https://www.kaidan.im/
arch = x86_64
@@ -9,15 +9,14 @@ pkgbase = kaidan
makedepends = extra-cmake-modules
depends = knotifications
depends = kirigami2
+ depends = qt5-location
depends = qt5-svg
depends = qxmpp
- depends = desktop-file-utils
+ depends = zxing-cpp
depends = hicolor-icon-theme
- source = https://download.kde.org/stable/kaidan/0.4.1/kaidan-0.4.1.tar.xz
- source = https://download.kde.org/stable/kaidan/0.4.1/kaidan-0.4.1.tar.xz.sig
+ source = https://download.kde.org/stable/kaidan/0.5.0/kaidan-0.5.0.tar.xz
validpgpkeys = 03C2D10DC97E5B0BEBB8F3B44663231A91A1E27B
- sha256sums = a9660e2b9c9d9ac6802f7de9a8e1d29a6d552beffcafca27231682bf1038e03c
- sha256sums = SKIP
+ sha256sums = 0f1d267d9c6001a26056789aa521bd5b0e36eea39dff95d4f33dbcd3e5257247
pkgname = kaidan
diff --git a/PKGBUILD b/PKGBUILD
index 4640351af3b4..25a749b10545 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,16 @@
# Maintainer: Antonio Rojas <arojas@archlinux.org>
pkgname=kaidan
-pkgver=0.4.1
+pkgver=0.5.0
pkgrel=1
pkgdesc="A user-friendly XMPP client for every device"
arch=(x86_64)
url="https://www.kaidan.im/"
license=(GPL3 MIT)
-depends=(knotifications kirigami2 qt5-svg qxmpp desktop-file-utils hicolor-icon-theme)
+depends=(knotifications kirigami2 qt5-location qt5-svg qxmpp zxing-cpp hicolor-icon-theme)
makedepends=(extra-cmake-modules)
-source=("https://download.kde.org/stable/$pkgname/$pkgver/$pkgname-$pkgver.tar.xz"{,.sig})
-sha256sums=('a9660e2b9c9d9ac6802f7de9a8e1d29a6d552beffcafca27231682bf1038e03c'
- 'SKIP')
+source=("https://download.kde.org/stable/$pkgname/$pkgver/$pkgname-$pkgver.tar.xz") # {,.sig}
+sha256sums=('0f1d267d9c6001a26056789aa521bd5b0e36eea39dff95d4f33dbcd3e5257247')
validpgpkeys=(03C2D10DC97E5B0BEBB8F3B44663231A91A1E27B) # Linus Jahn <lnj@kaidan.im>
prepare() {
@@ -20,8 +19,7 @@ prepare() {
build() {
cd build
- cmake ../$pkgname-$pkgver \
- -DCMAKE_INSTALL_PREFIX=/usr
+ cmake ../$pkgname-$pkgver
make
}