summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArtemiy Dudko2021-04-28 14:32:02 +0300
committerArtemiy Dudko2021-04-28 14:32:02 +0300
commit51ad46e1e19c23920fee094a8bf99a14f7a78be7 (patch)
treeaa585c8dab53d076100db3fab91aec71ff37a548
downloadaur-51ad46e1e19c23920fee094a8bf99a14f7a78be7.tar.gz
initial
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD27
3 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e2a9f8a90a6d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = socketwrench
+ pkgdesc = Socket Wrench is to Websockets what Postman/Insomnia is to HTTP connections (kinda).
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://asleepysamurai.com/articles/socketwrench
+ arch = x86_64
+ license = custom
+ noextract = SocketWrench-0.0.1-setup.deb
+ source = https://asleepysamurai.com/articles/socketwrench/binary/SocketWrench-0.0.1-setup.deb
+ sha256sums = bcd2dd48a953ff649999ff28bc4fb4b62e4f2f248e74c627332607d554c1d19b
+
+pkgname = socketwrench \ No newline at end of file
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..26a14b2a9dbe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Artemiy Dudko <thepioh(at)zoho(dot)com>
+
+pkgname=socketwrench
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="Socket Wrench is to Websockets what Postman/Insomnia is to HTTP connections (kinda)."
+arch=('x86_64')
+url="https://asleepysamurai.com/articles/socketwrench"
+license=('custom')
+# depends=('alsa-lib' 'gtk3' 'libsecret' 'libxss' 'libxtst' 'nss' 'xdg-utils')
+# optdepends=('libappindicator-gtk3: Systray indicator support'
+# 'org.freedesktop.secrets: Keyring password store support')
+source=("https://asleepysamurai.com/articles/socketwrench/binary/SocketWrench-${pkgver}-setup.deb")
+noextract=("SocketWrench-${pkgver}-setup.deb")
+sha256sums=('bcd2dd48a953ff649999ff28bc4fb4b62e4f2f248e74c627332607d554c1d19b')
+
+package() {
+ bsdtar -O -xf "SocketWrench-${pkgver}-setup.deb" data.tar.xz | bsdtar -C "${pkgdir}" -xJf -
+
+ # Permission fix
+ find "${pkgdir}" -type d -exec chmod 755 {} +
+
+ # # Move license
+ # install -dm755 "${pkgdir}/usr/share/licenses/${pkgname}"
+ # mv "${pkgdir}/usr/lib/slack/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}"
+ # ln -s "/usr/share/licenses/${pkgname}/LICENSE" "${pkgdir}/usr/lib/slack/LICENSE"
+}