summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavide Depau2019-09-09 16:30:25 +0200
committerDavide Depau2019-09-09 16:30:25 +0200
commit51ce36ebc3b57795e76afd750cb80f7894d66153 (patch)
tree2704e5218c36734eeabcfe3dc42ad54161840b16
downloadaur-51ce36ebc3b57795e76afd750cb80f7894d66153.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD35
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d17d54654a20
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = easybashgui-git
+ pkgdesc = Bash function library to have simple GUIs using dialog, yad, zenity, kdialog, xdialog, gtkdialog
+ pkgver = 11.0.1.r0.gc7c6c7c
+ pkgrel = 1
+ url = https://github.com/BashGui/easybashgui
+ arch = any
+ license = GPL3
+ makedepends = make
+ depends = bash
+ optdepends = dialog: ncurses-based TUI dialog
+ optdepends = libnewt: whiptail TUI dialog
+ optdepends = yad: GTK dialog
+ optdepends = gtkdialog: GTK dialog
+ optdepends = zenity: GTK dialog
+ optdepends = xdialog: GTK dialog
+ optdepends = kdialog: KDE/Qt5 dialog
+ provides = easybashgui
+ conflicts = easybashgui
+ source = easybashgui::git+https://github.com/BashGui/easybashgui.git
+ sha256sums = SKIP
+
+pkgname = easybashgui-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f712b0a44b06
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Davide Depau <davide@depau.eu>
+
+_pkgname=easybashgui
+pkgname=$_pkgname-git
+pkgver=11.0.1.r0.gc7c6c7c
+pkgrel=1
+pkgdesc="Bash function library to have simple GUIs using dialog, yad, zenity, kdialog, xdialog, gtkdialog"
+arch=('any')
+depends=('bash')
+makedepends=('make')
+optdepends=(
+ 'dialog: ncurses-based TUI dialog'
+ 'libnewt: whiptail TUI dialog'
+ 'yad: GTK dialog'
+ 'gtkdialog: GTK dialog'
+ 'zenity: GTK dialog'
+ 'xdialog: GTK dialog'
+ 'kdialog: KDE/Qt5 dialog'
+)
+url="https://github.com/BashGui/easybashgui"
+license=('GPL3')
+source=(${_pkgname}::git+https://github.com/BashGui/easybashgui.git)
+sha256sums=('SKIP')
+provides=($_pkgname)
+conflicts=($_pkgname)
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+ make DESTDIR="$pkgdir" install
+}