summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo Mao2023-10-13 19:12:22 +0800
committerLeo Mao2023-10-13 19:12:22 +0800
commit521d6067ecbf8fa5627c3481d9133b08b0339370 (patch)
treec58ca2a1e058281da6d6722df2264ae95a32a9ec
parentbfe1c8cbe3a889b8cbfc740dae5e01605a25e0b6 (diff)
downloadaur-521d6067ecbf8fa5627c3481d9133b08b0339370.tar.gz
upgpkg: python-imageio 2.31.5-2
Migrate to python-build and python-installer.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index af5a2edfa14c..64f47a57517d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = python-imageio
pkgdesc = a Python library that provides an easy interface to read and write a wide range of image data
pkgver = 2.31.5
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/imageio/imageio
arch = any
license = BSD
- makedepends = python
- makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
depends = python-numpy
depends = python-pillow
optdepends = avbin
diff --git a/PKGBUILD b/PKGBUILD
index a2f234faed33..18403a397ce5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname="python-imageio"
_pkgname="imageio"
pkgver=2.31.5
-pkgrel=1
+pkgrel=2
pkgdesc="a Python library that provides an easy interface to read and write a wide range of image data"
arch=('any')
_github="imageio/imageio"
@@ -12,19 +12,19 @@ url="https://github.com/imageio/imageio"
license=('BSD')
depends=('python-numpy' 'python-pillow')
optdepends=('avbin' 'python-imageio-ffmpeg' 'freeimage' 'python-astropy' 'python-simpleitk')
-makedepends=('python' 'python-setuptools')
+makedepends=('python-build' 'python-installer')
source=("$pkgname-$pkgver.tar.gz::https://github.com/imageio/imageio/archive/v${pkgver}.tar.gz")
sha256sums=('a04e1d87e01734c8981c2989b1d2b5bd729821705b09066cfc6c31d5ffe0ffd7')
build() {
msg "Building Python 3"
cd "$srcdir/${_pkgname}-${pkgver}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "$srcdir/${_pkgname}-${pkgver}"
- python setup.py install --root="$pkgdir"/ --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
# remove utilities for downloading binary dependencies