summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2021-01-02 23:19:18 +0100
committerAlexander F. Rødseth2021-01-02 23:19:18 +0100
commit521edc68f9cefb03a2108fc9db443c889b9a5115 (patch)
tree98a757ffc615c988a084fce4524553a484833e16
parent9d9a54d70347108d012e0feb0ff85c091b792677 (diff)
downloadaur-521edc68f9cefb03a2108fc9db443c889b9a5115.tar.gz
New release
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD41
-rwxr-xr-xcheck-for-update.sh17
3 files changed, 23 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 13e4cfe4a09c..913818b83f3a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,16 @@
pkgbase = algernon
pkgdesc = Web server with Lua, Markdown, QUIC, Redis and PostgreSQL support
- pkgver = 1.12.7
+ pkgver = 1.12.11
pkgrel = 1
url = https://algernon.roboticoverlords.org/
- arch = i686
arch = x86_64
- arch = armv6h
- arch = armv7h
- arch = aarch64
license = MIT
- makedepends = git
makedepends = go
optdepends = mariadb: For using the MariaDB/MySQL database backend
optdepends = postgresql: For using the PostgreSQL database backend
optdepends = redis: For using the Redis database backend
- source = algernon-1.12.7.tar.gz::https://github.com/xyproto/algernon/archive/1.12.7.tar.gz
- sha512sums = b696c06815d89d19d0c46159914350c8dd130ef51e60e2c86060c3d15e73e44cbdc68ad4aef4ad508d05e0a0a096ffda7bd83464a08ec7e07fd54f509f880d68
+ source = algernon-1.12.11.tar.gz::https://github.com/xyproto/algernon/archive/1.12.11.tar.gz
+ sha256sums = 0ecedfe86cf2016d8da281ca64d76b9383f76b0d58acee0d80e08c61df5035cc
pkgname = algernon
diff --git a/PKGBUILD b/PKGBUILD
index 90b04becd774..eb09ee6e4f29 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,39 @@
# Maintainer: Kenneth Endfinger <kaendfinger@gmail.com>
pkgname=algernon
-pkgver=1.12.7
+pkgver=1.12.11
pkgrel=1
pkgdesc='Web server with Lua, Markdown, QUIC, Redis and PostgreSQL support'
-arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
+arch=(x86_64)
url='https://algernon.roboticoverlords.org/'
license=(MIT)
-makedepends=(git go)
+makedepends=(go)
optdepends=('mariadb: For using the MariaDB/MySQL database backend'
'postgresql: For using the PostgreSQL database backend'
'redis: For using the Redis database backend')
-source=("algernon-${pkgver}.tar.gz::https://github.com/xyproto/algernon/archive/${pkgver}.tar.gz")
-sha512sums=('b696c06815d89d19d0c46159914350c8dd130ef51e60e2c86060c3d15e73e44cbdc68ad4aef4ad508d05e0a0a096ffda7bd83464a08ec7e07fd54f509f880d68')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/xyproto/algernon/archive/$pkgver.tar.gz")
+sha256sums=('0ecedfe86cf2016d8da281ca64d76b9383f76b0d58acee0d80e08c61df5035cc')
prepare() {
- cd "${pkgname}-${pkgver}"
- go build -mod=vendor -gcflags "all=-trimpath=${PWD}" -asmflags "all=-trimpath=${PWD}" -ldflags "-extldflags ${LDFLAGS}"
+ cd "$pkgname-$pkgver"
+ go build -mod=vendor -buildmode=pie -gcflags "all=-trimpath=$PWD" -asmflags "all=-trimpath=$PWD" -ldflags "-s -w -extldflags $LDFLAGS"
}
package() {
- cd "${pkgname}-${pkgver}"
-
+ cd "$pkgname-$pkgver"
install -Dm755 algernon "$pkgdir/usr/bin/algernon"
- install -Dm755 desktop/mdview "$pkgdir/usr/bin/mdview"
- install -Dm644 system/logrotate "$pkgdir/etc/logrotate.d/algernon"
- install -Dm644 system/serverconf.lua "$pkgdir/etc/algernon/serverconf.lua"
- install -Dm644 desktop/algernon.desktop \
- "$pkgdir/usr/share/applications/algernon.desktop"
- install -Dm644 desktop/algernon_md.desktop \
- "$pkgdir/usr/share/applications/algernon_md.desktop"
- install -Dm644 desktop/markdown.png "$pkgdir/usr/share/pixmaps/markdown.png"
- install -Dm644 system/algernon_dev.service \
- "$pkgdir/usr/share/doc/$pkgname/algernon.service.example"
+ install -d "$pkgdir/usr/share/doc/$pkgname/samples"
cp -r samples "$pkgdir/usr/share/doc/$pkgname/samples"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
-}
-# vim: ts=2 sw=2 et:
+ cd system
+ install -Dm644 logrotate "$pkgdir/etc/logrotate.d/algernon"
+ install -Dm644 serverconf.lua "$pkgdir/etc/algernon/serverconf.lua"
+ install -Dm644 algernon_dev.service "$pkgdir/usr/share/doc/$pkgname/algernon.service.example"
+
+ cd ../desktop
+ install -Dm755 mdview "$pkgdir/usr/bin/mdview"
+ install -Dm644 algernon.desktop "$pkgdir/usr/share/applications/algernon.desktop"
+ install -Dm644 algernon_md.desktop "$pkgdir/usr/share/applications/algernon_md.desktop"
+ install -Dm644 markdown.png "$pkgdir/usr/share/pixmaps/markdown.png"
+}
diff --git a/check-for-update.sh b/check-for-update.sh
deleted file mode 100755
index caaefa5cee09..000000000000
--- a/check-for-update.sh
+++ /dev/null
@@ -1,17 +0,0 @@
-#!/usr/bin/env bash
-set -e
-
-cd $(dirname "${0}")
-
-REPOSITORY="xyproto/algernon"
-
-PKG=$(cat .SRCINFO | grep "pkgbase" | head -n1 | awk '{print $3}')
-CURRENT=$(cat .SRCINFO | grep "pkgver" | head -n1 | awk '{print $3}')
-LATEST=$(curl --silent -L "https://api.github.com/repos/${REPOSITORY}/tags" | jq -r '.[].name' | grep -v -- "-" | grep -v "^v" | grep "\." | head -n1)
-if [ "${LATEST}" != "${CURRENT}" ]
-then
- echo "${PKG} : AUR ${CURRENT} != GitHub ${LATEST}"
- exit 1
-fi
-echo "${PKG} : AUR ${CURRENT} == GitHub ${LATEST}"
-exit 0