summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author71e6fd522018-01-06 08:55:23 +0800
committer71e6fd522018-01-06 08:55:23 +0800
commit52235d90660b9a6e1431766ae48b9ba3bf56812c (patch)
treeee5bde1681ec3864f6a4aa546245ab9d9d49c208
downloadaur-52235d90660b9a6e1431766ae48b9ba3bf56812c.tar.gz
python-sockjs
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD26
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e1ba576dc31c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-sockjs
+ pkgdesc = SockJS server implementation for aiohttp.
+ pkgver = 0.6.0
+ pkgrel = 1
+ url = https://github.com/aio-libs/sockjs/
+ arch = any
+ license = Apache
+ makedepends = python-setuptools
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/s/sockjs/sockjs-0.6.0.tar.gz
+ md5sums = 3ef9509c312d34cc2bb1b996330f2e0e
+
+pkgname = python-sockjs
+ depends = python
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e4f9ba3007cf
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.SRCINFO
+!PKGBUILD
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..199f1a7d1482
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: 71e6fd52 <DAStudio.71e6fd52@gmail.com>
+
+pkgbase=('python-sockjs')
+pkgname=('python-sockjs')
+_module='sockjs'
+pkgver='0.6.0'
+pkgrel=1
+pkgdesc="SockJS server implementation for aiohttp."
+url="https://github.com/aio-libs/sockjs/"
+depends=('python')
+makedepends=('python-setuptools')
+license=('Apache')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/s/sockjs/sockjs-${pkgver}.tar.gz")
+md5sums=('3ef9509c312d34cc2bb1b996330f2e0e')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}