summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOliver Rümpelein2020-01-03 22:01:37 +0100
committerOliver Rümpelein2020-01-03 22:18:32 +0100
commit525c79d4456827a38e1ba81c41d7b6cb2ae29e3e (patch)
tree3cebb2195c778d4dfcb81c55485ef13a556903e2
downloadaur-525c79d4456827a38e1ba81c41d7b6cb2ae29e3e.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--LICENSE8
-rw-r--r--PKGBUILD31
-rw-r--r--studiolink.desktop9
-rw-r--r--studiolink.svg202
5 files changed, 265 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fe46d4561d33
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = studiolink-standalone-bin
+ pkgdesc = A SIP application to create high quality Audio over IP (AoIP) connections.
+ pkgver = v19.09.0
+ pkgrel = 1
+ url = https://studio-link.de
+ arch = x86_64
+ license = custom
+ depends = alsa-lib
+ depends = libpulse
+ depends = hicolor-icon-theme
+ source = https://download.studio.link/releases/v19.09.0-beta/studio-link-standalone-linux.zip
+ sha512sums = 12190ab20e5706f9d816b67737a5f14a2f79f610dbbbb53ffe7304b46c45ed85e4f2e8bd459c0fd949522c59056d8fd22602f78ca69ae8f9355a3b97a0cbbc6d
+
+pkgname = studiolink-standalone-bin
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..9b6f659af7d5
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,8 @@
+LICENSE AGREEMENT FOR STUDIOLINK SOFTWARE:
+Copyright (c) 2013-2019 Sebastian Reimers
+
+Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..884f28d0374a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Oliver Rümpelein <arch@pheerai.de>
+pkgname=studiolink-standalone-bin
+pkgver=v19.09.0
+_pkgver=${pkgver}-beta
+pkgrel=1
+pkgdesc="A SIP application to create high quality Audio over IP (AoIP) connections."
+arch=('x86_64')
+url="https://studio-link.de"
+license=('custom')
+depends=('alsa-lib' 'libpulse' 'hicolor-icon-theme')
+opt_depends=('jack: For jack support')
+source=("https://download.studio.link/releases/${_pkgver}/studio-link-standalone-linux.zip"
+ "LICENSE"
+ "studiolink.desktop"
+ "studiolink.svg")
+sha512sums=('12190ab20e5706f9d816b67737a5f14a2f79f610dbbbb53ffe7304b46c45ed85e4f2e8bd459c0fd949522c59056d8fd22602f78ca69ae8f9355a3b97a0cbbc6d'
+ 'a3c168d3605190b7de36707a42d1450a22bd0d0b50b52bb4e0a8b169c1035f04f58dca8227d8557f9f0cc574d18323780efa035fd6cd57c3bb35d69a3c517937'
+ '2e80376c6ac640da556fa7861d54b44378c18d19a20257e5eef03d72e9c4554d4894c8e6b6168e672bd43e9272071859bcdcf65c75f5006c20c0d689b8080133'
+ '3aae487ecddedf17f83f0719c33770f9cb3998681ea3fb39b5c304245c73fdfd7604aee3fff1f54c11ad93256ab778eb3f3467e71c870e8dba8eab43cc2ceef6')
+
+package()
+{
+ strip ${srcdir}/studio-link-standalone
+ install -Dm755 ${srcdir}/studio-link-standalone ${pkgdir}/usr/bin/studiolink
+
+ install -Dm644 ${srcdir}/LICENSE "${pkgdir}/usr/share/licenses/studiolink-standalone-bin/LICENSE"
+
+ # freedesktop.org compatibility
+ install -Dm644 ${srcdir}/studiolink.desktop ${pkgdir}/usr/share/applications/studiolink.desktop
+ install -Dm644 ${srcdir}/studiolink.svg ${pkgdir}/usr/share/icons/hicolor/scalable/apps/studiolink.svg
+}
diff --git a/studiolink.desktop b/studiolink.desktop
new file mode 100644
index 000000000000..bd1c21156e95
--- /dev/null
+++ b/studiolink.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Studio Link
+Comment=High quality SIP connections for producers.
+Exec=studiolink
+Icon=studiolink
+Terminal=false
+Type=Application
+X-MultipleArgs=false
+Categories=Audio;AudioVideo; \ No newline at end of file
diff --git a/studiolink.svg b/studiolink.svg
new file mode 100644
index 000000000000..6526b2e26beb
--- /dev/null
+++ b/studiolink.svg
@@ -0,0 +1,202 @@
+<?xml version="1.0" encoding="UTF-8" standalone="no"?>
+<svg
+ xmlns:dc="http://purl.org/dc/elements/1.1/"
+ xmlns:cc="http://creativecommons.org/ns#"
+ xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
+ xmlns:svg="http://www.w3.org/2000/svg"
+ xmlns="http://www.w3.org/2000/svg"
+ xmlns:sodipodi="http://sodipodi.sourceforge.net/DTD/sodipodi-0.dtd"
+ xmlns:inkscape="http://www.inkscape.org/namespaces/inkscape"
+ version="1.2"
+ width="42.873226"
+ height="50.418896"
+ viewBox="0 0 1134.3542 1333.9973"
+ preserveAspectRatio="xMidYMid"
+ id="svg4846"
+ sodipodi:docname="studiolink.svg"
+ style="fill-rule:evenodd;stroke-width:28.22200012;stroke-linejoin:round"
+ inkscape:version="0.92.4 5da689c313, 2019-01-14">
+ <metadata
+ id="metadata4850">
+ <rdf:RDF>
+ <cc:Work
+ rdf:about="">
+ <dc:format>image/svg+xml</dc:format>
+ <dc:type
+ rdf:resource="http://purl.org/dc/dcmitype/StillImage" />
+ <dc:title></dc:title>
+ </cc:Work>
+ </rdf:RDF>
+ </metadata>
+ <sodipodi:namedview
+ pagecolor="#ffffff"
+ bordercolor="#666666"
+ borderopacity="1"
+ objecttolerance="10"
+ gridtolerance="10"
+ guidetolerance="10"
+ inkscape:pageopacity="0"
+ inkscape:pageshadow="2"
+ inkscape:window-width="1918"
+ inkscape:window-height="1052"
+ id="namedview4848"
+ showgrid="false"
+ fit-margin-left="-0.1"
+ fit-margin-top="0"
+ fit-margin-right="0"
+ fit-margin-bottom="0"
+ inkscape:zoom="4.6900855"
+ inkscape:cx="2.8425314"
+ inkscape:cy="17.807818"
+ inkscape:window-x="0"
+ inkscape:window-y="26"
+ inkscape:window-maximized="1"
+ inkscape:current-layer="g4844" />
+ <defs
+ class="ClipPathGroup"
+ id="defs4726">
+ <clipPath
+ id="a"
+ clipPathUnits="userSpaceOnUse">
+ <path
+ d="M 0,0 H 10590 V 10940 H 0 Z"
+ id="path4723"
+ inkscape:connector-curvature="0" />
+ </clipPath>
+ </defs>
+ <g
+ class="SlideGroup"
+ id="g4844"
+ transform="translate(-4685.0308,0.99861756)">
+ <g
+ id="g4985">
+ <g
+ transform="translate(-906.615,-4518)"
+ id="g4732"
+ class="com.sun.star.drawing.OpenBezierShape">
+ <path
+ style="fill:none"
+ inkscape:connector-curvature="0"
+ id="path4728"
+ d="m 5721,4517 h 995 v 997 h -995 z"
+ class="BoundingBox" />
+ <path
+ style="fill:none;stroke:#ff7e02;stroke-width:190"
+ inkscape:connector-curvature="0"
+ id="path4730"
+ d="m 6104,5417 -249,-248 c -183,-184 332,-703 517,-518 l 248,249" />
+ </g>
+ <g
+ transform="translate(-906.615,-4518)"
+ id="g4740"
+ class="com.sun.star.drawing.PolyPolygonShape">
+ <path
+ style="fill:none"
+ inkscape:connector-curvature="0"
+ id="path4734"
+ d="m 5824,5089 h 435 v 434 h -435 z"
+ class="BoundingBox" />
+ <path
+ style="fill:#171616"
+ inkscape:connector-curvature="0"
+ id="path4736"
+ d="m 6162,5379 -48,48 -195,-195 47,-48 z" />
+ <path
+ style="fill:#ff7e02;stroke:#ff7e02;stroke-width:190"
+ inkscape:connector-curvature="0"
+ id="path4738"
+ d="m 6162,5379 -48,48 -195,-195 47,-48 z" />
+ </g>
+ <g
+ transform="translate(-906.615,-4518)"
+ id="g4748"
+ class="com.sun.star.drawing.PolyPolygonShape">
+ <path
+ style="fill:none"
+ inkscape:connector-curvature="0"
+ id="path4742"
+ d="m 6292,4620 h 434 v 435 h -434 z"
+ class="BoundingBox" />
+ <path
+ style="fill:#171616"
+ inkscape:connector-curvature="0"
+ id="path4744"
+ d="m 6630,4910 -47,48 -196,-195 48,-48 z" />
+ <path
+ style="fill:none;stroke:#ff7e02;stroke-width:190"
+ inkscape:connector-curvature="0"
+ id="path4746"
+ d="m 6630,4910 -47,48 -196,-195 48,-48 z" />
+ </g>
+ <g
+ transform="translate(-906.615,-4518)"
+ id="g4754"
+ class="com.sun.star.drawing.OpenBezierShape">
+ <path
+ style="fill:none"
+ inkscape:connector-curvature="0"
+ id="path4750"
+ d="m 5600,4867 h 982 v 984 h -982 z"
+ class="BoundingBox" />
+ <path
+ style="fill:none;stroke:#ff7e02;stroke-width:190"
+ inkscape:connector-curvature="0"
+ id="path4752"
+ d="m 6212,4962 248,247 c 68.794,68.794 -9.175,223.576 -126.577,350.82 C 6203.373,5700.773 6024.936,5807.936 5944,5727 l -249,-248" />
+ </g>
+ <g
+ transform="translate(-906.615,-4518)"
+ id="g4760"
+ class="com.sun.star.drawing.PolyPolygonShape">
+ <path
+ style="fill:none"
+ inkscape:connector-curvature="0"
+ id="path4756"
+ d="m 6153,4951 h 245 v 244 h -245 z"
+ class="BoundingBox" />
+ <path
+ style="fill:#171616"
+ inkscape:connector-curvature="0"
+ id="path4758"
+ d="m 6153,4999 48,-48 195,196 -47,47 z" />
+ </g>
+ <g
+ transform="translate(-906.615,-4518)"
+ id="g4766"
+ class="com.sun.star.drawing.PolyPolygonShape">
+ <path
+ style="fill:none"
+ inkscape:connector-curvature="0"
+ id="path4762"
+ d="m 6058,4856 h 435 v 434 h -435 z"
+ class="BoundingBox" />
+ <path
+ style="fill:none;stroke:#ff7e02;stroke-width:190"
+ inkscape:connector-curvature="0"
+ id="path4764"
+ d="m 6153,4999 48,-48 195,196 -47,47 z" />
+ </g>
+ <g
+ transform="translate(-906.615,-4518)"
+ id="g4774"
+ class="com.sun.star.drawing.PolyPolygonShape">
+ <path
+ style="fill:none"
+ inkscape:connector-curvature="0"
+ id="path4768"
+ d="m 5589,5325 h 435 v 435 h -435 z"
+ class="BoundingBox" />
+ <path
+ style="fill:#171616"
+ inkscape:connector-curvature="0"
+ id="path4770"
+ d="m 5684,5468 48,-48 195,196 -47,47 z" />
+ <path
+ style="fill:none;stroke:#ff7e02;stroke-width:190"
+ inkscape:connector-curvature="0"
+ id="path4772"
+ d="m 5684,5468 48,-48 195,196 -47,47 z" />
+ </g>
+ </g>
+ </g>
+</svg>