summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12018-01-08 22:14:45 +0800
committerChocobo12018-01-08 22:18:56 +0800
commit525e4bf4ebe9349ef41785a87bf86ac4a2da77a9 (patch)
tree31ae7348c604ec169cd3275e98b12de687071ef6
downloadaur-525e4bf4ebe9349ef41785a87bf86ac4a2da77a9.tar.gz
newpkg: inotify-tools-git 3.20.1.r0.ge203934-1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD43
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d4295ff49a36
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = inotify-tools-git
+ pkgdesc = C library and a set of command-line programs for Linux providing a simple interface to inotify
+ pkgver = 3.20.1.r0.ge203934
+ pkgrel = 1
+ url = https://github.com/rvoicilas/inotify-tools/wiki
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = glibc
+ provides = inotify-tools
+ conflicts = inotify-tools
+ options = staticlibs
+ source = git+https://github.com/rvoicilas/inotify-tools.git
+ sha256sums = SKIP
+
+pkgname = inotify-tools-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..696aa73c2fa3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=inotify-tools-git
+pkgver=3.20.1.r0.ge203934
+pkgrel=1
+pkgdesc="C library and a set of command-line programs for Linux providing a simple interface to inotify"
+arch=('i686' 'x86_64')
+url="https://github.com/rvoicilas/inotify-tools/wiki"
+license=('GPL')
+depends=('glibc')
+makedepends=('git')
+provides=('inotify-tools')
+conflicts=('inotify-tools')
+options=('staticlibs')
+source=("git+https://github.com/rvoicilas/inotify-tools.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "inotify-tools"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "inotify-tools"
+
+ ./autogen.sh
+ ./configure --prefix="/usr"
+ make
+}
+
+check() {
+ cd "inotify-tools"
+
+ make check
+}
+
+package() {
+ cd "inotify-tools"
+
+ make DESTDIR="$pkgdir" install
+}