summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2021-07-12 16:41:46 +0200
committerbartus2021-07-12 16:43:32 +0200
commit52867abd71b9845dab4134a1b7a618e15e521094 (patch)
treeb511304544cd6372bbc8b1ddf6af80fd8c5ae3ba
parente2da15961aa5992df93458f65ccc1841990bb9e4 (diff)
downloadaur-52867abd71b9845dab4134a1b7a618e15e521094.tar.gz
Fix build against openexr:3
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD13
-rw-r--r--openexr3.patch398
3 files changed, 412 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6fba7efecc58..68c4b21aaaff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -26,23 +26,25 @@ pkgbase = appleseed
provides = appleseed
conflicts = appleseed
source = appleseed_2.1.0-beta.tgz::https://github.com/appleseedhq/appleseed/archive/2.1.0-beta.tar.gz
- source = osl_1.11.8.patch::https://github.com/appleseedhq/appleseed/pull/2900.patch
source = cmake.extra.install.dirs.remove.patch
+ source = osl_1.11.8.patch::https://github.com/appleseedhq/appleseed/pull/2900.patch
source = boost_107200.patch
source = python39.patch
source = oiio_cxx_std_14.patch
+ source = openexr3.patch
sha256sums = 5f8599c64a9c1dbdf0d8ee13a4d395b03e9bcba17fec731526109437ab760898
- sha256sums = 0171eaa9ec499ecf74ac8878dbacfb28f81094e9a7bed46819314613e6ae7133
sha256sums = 87b987f006e45d11cc4dfec2bd37fd2b760fd2bdbf06f48e7d467cbca9b2b301
+ sha256sums = 0171eaa9ec499ecf74ac8878dbacfb28f81094e9a7bed46819314613e6ae7133
sha256sums = 125d5191b52122434984ccc11a6f2677697a4fee3b9f4571ee0d3742a43a74a4
sha256sums = 5e0bffb5a1c1a877abf75c55a5485b2bf6220caa9886ba073e7513cbf4245886
sha256sums = 2e619021829cebfa5e5a805c6a38d7946c370e3a1666aab1cacccab8f78f26bc
+ sha256sums = b6ed6ca0034a2ec81ecf8f44e11dba7b3469130a3106fcca58318174003e2642
b2sums = 67005025f46c8fa8ac236e56e8fc3f447bd2e2a9862f8db37015cafeaf4d67536dc01aace81f2683586eced54221284e6cc7d697399f873c4e53de5b0fd59ae0
- b2sums = cc21c08931d4e5060bbf9b8d2732e68eb28edc923e952db09665e2f63a0918e24f6d35f39a2ea2048a6b5ad67833df08bc9a5e1fea065e1df975ca5e40d414f0
b2sums = 85d278ea12672e44657fbfe8695744508db88cea54dbc93410632b05175c94a5e29e28dfb739ba88ec10a2449ff499484854ba177db03f5e41b24d2b8e6b9328
+ b2sums = cc21c08931d4e5060bbf9b8d2732e68eb28edc923e952db09665e2f63a0918e24f6d35f39a2ea2048a6b5ad67833df08bc9a5e1fea065e1df975ca5e40d414f0
b2sums = 74ee6d8ef1d26155ec3775bf9c8793a760939835e8b09d574d0c152ecca90b78e31e8c1de3b576cf13c640131d5ce757c8488ab902439decd5f80b8d511f6251
b2sums = 115d48a3b570f9b7c1bbd5b38f1b5bdb8ded6b21ccb9c83ccbb305fad00942336b2cfd7ec3674a80a94edec0512d14c9d7ada4eed57a08f8d78ab23b7e636600
b2sums = 05909887108da2e7247697048dee9da2a6e50fcabaa55917ea855d31101680f07284274ed85d4a9a2937255d816560fb6cfb77297f4f7f002b25cfd3197a0784
+ b2sums = 9499c09e99fba96958861f1da7833728850c5581cf371a8f6994012288445d8fd24ec3cfe4f9e22a5860c930d91e710ffed9b33ba3cf2d8385ffa1cda4909528
pkgname = appleseed
-
diff --git a/PKGBUILD b/PKGBUILD
index 7278c1dc38b6..657c4372eb94 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,24 +16,27 @@ makedepends=(boost{,-python2} cmake ninja)
options=()
_github="https://github.com/${pkgname}hq/${pkgname}"
source=(appleseed_${_pkgver}.tgz::"${_github}/archive/${_pkgver}.tar.gz"
- osl_1.11.8.patch::"https://github.com/appleseedhq/appleseed/pull/2900.patch"
"cmake.extra.install.dirs.remove.patch"
+ osl_1.11.8.patch::"https://github.com/appleseedhq/appleseed/pull/2900.patch"
"boost_107200.patch"
"python39.patch"
"oiio_cxx_std_14.patch"
+ "openexr3.patch"
)
sha256sums=('5f8599c64a9c1dbdf0d8ee13a4d395b03e9bcba17fec731526109437ab760898'
- '0171eaa9ec499ecf74ac8878dbacfb28f81094e9a7bed46819314613e6ae7133'
'87b987f006e45d11cc4dfec2bd37fd2b760fd2bdbf06f48e7d467cbca9b2b301'
+ '0171eaa9ec499ecf74ac8878dbacfb28f81094e9a7bed46819314613e6ae7133'
'125d5191b52122434984ccc11a6f2677697a4fee3b9f4571ee0d3742a43a74a4'
'5e0bffb5a1c1a877abf75c55a5485b2bf6220caa9886ba073e7513cbf4245886'
- '2e619021829cebfa5e5a805c6a38d7946c370e3a1666aab1cacccab8f78f26bc')
+ '2e619021829cebfa5e5a805c6a38d7946c370e3a1666aab1cacccab8f78f26bc'
+ 'b6ed6ca0034a2ec81ecf8f44e11dba7b3469130a3106fcca58318174003e2642')
b2sums=('67005025f46c8fa8ac236e56e8fc3f447bd2e2a9862f8db37015cafeaf4d67536dc01aace81f2683586eced54221284e6cc7d697399f873c4e53de5b0fd59ae0'
- 'cc21c08931d4e5060bbf9b8d2732e68eb28edc923e952db09665e2f63a0918e24f6d35f39a2ea2048a6b5ad67833df08bc9a5e1fea065e1df975ca5e40d414f0'
'85d278ea12672e44657fbfe8695744508db88cea54dbc93410632b05175c94a5e29e28dfb739ba88ec10a2449ff499484854ba177db03f5e41b24d2b8e6b9328'
+ 'cc21c08931d4e5060bbf9b8d2732e68eb28edc923e952db09665e2f63a0918e24f6d35f39a2ea2048a6b5ad67833df08bc9a5e1fea065e1df975ca5e40d414f0'
'74ee6d8ef1d26155ec3775bf9c8793a760939835e8b09d574d0c152ecca90b78e31e8c1de3b576cf13c640131d5ce757c8488ab902439decd5f80b8d511f6251'
'115d48a3b570f9b7c1bbd5b38f1b5bdb8ded6b21ccb9c83ccbb305fad00942336b2cfd7ec3674a80a94edec0512d14c9d7ada4eed57a08f8d78ab23b7e636600'
- '05909887108da2e7247697048dee9da2a6e50fcabaa55917ea855d31101680f07284274ed85d4a9a2937255d816560fb6cfb77297f4f7f002b25cfd3197a0784')
+ '05909887108da2e7247697048dee9da2a6e50fcabaa55917ea855d31101680f07284274ed85d4a9a2937255d816560fb6cfb77297f4f7f002b25cfd3197a0784'
+ '9499c09e99fba96958861f1da7833728850c5581cf371a8f6994012288445d8fd24ec3cfe4f9e22a5860c930d91e710ffed9b33ba3cf2d8385ffa1cda4909528')
prepare() {
for patch in "${srcdir}"/*.patch; do
diff --git a/openexr3.patch b/openexr3.patch
new file mode 100644
index 000000000000..3cd09316c872
--- /dev/null
+++ b/openexr3.patch
@@ -0,0 +1,398 @@
+diff --git a/cmake/modules/FindOpenEXR.cmake b/cmake/modules/FindOpenEXR.cmake
+index 287342e9d..a2f7b4c62 100644
+--- a/cmake/modules/FindOpenEXR.cmake
++++ b/cmake/modules/FindOpenEXR.cmake
+@@ -1,93 +1,138 @@
+-
+-#
+-# This source file is part of appleseed.
+-# Visit https://appleseedhq.net/ for additional information and resources.
+-#
+-# This software is released under the MIT license.
+-#
+-# Copyright (c) 2013-2018 Esteban Tovagliari, The appleseedhq Organization
++# - Find OpenEXR library
++# Find the native OpenEXR includes and library
++# This module defines
++# OPENEXR_INCLUDE_DIRS, where to find ImfXdr.h, etc. Set when
++# OPENEXR_INCLUDE_DIR is found.
++# OPENEXR_LIBRARIES, libraries to link against to use OpenEXR.
++# OPENEXR_ROOT_DIR, The base directory to search for OpenEXR.
++# This can also be an environment variable.
++# OPENEXR_FOUND, If false, do not try to use OpenEXR.
+ #
+-# Permission is hereby granted, free of charge, to any person obtaining a copy
+-# of this software and associated documentation files (the "Software"), to deal
+-# in the Software without restriction, including without limitation the rights
+-# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+-# copies of the Software, and to permit persons to whom the Software is
+-# furnished to do so, subject to the following conditions:
++# For individual library access these advanced settings are available
++# OPENEXR_HALF_LIBRARY, Path to Half library
++# OPENEXR_IEX_LIBRARY, Path to Half library
++# OPENEXR_ILMIMF_LIBRARY, Path to Ilmimf library
++# OPENEXR_ILMTHREAD_LIBRARY, Path to IlmThread library
++# OPENEXR_IMATH_LIBRARY, Path to Imath library
+ #
+-# The above copyright notice and this permission notice shall be included in
+-# all copies or substantial portions of the Software.
+-#
+-# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+-# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+-# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+-# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+-# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+-# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+-# THE SOFTWARE.
+-#
+-
++# also defined, but not for general use are
++# OPENEXR_LIBRARY, where to find the OpenEXR library.
+
++#=============================================================================
++# Copyright 2011 Blender Foundation.
+ #
+-# Find OpenEXR headers and libraries.
+-#
+-# This module can take the following variables to define
+-# custom search locations:
+-#
+-# OPENEXR_ROOT
+-# OPENEXR_LOCATION
++# Distributed under the OSI-approved BSD 3-Clause License,
++# see accompanying file BSD-3-Clause-license.txt for details.
++#=============================================================================
+
+-# This module defines the following variables:
+-#
+-# OPENEXR_FOUND True if OpenEXR was found
+-# OPENEXR_INCLUDE_DIRS Where to find OpenEXR header files
+-# OPENEXR_LIBRARIES List of OpenEXR libraries to link against
+-#
++# If OPENEXR_ROOT_DIR was defined in the environment, use it.
++IF(NOT OPENEXR_ROOT_DIR AND NOT $ENV{OPENEXR_ROOT_DIR} STREQUAL "")
++ SET(OPENEXR_ROOT_DIR $ENV{OPENEXR_ROOT_DIR})
++ENDIF()
+
+-include (FindPackageHandleStandardArgs)
++# Old versions (before 2.0?) do not have any version string, just assuming this should be fine though.
++SET(_openexr_libs_ver_init "2.0")
+
+-find_path (OPENEXR_INCLUDE_DIR NAMES ImfHeader.h
+- PATH_SUFFIXES OpenEXR
+- HINTS ${OPENEXR_ROOT}/include
+- ${OPENEXR_LOCATION}/include
+- /usr/local/include
+- /usr/include
++SET(_openexr_FIND_COMPONENTS
++ Iex
++ Imath
++ OpenEXR
++ IlmThread
+ )
+
+-find_library (OPENEXR_IMF_LIBRARY NAMES IlmImf-2_3 IlmImf-2_2 IlmImf
+- PATH_SUFFIXES lib64 lib
+- HINTS ${OPENEXR_ROOT}
+- ${OPENEXR_LOCATION}
+- /usr/local
+- /usr
++SET(_openexr_SEARCH_DIRS
++ ${OPENEXR_ROOT_DIR}
++ /opt/lib/openexr
+ )
+
+-find_library (OPENEXR_THREADS_LIBRARY
+- NAMES IlmThread-2_3 IlmThread-2_2 IlmThread
+- PATH_SUFFIXES lib64 lib
+- HINTS ${OPENEXR_ROOT}
+- ${OPENEXR_LOCATION}
+- /usr/local
+- /usr
++FIND_PATH(OPENEXR_INCLUDE_DIR
++ NAMES
++ OpenEXR/ImfXdr.h
++ HINTS
++ ${_openexr_SEARCH_DIRS}
++ PATH_SUFFIXES
++ include
+ )
+
+-# Handle the QUIETLY and REQUIRED arguments and set OPENEXR_FOUND.
+-find_package_handle_standard_args (OPENEXR DEFAULT_MSG
+- OPENEXR_INCLUDE_DIR
+- OPENEXR_IMF_LIBRARY
+- OPENEXR_THREADS_LIBRARY
+-)
++# If the headers were found, get the version from config file, if not already set.
++IF(OPENEXR_INCLUDE_DIR)
++ IF(NOT OPENEXR_VERSION)
++
++ FIND_FILE(_openexr_CONFIG
++ NAMES
++ OpenEXRConfig.h
++ PATHS
++ "${OPENEXR_INCLUDE_DIR}"
++ "${OPENEXR_INCLUDE_DIR}/OpenEXR"
++ NO_DEFAULT_PATH
++ )
+
+-# Set the output variables.
+-if (OPENEXR_FOUND)
+- set (OPENEXR_INCLUDE_DIRS ${OPENEXR_INCLUDE_DIR})
+- set (OPENEXR_LIBRARIES ${OPENEXR_IMF_LIBRARY} ${OPENEXR_THREADS_LIBRARY})
+-else ()
+- set (OPENEXR_INCLUDE_DIRS)
+- set (OPENEXR_LIBRARIES)
+-endif ()
+-
+-mark_as_advanced (
+- OPENEXR_INCLUDE_DIR
+- OPENEXR_IMF_LIBRARY
+- OPENEXR_THREADS_LIBRARY
++ IF(_openexr_CONFIG)
++ FILE(STRINGS "${_openexr_CONFIG}" OPENEXR_BUILD_SPECIFICATION
++ REGEX "^[ \t]*#define[ \t]+OPENEXR_VERSION_STRING[ \t]+\"[.0-9]+\".*$")
++ ELSE()
++ MESSAGE(WARNING "Could not find \"OpenEXRConfig.h\" in \"${OPENEXR_INCLUDE_DIR}\"")
++ ENDIF()
++
++ IF(OPENEXR_BUILD_SPECIFICATION)
++ MESSAGE(STATUS "${OPENEXR_BUILD_SPECIFICATION}")
++ STRING(REGEX REPLACE ".*#define[ \t]+OPENEXR_VERSION_STRING[ \t]+\"([.0-9]+)\".*"
++ "\\1" _openexr_libs_ver_init ${OPENEXR_BUILD_SPECIFICATION})
++ ELSE()
++ MESSAGE(WARNING "Could not determine ILMBase library version, assuming ${_openexr_libs_ver_init}.")
++ ENDIF()
++
++ UNSET(_openexr_CONFIG CACHE)
++
++ ENDIF()
++ENDIF()
++
++SET("OPENEXR_VERSION" ${_openexr_libs_ver_init} CACHE STRING "Version of OpenEXR lib")
++UNSET(_openexr_libs_ver_init)
++
++STRING(REGEX REPLACE "([0-9]+)[.]([0-9]+).*" "\\1_\\2" _openexr_libs_ver ${OPENEXR_VERSION})
++
++SET(_openexr_LIBRARIES)
++FOREACH(COMPONENT ${_openexr_FIND_COMPONENTS})
++ STRING(TOUPPER ${COMPONENT} UPPERCOMPONENT)
++
++ FIND_LIBRARY(OPENEXR_${UPPERCOMPONENT}_LIBRARY
++ NAMES
++ ${COMPONENT}-${_openexr_libs_ver} ${COMPONENT}
++ NAMES_PER_DIR
++ HINTS
++ ${_openexr_SEARCH_DIRS}
++ PATH_SUFFIXES
++ lib64 lib
++ )
++ LIST(APPEND _openexr_LIBRARIES "${OPENEXR_${UPPERCOMPONENT}_LIBRARY}")
++ENDFOREACH()
++
++UNSET(_openexr_libs_ver)
++
++# handle the QUIETLY and REQUIRED arguments and set OPENEXR_FOUND to TRUE if
++# all listed variables are TRUE
++INCLUDE(FindPackageHandleStandardArgs)
++FIND_PACKAGE_HANDLE_STANDARD_ARGS(OpenEXR DEFAULT_MSG
++ _openexr_LIBRARIES OPENEXR_INCLUDE_DIR)
++
++IF(OPENEXR_FOUND)
++ SET(OPENEXR_LIBRARIES ${_openexr_LIBRARIES})
++ # Both include paths are needed because of dummy OSL headers mixing #include <OpenEXR/foo.h> and #include <foo.h> :(
++ SET(OPENEXR_INCLUDE_DIRS ${OPENEXR_INCLUDE_DIR} ${OPENEXR_INCLUDE_DIR}/OpenEXR ${OPENEXR_INCLUDE_DIR}/Imath)
++ENDIF()
++
++MARK_AS_ADVANCED(
++ OPENEXR_INCLUDE_DIR
++ OPENEXR_VERSION
+ )
++FOREACH(COMPONENT ${_openexr_FIND_COMPONENTS})
++ STRING(TOUPPER ${COMPONENT} UPPERCOMPONENT)
++ MARK_AS_ADVANCED(OPENEXR_${UPPERCOMPONENT}_LIBRARY)
++ENDFOREACH()
++
++UNSET(COMPONENT)
++UNSET(UPPERCOMPONENT)
++UNSET(_openexr_FIND_COMPONENTS)
++UNSET(_openexr_LIBRARIES)
++UNSET(_openexr_SEARCH_DIRS)
+diff --git a/src/appleseed/foundation/core/thirdparties.cpp b/src/appleseed/foundation/core/thirdparties.cpp
+index 7196557bc..845cd205e 100644
+--- a/src/appleseed/foundation/core/thirdparties.cpp
++++ b/src/appleseed/foundation/core/thirdparties.cpp
+@@ -42,7 +42,6 @@
+
+ // IlmBase headers.
+ #include "foundation/platform/_beginexrheaders.h"
+-#include <OpenEXR/IlmBaseConfig.h>
+ #include "foundation/platform/_endexrheaders.h"
+
+ // LZ4 headers.
+@@ -121,7 +120,6 @@ LibraryVersionArray ThirdParties::get_versions()
+ versions.push_back(APIStringPair("OpenColorIO", OCIO_VERSION));
+ #endif
+
+- versions.push_back(APIStringPair("IlmBase", ILMBASE_VERSION_STRING));
+ versions.push_back(APIStringPair("libjpeg-turbo", LibJpegTurboVersion));
+ versions.push_back(APIStringPair("LibTIFF", LibTIFFVersion));
+ versions.push_back(APIStringPair("LZ4", format("{0}.{1}.{2}", LZ4_VERSION_MAJOR, LZ4_VERSION_MINOR, LZ4_VERSION_RELEASE)));
+diff --git a/src/appleseed/foundation/image/color.h b/src/appleseed/foundation/image/color.h
+index 6b97efcd8..3f288b032 100644
+--- a/src/appleseed/foundation/image/color.h
++++ b/src/appleseed/foundation/image/color.h
+@@ -40,7 +40,7 @@
+ // Imath headers.
+ #ifdef APPLESEED_ENABLE_IMATH_INTEROP
+ #include "foundation/platform/_beginexrheaders.h"
+-#include "OpenEXR/ImathColor.h"
++#include "Imath/ImathColor.h"
+ #include "foundation/platform/_endexrheaders.h"
+ #endif
+
+diff --git a/src/appleseed/foundation/math/aabb.h b/src/appleseed/foundation/math/aabb.h
+index 7d0de2e47..b3dcf65d8 100644
+--- a/src/appleseed/foundation/math/aabb.h
++++ b/src/appleseed/foundation/math/aabb.h
+@@ -37,7 +37,7 @@
+ // Imath headers.
+ #ifdef APPLESEED_ENABLE_IMATH_INTEROP
+ #include "foundation/platform/_beginexrheaders.h"
+-#include "OpenEXR/ImathBox.h"
++#include "Imath/ImathBox.h"
+ #include "foundation/platform/_endexrheaders.h"
+ #endif
+
+diff --git a/src/appleseed/foundation/math/matrix.h b/src/appleseed/foundation/math/matrix.h
+index f8b9f8f23..80441e320 100644
+--- a/src/appleseed/foundation/math/matrix.h
++++ b/src/appleseed/foundation/math/matrix.h
+@@ -44,7 +44,7 @@
+ // Imath headers.
+ #ifdef APPLESEED_ENABLE_IMATH_INTEROP
+ #include "foundation/platform/_beginexrheaders.h"
+-#include "OpenEXR/ImathMatrix.h"
++#include "Imath/ImathMatrix.h"
+ #include "foundation/platform/_endexrheaders.h"
+ #endif
+
+diff --git a/src/appleseed/foundation/math/quaternion.h b/src/appleseed/foundation/math/quaternion.h
+index a73f99327..8e9899c46 100644
+--- a/src/appleseed/foundation/math/quaternion.h
++++ b/src/appleseed/foundation/math/quaternion.h
+@@ -37,7 +37,7 @@
+ // Imath headers.
+ #ifdef APPLESEED_ENABLE_IMATH_INTEROP
+ #include "foundation/platform/_beginexrheaders.h"
+-#include "OpenEXR/ImathQuat.h"
++#include "Imath/ImathQuat.h"
+ #include "foundation/platform/_endexrheaders.h"
+ #endif
+
+diff --git a/src/appleseed/foundation/math/vector.h b/src/appleseed/foundation/math/vector.h
+index 8eca71fcf..f67de5e49 100644
+--- a/src/appleseed/foundation/math/vector.h
++++ b/src/appleseed/foundation/math/vector.h
+@@ -36,7 +36,7 @@
+ // Imath headers.
+ #ifdef APPLESEED_ENABLE_IMATH_INTEROP
+ #include "foundation/platform/_beginexrheaders.h"
+-#include "OpenEXR/ImathVec.h"
++#include "Imath/ImathVec.h"
+ #include "foundation/platform/_endexrheaders.h"
+ #endif
+
+diff --git a/src/appleseed/foundation/meta/tests/test_aabb.cpp b/src/appleseed/foundation/meta/tests/test_aabb.cpp
+index 54547752e..3ece33e18 100644
+--- a/src/appleseed/foundation/meta/tests/test_aabb.cpp
++++ b/src/appleseed/foundation/meta/tests/test_aabb.cpp
+@@ -36,7 +36,7 @@
+ // Imath headers.
+ #ifdef APPLESEED_ENABLE_IMATH_INTEROP
+ #include "foundation/platform/_beginexrheaders.h"
+-#include "OpenEXR/ImathBox.h"
++#include "Imath/ImathBox.h"
+ #include "foundation/platform/_endexrheaders.h"
+ #endif
+
+diff --git a/src/appleseed/foundation/meta/tests/test_color.cpp b/src/appleseed/foundation/meta/tests/test_color.cpp
+index d47fdfcdf..23ff5bff6 100644
+--- a/src/appleseed/foundation/meta/tests/test_color.cpp
++++ b/src/appleseed/foundation/meta/tests/test_color.cpp
+@@ -36,7 +36,7 @@
+ // Imath headers.
+ #ifdef APPLESEED_ENABLE_IMATH_INTEROP
+ #include "foundation/platform/_beginexrheaders.h"
+-#include "OpenEXR/ImathColor.h"
++#include "Imath/ImathColor.h"
+ #include "foundation/platform/_endexrheaders.h"
+ #endif
+
+diff --git a/src/appleseed/foundation/meta/tests/test_half.cpp b/src/appleseed/foundation/meta/tests/test_half.cpp
+index 523dfd97b..418819cf9 100644
+--- a/src/appleseed/foundation/meta/tests/test_half.cpp
++++ b/src/appleseed/foundation/meta/tests/test_half.cpp
+@@ -33,7 +33,7 @@
+
+ // OpenEXR headers.
+ #include "foundation/platform/_beginexrheaders.h"
+-#include "OpenEXR/half.h"
++#include "Imath/half.h"
+ #include "foundation/platform/_endexrheaders.h"
+
+ // Standard headers.
+diff --git a/src/appleseed/foundation/meta/tests/test_matrix.cpp b/src/appleseed/foundation/meta/tests/test_matrix.cpp
+index 72afb2a54..46f429712 100644
+--- a/src/appleseed/foundation/meta/tests/test_matrix.cpp
++++ b/src/appleseed/foundation/meta/tests/test_matrix.cpp
+@@ -38,7 +38,7 @@
+ // Imath headers.
+ #ifdef APPLESEED_ENABLE_IMATH_INTEROP
+ #include "foundation/platform/_beginexrheaders.h"
+-#include "OpenEXR/ImathMatrix.h"
++#include "Imath/ImathMatrix.h"
+ #include "foundation/platform/_endexrheaders.h"
+ #endif
+
+diff --git a/src/appleseed/foundation/meta/tests/test_quaternion.cpp b/src/appleseed/foundation/meta/tests/test_quaternion.cpp
+index 7ea991f8f..cf42002bf 100644
+--- a/src/appleseed/foundation/meta/tests/test_quaternion.cpp
++++ b/src/appleseed/foundation/meta/tests/test_quaternion.cpp
+@@ -38,8 +38,8 @@
+ // Imath headers.
+ #ifdef APPLESEED_ENABLE_IMATH_INTEROP
+ #include "foundation/platform/_beginexrheaders.h"
+-#include "OpenEXR/ImathQuat.h"
+-#include "OpenEXR/ImathVec.h"
++#include "Imath/ImathQuat.h"
++#include "Imath/ImathVec.h"
+ #include "foundation/platform/_endexrheaders.h"
+ #endif
+
+diff --git a/src/appleseed/foundation/meta/tests/test_vector.cpp b/src/appleseed/foundation/meta/tests/test_vector.cpp
+index 3904f37fd..6bf0b25d1 100644
+--- a/src/appleseed/foundation/meta/tests/test_vector.cpp
++++ b/src/appleseed/foundation/meta/tests/test_vector.cpp
+@@ -35,7 +35,7 @@
+ // Imath headers.
+ #ifdef APPLESEED_ENABLE_IMATH_INTEROP
+ #include "foundation/platform/_beginexrheaders.h"
+-#include "OpenEXR/ImathVec.h"
++#include "Imath/ImathVec.h"
+ #include "foundation/platform/_endexrheaders.h"
+ #endif
+
+diff --git a/src/thirdparty/bcd/bcd/ImageIO.cpp b/src/thirdparty/bcd/bcd/ImageIO.cpp
+index afb350ca6..62721f39b 100644
+--- a/src/thirdparty/bcd/bcd/ImageIO.cpp
++++ b/src/thirdparty/bcd/bcd/ImageIO.cpp
+@@ -13,6 +13,7 @@
+ // BCD headers.
+ #include "DeepImage.h"
+ #include "ImageIO.h"
++#include "ImfHeader.h"
+
+ // OpenEXR headers.
+ #if defined _MSC_VER