summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2019-05-23 09:44:37 +0100
committerGrey Christoforo2019-05-23 09:46:26 +0100
commit529bc8149a2d0dc993064266dd58a6e0669030b4 (patch)
treee22eda0db0a080b22521fb792b48c38c4c81252a
downloadaur-529bc8149a2d0dc993064266dd58a6e0669030b4.tar.gz
initial commit
add srcinfo
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD27
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..880cb6d8c42c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-epics
+ pkgdesc = Python interface to Epics Channel Access
+ pkgver = 3.3.3
+ pkgrel = 1
+ url = http://pyepics.github.io/pyepics/
+ arch = any
+ license = custom
+ makedepends = python-setuptools
+ depends = python
+ depends = python-numpy
+ depends = epics-base
+ source = https://github.com/pyepics/pyepics/archive/3.3.3.tar.gz
+ sha256sums = 0ec2006a932246dd58b44f2ce122b70ca7c44f63ef2722aa59246cf2ea0f63e1
+
+pkgname = python-epics
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72a3ed3fe6e0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.tar*
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..254c1aaaf7bb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
+
+pkgname=python-epics
+_pkgname=pyepics
+pkgver=3.3.3
+pkgrel=1
+pkgdesc="Python interface to Epics Channel Access "
+arch=('any')
+url=http://pyepics.github.io/pyepics/
+license=('custom')
+depends=('python' 'python-numpy' 'epics-base')
+makedepends=('python-setuptools')
+source=("https://github.com/pyepics/${_pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('0ec2006a932246dd58b44f2ce122b70ca7c44f63ef2722aa59246cf2ea0f63e1')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py build
+}
+
+
+package(){
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:ts=2:sw=2:et: