summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryustin2023-04-18 23:08:12 +0200
committeryustin2023-04-18 23:08:12 +0200
commit529e04b15fb8ef072f8e3180f79bce5313d5140d (patch)
tree641be76dc7018a991328507c3be2500e28bfe12b
parent4d8eecb16eef064d5e57e7666e2b2d9c5920c0a2 (diff)
downloadaur-529e04b15fb8ef072f8e3180f79bce5313d5140d.tar.gz
7.1.68-2
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD29
-rw-r--r--grep.patch64
3 files changed, 113 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad65bc340388..07f177f4befd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = radium
pkgdesc = A graphical music editor. A next generation tracker.
pkgver = 7.1.68
- pkgrel = 1
+ pkgrel = 2
url = https://users.notam02.no/~kjetism/radium
install = radium.install
arch = x86_64
@@ -14,9 +14,9 @@ pkgbase = radium
makedepends = libxinerama
makedepends = libxkbfile
makedepends = libxrandr
- makedepends = llvm11
+ makedepends = llvm
makedepends = qt5-tools
- makedepends = steinberg-vst36
+ makedepends = vst2sdk
depends = desktop-file-utils
depends = fftw
depends = glu
@@ -36,6 +36,24 @@ pkgbase = radium
depends = ttf-croscore
depends = ttf-lato
depends = libatomic_ops
+ depends = libsamplerate
+ depends = tk
+ depends = guile
+ depends = libxkbfile
+ depends = openssl
+ depends = ncurses
+ depends = gmp
+ depends = xcb-util-keysyms
+ depends = mpfr
+ depends = libmpc
+ depends = libogg
+ depends = libvorbis
+ depends = openssl
+ depends = alsa-lib
+ depends = glib2
+ depends = binutils
+ depends = xorg-util-macros
+ depends = qt5-base
optdepends = new-session-manager: for session management
optdepends = calf-ladspa: default chorus plugin used in new file templates
optdepends = ladspa-plugins: package group for plugins normally included in binary releases
@@ -46,10 +64,12 @@ pkgbase = radium
source = build_libpds.patch
source = crashreporter.patch
source = radium.install
+ source = grep.patch
sha256sums = 7054cd218bee78eea01d3c6798350e531795f1e933000a3f13f95cd4cb4a04b4
sha256sums = ed456586a1f28eec9acd081a676e61145e13f07c1a6e967c0af1f7d08be4023e
sha256sums = 2f145e84c5940f4f82544ae68e668d5bd02ee7bce559d3354f60d12eaea1a548
sha256sums = 16b0c6dc95e835fed5c7d4f350780561cd996ef723b392c415db83edba07af94
sha256sums = f627730ff7a819e8cc5ac5c2b5f1fb2f2237327db6ea5442c55a23c1ce82ef14
+ sha256sums = 7ccb4eb8c2924a5b6c610b4f35bc9ff22602cb2e131035d285bef87d813460b3
pkgname = radium
diff --git a/PKGBUILD b/PKGBUILD
index cfb94e644c70..6292488ed09e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=radium
pkgver=7.1.68
-pkgrel=1
+pkgrel=2
pkgdesc='A graphical music editor. A next generation tracker.'
arch=(x86_64)
url=https://users.notam02.no/~kjetism/radium
@@ -31,6 +31,24 @@ depends=(
ttf-croscore
ttf-lato
libatomic_ops
+ libsamplerate
+ tk
+ guile
+ libxkbfile
+ openssl
+ ncurses
+ gmp
+ xcb-util-keysyms
+ mpfr
+ libmpc
+ libogg
+ libvorbis
+ openssl
+ alsa-lib
+ glib2
+ binutils
+ xorg-util-macros
+ qt5-base
)
makedepends=(
boost
@@ -40,9 +58,9 @@ makedepends=(
libxinerama
libxkbfile
libxrandr
- llvm11
+ llvm
qt5-tools
- steinberg-vst36
+ vst2sdk
)
optdepends=(
'new-session-manager: for session management'
@@ -56,18 +74,23 @@ source=("$pkgname-$pkgver.tar.gz::https://github.com/kmatheussen/radium/archive/
build_libpds.patch
crashreporter.patch
radium.install
+ grep.patch
)
sha256sums=('7054cd218bee78eea01d3c6798350e531795f1e933000a3f13f95cd4cb4a04b4'
'ed456586a1f28eec9acd081a676e61145e13f07c1a6e967c0af1f7d08be4023e'
'2f145e84c5940f4f82544ae68e668d5bd02ee7bce559d3354f60d12eaea1a548'
'16b0c6dc95e835fed5c7d4f350780561cd996ef723b392c415db83edba07af94'
'f627730ff7a819e8cc5ac5c2b5f1fb2f2237327db6ea5442c55a23c1ce82ef14'
+ '7ccb4eb8c2924a5b6c610b4f35bc9ff22602cb2e131035d285bef87d813460b3'
)
install=radium.install
prepare() {
cd radium-$pkgver
+ #sed "/grep [^\-]*\\\ /s/grep \([^\]*\)\\\ \([^ ]*\)/grep \"\1 \2\"/p" -i check_dependencies.sh
+ patch -p0 < "$srcdir/grep.patch"
+
# Add VST2SDK env var so we can use VST2 headers from steinberg-vst36 in AUR
patch -p1 < "$srcdir/add-vstsdk-location-var.patch"
diff --git a/grep.patch b/grep.patch
new file mode 100644
index 000000000000..2f66ed60df8f
--- /dev/null
+++ b/grep.patch
@@ -0,0 +1,64 @@
+--- check_dependencies.sh.orig 2023-01-22 17:00:46.339891749 +0100
++++ check_dependencies.sh 2023-01-22 20:25:11.527264810 +0100
+@@ -52,13 +52,13 @@
+ exit 5
+ fi
+
+- if $MOC -v 2>&1 |grep Qt\ 3 ; then
++ if $MOC -v 2>&1 |grep "Qt 3" ; then
+ echo $MOC "is for QT3. Need moc for QT$RADIUM_QT_VERSION. Make sure MOC is set correctly in the Makefile."
+ echo
+ exit 5
+ fi
+
+- if $UIC -v 2>&1 |grep Qt\ 3 ; then
++ if $UIC -v 2>&1 |grep "Qt 3" ; then
+ echo $UIC "is for QT3. Need uic for QT$RADIUM_QT_VERSION. Make sure UIC is set correctly in the Makefile."
+ echo
+ exit 5
+@@ -72,7 +72,7 @@
+ if [[ "$line" == \#* ]] ; then
+ true
+ else
+- if echo "$line" | grep -e "\ \*" ; then
++ if echo "$line" | grep -e " \*" ; then
+ echo "This line in api/protos.conf is wrongly formatted. Must use \"<type>*\", not \"<type> *\""
+ echo
+ exit 5
+@@ -81,31 +81,31 @@
+ done < "$input"
+
+
+-if grep int\ seqblockid api/protos.conf ; then
++if grep "int seqblockid" api/protos.conf ; then
+ echo "The above line(s) in api/protos.conf is/are wrong. seqblock id is 64 bit"
+ echo
+ exit 5
+ fi
+
+-if grep int\ seqblock_id api/protos.conf ; then
++if grep "int seqblock_id" api/protos.conf ; then
+ echo "The above line(s) in api/protos.conf is/are wrong. seqblock id is 64 bit"
+ echo
+ exit 5
+ fi
+
+-if grep int\ instrument_id api/protos.conf ; then
++if grep "int instrument_id" api/protos.conf ; then
+ echo "The above line(s) in api/protos.conf is/are wrong. instrument id is 64 bit"
+ echo
+ exit 5
+ fi
+
+-if grep int\ guinum api/protos.conf ; then
++if grep "int guinum" api/protos.conf ; then
+ echo "The above line(s) in api/protos.conf is/are wrong. guinum is 64 bit"
+ echo
+ exit 5
+ fi
+
+-if grep int\ id api/protos.conf ; then
++if grep "int id" api/protos.conf ; then
+ echo "The above line(s) in api/protos.conf is/are wrong. id has so far been 64 bit"
+ echo
+ exit 5