summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLetu Ren2023-10-11 10:24:19 +0800
committerLetu Ren2023-10-11 10:24:19 +0800
commit529f3f05ad3321cedae868bc0910c3a187ac1f64 (patch)
treec17a6966d26620517c6125c7140721768fab0762
parentcb1b40038371114edba947360c379b6492164e7d (diff)
downloadaur-529f3f05ad3321cedae868bc0910c3a187ac1f64.tar.gz
provide bazel
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c0ba37ba716..bdaedc2f8fe8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = bazelisk-bin
pkgdesc = A user-friendly launcher for Bazel
pkgver = 1.18.0
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/bazelbuild/bazelisk
arch = x86_64
license = Apache
- provides = bazelisk
+ provides = bazel
+ conflicts = bazel
conflicts = bazelisk
source = bazelisk-linux-amd64-1.18.0::https://github.com/bazelbuild/bazelisk/releases/download/v1.18.0/bazelisk-linux-amd64
sha256sums = ce52caa51ef9e509fb6b7e5ad892e5cf10feb0794b0aed4d2f36adb00a1a2779
diff --git a/PKGBUILD b/PKGBUILD
index 4632f2ebd828..fd0b27794f70 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,15 @@
pkgname=bazelisk-bin
pkgver=1.18.0
-pkgrel=4
+pkgrel=5
pkgdesc='A user-friendly launcher for Bazel'
arch=('x86_64')
url='https://github.com/bazelbuild/bazelisk'
license=('Apache')
-provides=('bazelisk')
-conflicts=('bazelisk')
+# https://github.com/bazelbuild/bazelisk#installation
+# We should add both `bazelisk` and `bazel` to PATH
+provides=('bazel')
+conflicts=('bazel' 'bazelisk')
source=(
"bazelisk-linux-amd64-${pkgver}::https://github.com/bazelbuild/bazelisk/releases/download/v${pkgver}/bazelisk-linux-amd64"
)
@@ -17,5 +19,6 @@ sha256sums=('ce52caa51ef9e509fb6b7e5ad892e5cf10feb0794b0aed4d2f36adb00a1a2779')
package() {
install -Dm755 "${srcdir}/bazelisk-linux-amd64-${pkgver}" "${pkgdir}/usr/bin/bazelisk"
+ ln -s /usr/bin/bazelisk "${pkgdir}/usr/bin/bazel"
}