summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Murino2023-01-18 18:02:22 +0100
committerNicola Murino2023-01-18 18:02:22 +0100
commit52d4e4c20c1cd9e8a6492ba2332a5494cab7ee70 (patch)
treea3823f7afb61ef8ab71b3f948f04d1d6e18d5649
parent43db4b8f1e92cfc1a2fa6cbcc6ecc8c9737d4425 (diff)
downloadaur-52d4e4c20c1cd9e8a6492ba2332a5494cab7ee70.tar.gz
Update to 0.21.2
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD33
-rw-r--r--c47cf796.patch29
3 files changed, 49 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 62b9a4b92416..e042b853553d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-libpsl
pkgdesc = Public Suffix List library (mingw-w64)
- pkgver = 0.21.1
- pkgrel = 3
+ pkgver = 0.21.2
+ pkgrel = 1
url = https://github.com/rockdaboot/libpsl
arch = any
license = MIT
@@ -10,7 +10,9 @@ pkgbase = mingw-w64-libpsl
makedepends = gtk-doc
depends = mingw-w64-libidn2
depends = mingw-w64-libunistring
- source = https://github.com/rockdaboot/libpsl/releases/download/0.21.1/libpsl-0.21.1.tar.gz
- sha512sums = a5084b9df4ff2a0b1f5074b20972efe0da846473396d27b57967c7f6aa190ab3c910b4bfc4f8f03802f08decbbad5820d850c36ad59610262ae37fe77de0c7f5
+ source = https://github.com/rockdaboot/libpsl/releases/download/0.21.2/libpsl-0.21.2.tar.gz
+ source = c47cf796.patch
+ sha512sums = f1df72220bf4391d4701007100b0df66c833a2cbcb7481c9d13f0b9e0cad3b66d2d15d4b976e5bad60d2ad1540355112fa1acb07aa925c241d2d7cd20681c71d
+ sha512sums = a9b82a88c51abe86f10e65104b86afd345d992389fdbc4a7a71df632e2a3a1eb24f831103325e0d65205d081b9f6402864100a8f9b9b173e09e86f9d505f3355
pkgname = mingw-w64-libpsl
diff --git a/PKGBUILD b/PKGBUILD
index 6f7111767895..d07a3fc224d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,47 +2,42 @@
pkgname=mingw-w64-libpsl
_pkgname=libpsl
-pkgver=0.21.1
-pkgrel=3
+pkgver=0.21.2
+pkgrel=1
pkgdesc='Public Suffix List library (mingw-w64)'
url='https://github.com/rockdaboot/libpsl'
arch=(any)
license=('MIT')
depends=('mingw-w64-libidn2' 'mingw-w64-libunistring')
makedepends=('mingw-w64-configure' 'python' 'gtk-doc')
-source=(https://github.com/rockdaboot/libpsl/releases/download/${pkgver}/${_pkgname}-${pkgver}.tar.gz)
-sha512sums=('a5084b9df4ff2a0b1f5074b20972efe0da846473396d27b57967c7f6aa190ab3c910b4bfc4f8f03802f08decbbad5820d850c36ad59610262ae37fe77de0c7f5')
+source=(https://github.com/rockdaboot/libpsl/releases/download/${pkgver}/${_pkgname}-${pkgver}.tar.gz
+ c47cf796.patch)
+sha512sums=('f1df72220bf4391d4701007100b0df66c833a2cbcb7481c9d13f0b9e0cad3b66d2d15d4b976e5bad60d2ad1540355112fa1acb07aa925c241d2d7cd20681c71d'
+ 'a9b82a88c51abe86f10e65104b86afd345d992389fdbc4a7a71df632e2a3a1eb24f831103325e0d65205d081b9f6402864100a8f9b9b173e09e86f9d505f3355')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
cd "${srcdir}/${_pkgname}-${pkgver}"
- autoreconf -fiv
+ patch -p1 -i ${srcdir}/c47cf796.patch
}
build() {
- unset LDFLAGS
cd "${srcdir}/${_pkgname}-${pkgver}"
for _arch in ${_architectures}; do
- mkdir -p build-${_arch} && pushd build-${_arch}
- ${_arch}-configure \
- --disable-gtk-doc \
- --disable-gtk-doc-html \
- --disable-man \
- --enable-{builtin,runtime}=libidn2 \
- ..
- LC_CTYPE=en_US.UTF-8 make
+ mkdir -p "build-${_arch}" && pushd build-${_arch}
+ ${_arch}-meson \
+ -D docs=false \
+ -D runtime=libidn2 ..
+ ninja
popd
done
}
package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
for _arch in ${_architectures}; do
- cd "${srcdir}/${_pkgname}-${pkgver}/build-${_arch}"
- make DESTDIR="${pkgdir}" install
- find "$pkgdir/usr/${_arch}" -name '*.exe' -exec ${_arch}-strip --strip-all {} \;
- find "$pkgdir/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
- find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' -exec ${_arch}-strip -g {} \;
+ DESTDIR="${pkgdir}" ninja -C "${srcdir}/${_pkgname}-${pkgver}/build-${_arch}" install
if [[ $NO_EXECUTABLES ]]; then
find "$pkgdir/usr/${_arch}" -name '*.exe' -delete
fi
diff --git a/c47cf796.patch b/c47cf796.patch
new file mode 100644
index 000000000000..4ad9f935ad61
--- /dev/null
+++ b/c47cf796.patch
@@ -0,0 +1,29 @@
+From c47cf796fcf98641cb34929d17de041b26c54447 Mon Sep 17 00:00:00 2001
+From: Chun-wei Fan <fanc999@yahoo.com.tw>
+Date: Tue, 27 Dec 2022 12:57:04 +0800
+Subject: [PATCH] tools/psl.c: Fix build on Windows
+
+localtime_r() is not available on Windows but a more-secure variant
+of localtime(), localtime_s() is provided on Windows.
+
+Define localtime_r() on Windows as its arguments are reversed as compared
+to localetime_s(), to achive more or less the same purpose.
+---
+ tools/psl.c | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/tools/psl.c b/tools/psl.c
+index 95d8b65..054d0b6 100644
+--- a/tools/psl.c
++++ b/tools/psl.c
+@@ -38,6 +38,10 @@
+
+ #ifdef _WIN32
+ # include <winsock2.h> // WSAStartup, WSACleanup
++
++// Windows does not have localtime_r but has localtime_s, which is more or less
++// the same except that the arguments are reversed
++# define localtime_r(t_sec,t_now) localtime_s(t_now,t_sec)
+ #endif
+
+ #include <stdlib.h>