summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrealgagu2018-10-04 13:17:12 -0500
committerfrealgagu2018-10-04 13:17:12 -0500
commit52eb91969f8896bf3d67e0b0e735656d229892d4 (patch)
tree657eefb6468e2276af4f86879292a367b4f2f87a
parent1a54ad3cd13cd6248ca6040367082745f6baf8e0 (diff)
downloadaur-52eb91969f8896bf3d67e0b0e735656d229892d4.tar.gz
Upgrading to version 2.24. Using juliagoda repository.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD34
-rw-r--r--antimicro.patch12
3 files changed, 38 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ced28226a1c..7acb79efbc3f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,24 @@
pkgbase = antimicro
pkgdesc = Graphical program used to map keyboard keys and mouse controls to a gamepad
- pkgver = 2.23
- pkgrel = 3
- url = https://github.com/AntiMicro/antimicro
+ pkgver = 2.24
+ pkgrel = 1
+ url = https://github.com/juliagoda/antimicro
arch = i686
arch = x86_64
license = GPL3
makedepends = cmake
+ makedepends = extra-cmake-modules
makedepends = gettext
makedepends = itstool
makedepends = qt5-tools
+ depends = desktop-file-utils
depends = libxtst
depends = qt5-base
depends = sdl2
- source = antimicro-2.23.tar.gz::https://github.com/AntiMicro/antimicro/archive/2.23.tar.gz
- sha256sums = ef309170612da805992f9194f1973bf38a3174a0856856afedab67f9d927a9ef
+ source = antimicro-2.24.tar.gz::https://github.com/juliagoda/antimicro/archive/2.24.tar.gz
+ source = antimicro.patch
+ sha256sums = 220edefd7b2f2dadd9f52d8160aae30976d182dd88db7f2a4f751453a1ec85d9
+ sha256sums = 6609845ef9a2a856be141e9c1bbe4c5adf00e1c9a965f46a765f22b3fc4e231d
pkgname = antimicro
diff --git a/PKGBUILD b/PKGBUILD
index 9728e865e9ec..d947a49a4380 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,31 @@
-# Maintainer: grimi <grimi at poczta dot fm>
# Maintainer: Fredy GarcĂ­a <frealgagu at gmail dot com>
-# Maintainer: Thomas Nordenmark <t.nordenmark@gmail.com>
-# Developer: Travis Nickles <nickles.travis@gmail.com>
+# Contributor: grimi <grimi at poczta dot fm>
+# Contributor: Thomas Nordenmark <t.nordenmark@gmail.com>
+# Contributor: Travis Nickles <nickles.travis@gmail.com>
pkgname=antimicro
-pkgver=2.23
-pkgrel=3
+pkgver=2.24
+pkgrel=1
pkgdesc="Graphical program used to map keyboard keys and mouse controls to a gamepad"
arch=("i686" "x86_64")
-url="https://github.com/AntiMicro/${pkgname}"
+url="https://github.com/juliagoda/${pkgname}"
license=("GPL3")
-depends=("libxtst" "qt5-base" "sdl2")
-makedepends=("cmake" "gettext" "itstool" "qt5-tools")
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/AntiMicro/${pkgname}/archive/${pkgver}.tar.gz")
-sha256sums=("ef309170612da805992f9194f1973bf38a3174a0856856afedab67f9d927a9ef")
+depends=("desktop-file-utils" "libxtst" "qt5-base" "sdl2")
+makedepends=("cmake" "extra-cmake-modules" "gettext" "itstool" "qt5-tools")
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/juliagoda/${pkgname}/archive/${pkgver}.tar.gz"
+ "${pkgname}.patch")
+sha256sums=("220edefd7b2f2dadd9f52d8160aae30976d182dd88db7f2a4f751453a1ec85d9"
+ "6609845ef9a2a856be141e9c1bbe4c5adf00e1c9a965f46a765f22b3fc4e231d")
prepare() {
- #Using fix suggested by rakuco by deleting lines with QT5_WRAP_CPP
- #https://github.com/AntiMicro/antimicro/pull/207/files
- sed -i "/QT5_WRAP_CPP/d" "${pkgname}-${pkgver}/CMakeLists.txt"
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -Np1 -i "../${pkgname}.patch"
}
build() {
- mkdir -p "${pkgname}-${pkgver}/build"
- cd "${pkgname}-${pkgver}/build"
+ cd "${srcdir}/${pkgname}-${pkgver}"
- cmake .. \
+ cmake \
-DCMAKE_INSTALL_PREFIX=/usr \
-DUSE_SDL_2=ON \
-DWITH_XTEST=ON \
@@ -35,7 +35,7 @@ build() {
}
package() {
- cd "${pkgname}-${pkgver}/build"
+ cd "${srcdir}/${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
}
diff --git a/antimicro.patch b/antimicro.patch
new file mode 100644
index 000000000000..8461a3fff1be
--- /dev/null
+++ b/antimicro.patch
@@ -0,0 +1,12 @@
+diff -Naur a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt 2018-06-15 12:14:52.000000000 -0500
++++ b/CMakeLists.txt 2018-10-04 13:00:34.093959019 -0500
+@@ -45,7 +45,7 @@
+
+ if(COMPILER_SUPPORTS_CXX11)
+ if (NOT WIN32)
+- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fvisibility=hidden -fvisibility-inlines-hidden -Werror -Wall -Wextra -Wno-unused-parameter -Wunused-function -Wunused-label -Wunused-value -Wunused-variable -Wunused-but-set-parameter -pedantic -Wno-reorder -std=c++11")
++ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fvisibility=hidden -fvisibility-inlines-hidden -Wall -Wextra -Wno-unused-parameter -Wunused-function -Wunused-label -Wunused-value -Wunused-variable -Wunused-but-set-parameter -pedantic -Wno-reorder -std=c++11")
+ else()
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
+ endif()