summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Hayot2023-11-28 11:03:53 +0100
committerGuillaume Hayot2023-11-28 11:03:53 +0100
commit530a5563699a4a9a7cef6132cf393fca78de3e38 (patch)
treed2092c45efc971bd9145360d48508f134705e268
parentc16228708f8acff6dcafbc669f7499763c9e5f17 (diff)
downloadaur-530a5563699a4a9a7cef6132cf393fca78de3e38.tar.gz
v4.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 359740e2b530..6dadf529d6c6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = parlatype
pkgdesc = GNOME audio player for transcription
- pkgver = 3.1
- pkgrel = 2
+ pkgver = 4.0
+ pkgrel = 1
url = https://github.com/gkarsay/parlatype
arch = any
license = GPL3
@@ -19,7 +19,7 @@ pkgbase = parlatype
depends = gst-plugins-good
depends = iso-codes
optdepends = parlatype-libreoffice-extension: LibreOffice macros
- source = https://github.com/gkarsay/parlatype/releases/download/v3.1/parlatype-3.1.tar.gz
- b2sums = 7227a7b725f0bdae75ecf30cbc6fd06085ece95be1c73fb8019cb66ca00e9c8a3fa31e99ff38869045cedcc7871a7fa23bb4cbbcb442d143d85ecab3407d038c
+ source = https://github.com/gkarsay/parlatype/releases/download/v4.0/parlatype-4.0.tar.gz
+ b2sums = 9b32fb34977edd07d2b14891c8466163998820d6ac547e4727f9aef2beb67258417b9164c918e2c18f7ddb05017babfaca296b223a51c4f690c1f1df0b84a84b
pkgname = parlatype
diff --git a/PKGBUILD b/PKGBUILD
index c7549a426fb8..1e2c012dfa17 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
# Maintainer: Guillaume Hayot <ghayot@postblue.info>
pkgname=parlatype
-pkgver=3.1
-pkgrel=2
+pkgver=4.0
+pkgrel=1
pkgdesc="GNOME audio player for transcription"
arch=('any')
url="https://github.com/gkarsay/parlatype"
license=('GPL3')
depends=('gtk3' 'gstreamer' 'gst-plugins-base' 'gst-plugins-good' 'iso-codes')
-makedepends=('appstream' 'appstream-glib' 'meson' 'gettext' 'gobject-introspection' 'yelp-tools' 'desktop-file-utils' 'gtk-doc')
+makedepends=('appstream' 'appstream-glib' 'meson' 'gettext' 'gobject-introspection' 'yelp-tools' 'desktop-file-utils' 'gtk-doc' 'cmake') # add pocketsphinx and/or deepspeech if needed
optdepends=('parlatype-libreoffice-extension: LibreOffice macros')
source=("https://github.com/gkarsay/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz")
-b2sums=('7227a7b725f0bdae75ecf30cbc6fd06085ece95be1c73fb8019cb66ca00e9c8a3fa31e99ff38869045cedcc7871a7fa23bb4cbbcb442d143d85ecab3407d038c')
+b2sums=('9b32fb34977edd07d2b14891c8466163998820d6ac547e4727f9aef2beb67258417b9164c918e2c18f7ddb05017babfaca296b223a51c4f690c1f1df0b84a84b')
build() {
cd "$pkgname-$pkgver"
- arch-meson build -Dgir=true -Dgtk-doc=true
+ arch-meson build -Dgir=true -Dgtk-doc=true # add -Dpocketsphinx=true and/or -Ddeepspeech=true if needed
cd build
ninja
}