summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatheus Gabriel Werny de Lima2021-05-22 13:15:00 +0200
committerMatheus Gabriel Werny de Lima2021-05-22 13:15:00 +0200
commit5362414b3582db1afa8a9b3528ba63f034ec8634 (patch)
treefafff5e74f6b8147fe2e06052e0c77da24c196d6
parentd246672d1b2728aff677b9d3872dc36d4e35de76 (diff)
downloadaur-5362414b3582db1afa8a9b3528ba63f034ec8634.tar.gz
Changed the executable.
-rwxr-xr-xPKGBUILD7
1 files changed, 2 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d5c43ce40dad..4ff290ccb621 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -75,15 +75,12 @@ package()
mkdir -p "${pkgdir}"/usr/share/doc/"${_pkgname}"/
mkdir -p "${pkgdir}"/usr/share/licenses/"${_pkgname}"/
- # Modify run.sh to state the absolute path of the .csproj.
- echo -e "#!/bin/bash
-dotnet run --no-launch-profile --no-build -c Release -p \"/usr/share/\"${_pkgname}\"/NBXplorer/NBXplorer.csproj\" -- \"\${@}\"" > "${srcdir}"/"${_pkgname}"/run.sh
-
# Install the software.
cp -r "${srcdir}"/"${_pkgname}"/ "${pkgdir}"/usr/share/
## Create an executable.
- ln -sfrT "${pkgdir}"/usr/share/"${_pkgname}"/run.sh "${pkgdir}"/usr/bin/"${_pkgname_lc}"
+ echo -e "#!/bin/bash
+dotnet run --no-launch-profile --no-build -c Release -p \"/usr/share/\"${_pkgname}\"/NBXplorer/NBXplorer.csproj\" -- \"\${@}\"" > "${pkgdir}"/usr/bin/"${_pkgname_lc}"
chmod 755 "${pkgdir}"/usr/bin/"${_pkgname_lc}"
# Install the documentation.