summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXenGi2018-02-19 06:07:53 +0100
committerXenGi2018-02-19 06:07:53 +0100
commit536301cfaa5611733f9c1566aeb5f4e58c9c12e3 (patch)
treecf40eba49c77cfae381bad8ef37b07ac53defe1d
parenta5ae75e26353ecaaf2582603073d93cd994d75dc (diff)
downloadaur-536301cfaa5611733f9c1566aeb5f4e58c9c12e3.tar.gz
changed pokeapi urls to https
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
-rw-r--r--pokeshell.install4
3 files changed, 6 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e40c6b8ae9e4..a45d7cc2d6b3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,7 @@
-# Generated by mksrcinfo v8
-# Tue Jul 26 21:12:37 UTC 2016
pkgbase = pokeshell
pkgdesc = Displays pokemons in your shell
pkgver = 1.0.0
- pkgrel = 4
- url = https://github.com/XenGi/pokeshell
+ pkgrel = 5
install = pokeshell.install
arch = any
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 9ee1f7386862..0eb1ca28f825 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,25 +4,23 @@ _maxwidth=80
_maxheight=22
_firstpokemon=1
_lastpokemon=151
+
pkgname=pokeshell
pkgver=1.0.0
-pkgrel=4
+pkgrel=5
pkgdesc="Displays pokemons in your shell"
arch=(any)
-url="https://github.com/XenGi/pokeshell"
license=('MIT')
makedepends=('curl' 'imagemagick' 'img2xterm')
options=(!emptydirs)
install='pokeshell.install'
-#source=("https://github.com/rossy/$pkgname/archive/v$pkgver.tar.gz")
-#sha256sums=('')
build() {
cd "$srcdir/"
for _i in `seq $_firstpokemon 1 $_lastpokemon` ; do
printf "Generating Pokemon #$_i"
# download pokemon image
- curl -s http://pokeapi.co/media/img/$_i.png -o $_i.png
+ curl -s https://pokeapi.co/media/img/$_i.png -o $_i.png
printf "."
# trim image
convert $_i.png -trim -resize ${_maxwidth}x$(($_maxheight * 2))\> $_i.png
diff --git a/pokeshell.install b/pokeshell.install
index ed481d21e3e7..73d1f534dce1 100644
--- a/pokeshell.install
+++ b/pokeshell.install
@@ -3,7 +3,7 @@ post_install() {
echo ""
echo "cat /usr/share/pokeshell/\$((\$RANDOM % 151 + 1)).pokemon"
echo ""
- echo "For fish shell you can add this function to your ~/.config/fish/functions/fish_prompt.fish:"
+ echo "For fish shell you customize your greeting function by changing ~/.config/fish/functions/fish_prompt.fish:"
echo ""
echo "function fish_greeting"
echo " set r (random)"
@@ -16,7 +16,7 @@ post_upgrade() {
echo ""
echo "cat /usr/share/pokeshell/\$((\$RANDOM % 151 + 1)).pokemon"
echo ""
- echo "For fish shell you can add this function to your ~/.config/fish/functions/fish_prompt.fish:"
+ echo "For fish shell you customize your greeting function by changing ~/.config/fish/functions/fish_prompt.fish:"
echo ""
echo "function fish_greeting"
echo " set r (random)"